 API browser of pushAdminMessage500 COM module
Interface version: | 5.00
Interface date: | 27 Nov 2024

The PushAdminMessageManager is an ATL COM module which provides methods to generate administrative messages like the starting or ending of a treatment. Such an administrative message is printed or a XML infoset is produced and pushed electronically to a recipient. In the latter case the info object optionally can be signed and/or encrypted. It is a design goal to keep the message parsing system minimal regarding the underlying XSD standard and thus to guarantee a very low-threshold and agile implementation. |  | space
Interfaces |  | 4 interface
IAddress | The utility interface IAddress is available for setting and retrieving structured address data. |
IPushAdminMessageManager | The main interface IPushAdminMessageManager -creatable in its own right- provides methods for generating and pushing administrative messages. Furthermore, created XML infosets can be loaded back into memory for further processing. |
IPushAdminMessageRequest | With the IPushAdminMessageRequest interface all administrative message related data can be set/defined by the interface's methods. |
IPushAdminMessageResult | The interface IPushAdminMessageResult allows to read back all data that have been defined with the IPushAdminMessageRequest interface or by loading a previously generated XML infoset. |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important documents about the usage and handling |  |
Document | General usage of the pushAdminMessage COM module - an overview |
Document | VB code snippet for using the pushAdminMessage COM module |
Document | Syntax of the printTemplate variable of the Print method |
Document | How to generate a PDF archive file of a pushAdminMessage request |
Document | How to print electronic stamps onto a pushAdminMessage request |
Document | pushAdminMessageManagerServer500: Introduction, overview and usage of the Restful Webservice Server |

© by sumex1.net - all rights reserved


  • pushAdminMessage500
  • IAddress

IAddress interface |  | V5.00/27 Nov 2024
With the IAddress interface structured address data can be set and retrieved. The whole address can be seen as a collection of substructures like the name, the postal part, a communication part etc. Where each of these sub structure can be set or retrieved by an interface method. The name part of a person is set by the method SetPerson and a company's name is entered by the method SetCompany. Before setting a new address the internal data has to be initialized by the method Initialize. |  | space
space
Methods |  | 13 methods
AddPhone | Adds a structured phone number |
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetCompany | Retrieves the company's naming part of the address |
GetFirstPhone | Retrieves the first phone number information |
GetNextPhone | Retrieves the next phone number information |
GetOnline | Retrieves the structured online part of the address |
GetPerson | Retrieves the person's naming part of the address |
GetPostal | Retrieves the structured postal address part of the address. |
Initialize | Initializes all internal address variables |
SetCompany | Sets the company's naming part of the address |
SetOnline | Sets the structured online part of the address. |
SetPerson | Sets the person's naming part of the address |
SetPostal | Sets the structured postal address part |
space
Properties |  | 2 properties
[put] DestructAddress | Destructs/invalidates this IAddress interface instance |
[get] Type | GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all |
space |


  • IAddress
  • AddPhone

IAddress::AddPhone method |  |  | space
Adds a structured phone number. The Swiss international calling code +41 is filtered out in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/AddPhone
[JSON input data] | pIAddress: bstrNumber: bstrLocalCode: bstrInternationalCode: bstrExt: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrNumber | The pure phone number part of the telephone number. It is possible to set the full telephone number in this variable and leave the other parts of the telephone number empty |
[in] BSTR | bstrLocalCode | The local area code part of the telephone number. |
[in] BSTR | bstrInternationalCode | The international calling code part of the telephone number. |
[in] BSTR | bstrExt | The optional extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetAbortInfo

IAddress::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetAbortInfo
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
space |


  • IAddress
  • GetCompany

IAddress::GetCompany method |  |  | space
Retrieves the company's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetCompany
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrCompanyName: pbstrDepartment: pbstrSubaddressing: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetCompany( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrCompanyName, *pbstrDepartment, *pbstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCompanyName | The company's name. |
[out] BSTR | *pbstrDepartment | The optional department part of the company. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetFirstPhone

IAddress::GetFirstPhone method |  |  | space
Retrieves the first phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetFirstPhone
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetNextPhone

IAddress::GetNextPhone method |  |  | space
Retrieves the next phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetNextPhone
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetOnline

IAddress::GetOnline method |  |  | space
Retrieves the structured online part of the address. Empty variables are returned if there is no online information available. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetOnline
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrEMail: pbstrUrl: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetOnline( | BSTR BSTR VARIANT_BOOL | *pbstrEMail, *pbstrUrl, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEMail | A relevant email address. |
[out] BSTR | *pbstrUrl | A relevant URL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetPerson

IAddress::GetPerson method |  |  | space
Retrieves the person's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPerson
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrFamilyname: pbstrGivenname: pbstrSalutation: pbstrTitle: pbstrSubaddressing: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFamilyname, *pbstrGivenname, *pbstrSalutation, *pbstrTitle, *pbstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrFamilyname | The family name (or last name) of the person. |
[out] BSTR | *pbstrGivenname | The given name (or first name) of the person. |
[out] BSTR | *pbstrSalutation | The optional salutation of the person. |
[out] BSTR | *pbstrTitle | The optional title of the person. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetPostal

IAddress::GetPostal method |  |  | space
Retrieves the structured postal address part of the address. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPostal
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrStreet: pbstrPoBox: pbstrZip: pbstrCity: pbstrStateCode: pbstrCountry: pbstrCountryCode: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrStreet, *pbstrPoBox, *pbstrZip, *pbstrCity, *pbstrStateCode, *pbstrCountry, *pbstrCountryCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrStreet | The street name part of an address. |
[out] BSTR | *pbstrPoBox | The P.O. box code part of an address. Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[out] BSTR | *pbstrZip | The ZIP code part of an address. |
[out] BSTR | *pbstrCity | The city name of an address. |
[out] BSTR | *pbstrStateCode | The optional state code part of an address. |
[out] BSTR | *pbstrCountry | The optional bstrCountry supplies the country name of the address given |
[out] BSTR | *pbstrCountryCode | The ISO 3166-1 alpha-2 country designator (2 uppercase characters) of the address given |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • Initialize

IAddress::Initialize method |  |  | space
Initializes all internal address variables. This method should be called before new data is supplied to reset all internally stored data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/Initialize
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetCompany

IAddress::SetCompany method |  |  | space
Sets the company's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetCompany
[JSON input data] | pIAddress: bstrCompanyName: bstrDepartment: bstrSubaddressing: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetCompany( | BSTR BSTR BSTR VARIANT_BOOL | bstrCompanyName, bstrDepartment, bstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCompanyName | The company's name. |
[in] BSTR | bstrDepartment | The optional department part of the company. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetOnline

IAddress::SetOnline method |  |  | space
Sets the structured online part of the address. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetOnline
[JSON input data] | pIAddress: bstrEMail: bstrUrl: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetOnline( | BSTR BSTR VARIANT_BOOL | bstrEMail, bstrUrl, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEMail | A relevant email address. |
[in] BSTR | bstrUrl | A relevant URL address. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetPerson

IAddress::SetPerson method |  |  | space
Sets the person's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetPerson
[JSON input data] | pIAddress: bstrFamilyname: bstrGivenname: bstrSalutation: bstrTitle: bstrSubaddressing: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFamilyname, bstrGivenname, bstrSalutation, bstrTitle, bstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrFamilyname | The family name (or last name) of the person. |
[in] BSTR | bstrGivenname | The given name (or first name) of the person. |
[in] BSTR | bstrSalutation | The optional salutation of the person. |
[in] BSTR | bstrTitle | The optional title of the person. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetPostal

IAddress::SetPostal method |  |  | space
Sets the structured postal address part. The Swiss ISO county code is the default but is filtered in the printing. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetPostal
[JSON input data] | pIAddress: bstrStreet: bstrPoBox: bstrZip: bstrCity: bstrStateCode: bstrCountry: bstrCountryCode: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrStreet, bstrPoBox, bstrZip, bstrCity, bstrStateCode, bstrCountry, bstrCountryCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrStreet | The full street name of the address given |
[in] BSTR | bstrPoBox | The P.O. box code part of the address given Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[in] BSTR | bstrZip | The mandatory ZIP code of the address given |
[in] BSTR | bstrCity | The mandatory city name of the address given |
[in] BSTR | bstrStateCode | The optional state code part of the address given |
[in] BSTR | bstrCountry | The optional bstrCountry supplies the country name of the address given |
[in] BSTR | bstrCountryCode | The ISO 3166-1 alpha-2 country designator (2 uppercase characters) of the address given |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • DestructAddress

IAddress::DestructAddress property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IAddress interface instance. The counterpart property to generate an Iaddress interface instance is IPushAdminMessageRequest::GetCreateAddress. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAddress/PutDestructAddress
[JSON input data] | pIAddress: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAddress
  • Type

IAddress::Type property | space
GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all.

If no address is defined then enAddressUndefined is returned.
space
Restful webservice calling syntax
[GET] | /baseURL/ IAddress/GetType?param
[param] pIAddress= longValue
[JSON result data] peType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Type( AddressType *peType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] AddressType | *peType
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • AddressType *GetType(void);
space


  • IPushAdminMessageManager

IPushAdminMessageManager interface |  | V5.00/27 Nov 2024
The IPushAdminMessageManager interface provides all the necessary methods to produce administrative messages of type pushAdminMessage_500. Firstly, an instance of the IPushAdminMessageRequest interface is created by the GetPushAdminMessageRequest property. All the administrative data and parameters can be set by the supplied interface methods like SetPatient, SetMessage4Stationary,... After all information is defined the administrative message object is printed or a XML infoset is produced which can be electronically transported to a recipient. In the latter case the infoset optionally can be signed and/or encrypted . |  | space
space
Methods |  | 8 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetLogSettings | Get the log settings for the module. |
GetXML | The GetXML method generates the XML infoset based on the data of the IPushAdminMessageRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory |
LoadXML | Loads a previously generated XML infoset back into memory for further processing via the returned interface handles |
Print | The Print method validates the defined administrative message data and prints the request on the local printer |
PrintAdjust | Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file |
PrintSetup | Shows the printer setup dialog that allows to define the printer and its settings |
SetLogSettings | Sets the log setting preferences for the module |
space
Properties |  | 9 properties
[get] CreatePushAdminMessageManager | Creates an instance of the main IPushAdminMessageManager interface |
[put] DestructPushAdminMessageManager | Destructs/invalidates a main instance of the IPushAdminMessageManager interface |
[put] DestructPushAdminMessageRequest | Destructs/invalidates this IPushAdminMessageRequest interface instance |
[put] DestructPushAdminMessageResult | Destructs/invalidates this IPushAdminMessageResult interface instance. |
[get/put] ModuleLanguage | Get/Set the language for the module i.e |
[get] ModuleVersion | Get the version of the PushAdminMessageManager module. |
[get] ModuleVersionText | Get the version of the PushAdminMessageManager module in textual form. |
[get/put] Modus | Gets/Sets the operation modus of the module |
[get] PushAdminMessageRequest | Gets the IPushAdminMessageRequest interface instance |
space |


  • IPushAdminMessageManager
  • GetAbortInfo

IPushAdminMessageManager::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageManager/GetAbortInfo
[JSON input data] | pIPushAdminMessageManager: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
space |


  • IPushAdminMessageManager
  • GetLogSettings

IPushAdminMessageManager::GetLogSettings method | space
Get the log settings for the module.
space
Restful webservice calling syntax
[POST] | /baseURL/ IPushAdminMessageManager/GetLogSettings
[JSON input data] pIPushAdminMessageManager: longValue, //interface address
[JSON result data] plLogLevel:
plMaxSizeKB:
peDoArchive:
pbstrArchiveDir:
pbStatus: 		longValue,
longValue,
longValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] long *plLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] long | *plMaxSizeKB | The maximum size in KB of the log file.
[out] YesNoType | *peDoArchive | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] BSTR | *pbstrArchiveDir | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageManager
  • GetXML

IPushAdminMessageManager::GetXML method |  |  | space
The GetXML method generates the XML infoset based on the data of the IPushAdminMessageRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory. The full file name to this XML document is replied in the pbstrOutputFile output variable. The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down! Note about encryption: an encrypted XML infoset can not be loaded successfully by LoadXML. Therefore, to build a local archive besides encrypted XML infoset call GetXML twice once with the lXMLGenerationAttributes = enGenerateWithoutEncryption |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageManager/GetXML
[JSON input data] | pIPushAdminMessageManager: lGenerationAttributes: | longValue, //interface address longValue
[JSON result data] | pbstrOutputFile: plValidationError: plTimestamp: pbstrUsedSchema: pIPushAdminMessageResult: pbStatus: | "utf8StringValue", longValue, longValue, "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetXML( | long BSTR long long BSTR IPushAdminMessageResult VARIANT_BOOL | lGenerationAttributes, *pbstrOutputFile, *plValidationError, *plTimestamp, *pbstrUsedSchema, **pIPushAdminMessageResult, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lGenerationAttributes | This variable overrules the default behavior of the XML generation process even if the appropriate data have been defined. lGenerationAttributes is a 32-bit integer where the possible "commands" are values from the generationAttributes data type ORed together to form the overall command. This feature is necessary to generate different "flavors" of XML infosets without re-setting input data. For instance, an encrypted XML infoset for the "to" entity can be produced and in a second call the XML infoset without encryption (lGenerationAttributes=enGenerateXMLWithoutEncryption) is requested for a local archive (that can be loaded back later!). |
[out] BSTR | *pbstrOutputFile | The full file name (path + name) where the XML infoset is stored in UTF-8 mode. The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down! In Restful Webservice output: pbstrOutputFile is a releative URL which must be downloaded in a subsequent GET process. |
[out] long | *plValidationError | lValidationError is filled with the validation error code returned by the MSXML DOM parser. A zero value indicates that the validation was successful. |
[out] long | *plTimestamp | The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on. |
[out] BSTR | *pbstrUsedSchema | The full XSD name that was used to generate the XML infoset. In a standard situation this would be pushAdminMessage_500.xsd. |
[out] IPushAdminMessageResult | **pIPushAdminMessageResult | The instance of a IPushAdminMessageResult interface allows to read all loaded data back. The handle is NULL if an error occurred. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageManager
  • LoadXML

IPushAdminMessageManager::LoadXML method |  |  | space
Loads a previously generated XML infoset back into memory for further processing via the returned interface handles. The PushAdminMessage500 COM module understands and processes the pushAdminMessage_500 XSD standard as well as its predecessor, namely pushAdminMessage_450. To analyze and retrieve the loaded data use the returned instance of the IPushAdminMessageRequest interface and/or preview/print the data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageManager/LoadXML?param
[param] | pIPushAdminMessageManager=longValue& bstrInputFile=urlEncodedString + <application/octet-stream> input_file_upload_stream
[JSON result data] | pbstrUsedSchema: pIPushAdminMessageRequest: pIPushAdminMessageResult: pbStatus: | "utf8StringValue", longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT LoadXML( | BSTR BSTR IPushAdminMessageRequest IPushAdminMessageResult VARIANT_BOOL | bstrInputFile, *pbstrUsedSchema, **pIPushAdminMessageRequest, **pIPushAdminMessageResult, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrInputFile | The input XML infoset (full file name) that must be loaded and analyzed. |
[out] BSTR | *pbstrUsedSchema | The full XSD schema name referenced by the of the loaded XML file. Since there is only one understandable standard, the returned schema is pushAdminMessage_450.xsd. This variable is not set if the loading of an XML infoset was unsuccessful or the referenced XSD is not valid. |
[out] IPushAdminMessageRequest | **pIPushAdminMessageRequest | The IPushAdminMessageRequest interface handle that allows to add further data. The handle is NULL if an error occurred. |
[out] IPushAdminMessageResult | **pIPushAdminMessageResult |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageManager
  • Print

IPushAdminMessageManager::Print method | space
The Print method validates the defined administrative message data and prints the request on the local printer. The printer selection is done via the used report generator template file. If the template file was not connected to a printer with the PrintSetup method then the default printer with its default settings is used.

The bstrPrintTemplate variable obeys a special syntax and can optionally be used to set special print commands like using electronic webstamps, producing PDFs or changing print objects dynamically.
  • "How to print webstamps" is a description how to integrate electronic stamps into the care credit
  • "How to generate PDF archive file" is a description about generating PDF archive files of the push admin message
  • "Syntax of the printTemplate variable" is a description about the syntax of the printTemplate variable

IMPORTANT LICENSE NOTE The report engine used is Hexatech's ViewPro (www.hexatech.com). If you supply your own template files then you must have your own ViewPro license. By using this COM module you implicitly agree upon this restriction!
space
Restful webservice calling syntax
[POST] | /baseURL/ IPushAdminMessageManager/Print
[JSON input data] pIPushAdminMessageManager:
bstrPrintTemplate:
lGenerationAttributes:
ePrintPreview: 		longValue, //interface address
"utf8StringValue",
longValue,
longValue
[JSON result data] plTimestamp:
pIPushAdminMessageResult:
pbstrPDFFile:
pbStatus: 		longValue,
longValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT Print( BSTR
long
YesNoType
long
IPushAdminMessageResult
VARIANT_BOOL 		bstrPrintTemplate,
lGenerationAttributes,
ePrintPreview,
*plTimestamp,
**pIPushAdminMessageResult,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate The bstrPrintTemplate variable is used to explicitly change print template reports and/or print objects as defined in "Syntax of the printTemplate variable".

If bstrPrintTemplate is empty then the default print template of the defined data language ( IPushAdminMessageRequest:: Initialize method) is used.
[in] long lGenerationAttributes This variable overrules the default behavior of the print process.

lGenerationAttributes is a 32-bit integer where the possible "commands" are values from the generationAttributes data type ORed together to form the overall command.
[in] YesNoType ePrintPreview A Boolean that defines if print preview is used (enYes) or printing is done (enNo)

In Restful Webservice system: ePrintPreview is automatically set to enNo no matter what the input value is. Furthermore, printing is automatically redirected to a PDF output file since there are no printers available.

[out] long | *plTimestamp | The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on.
[out] IPushAdminMessageResult **pIPushAdminMessageResult The IPushAdminMessageResult interface handle that allows to get all loaded data back.
The handle is NULL if an error occurred.
[out] BSTR *pbstrPDFFile In Restful webservice output:

pbstrPDFFile is a relative URL to a PDF file holding the result of the Print method. Therefore, after receiving the JSON result data do GET pbstrPDFile such as to have the produced printout.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageManager
  • PrintAdjust

IPushAdminMessageManager::PrintAdjust method | space
Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file.

Besides the position adjustment of any available print object, there exists the possibility of move all print objects globally.
space
Restful webservice calling syntax
This method has no Restful Webservice representation!
space
C/C++ calling syntax
HRESULT PrintAdjust( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via the following case insensitive logical name:
Detail[_version]_addressSide_language
- the single-page admin message template for all laws
where
  • version is 450, the absence of a version identifier defaults to 450
  • language is one of {dt, fr, it}.
  • addressSide is R for right sided addressing of the recipient.

For example the logical name "Detail_R_fr" is the French print template of version 450 with right sided addressing.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageManager
  • PrintSetup

IPushAdminMessageManager::PrintSetup method | space
Shows the printer setup dialog that allows to define the printer and its settings. When saving the data the selected printer and the currently used computer is connected with the given .vps report generator file.
space
Restful webservice calling syntax
This method has no Restful Webservice representation!
space
C/C++ calling syntax
HRESULT PrintSetup( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via the following case insensitive logical name:
Detail[_version]_addressSide_language
- the single-page admin message template for all laws
where
  • version is 450, the absence of a version identifier defaults to 450
  • language is one of {dt, fr, it}.
  • addressSide is R for right sided addressing of the recipient.

For example the logical name "Detail_R_fr" is the French print template of version 450 with right sided addressing.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageManager
  • SetLogSettings

IPushAdminMessageManager::SetLogSettings method | space
Sets the log setting preferences for the module.

The default for the log activity are: level=1, lMaxSizeKB=20000,eDoArchive=enNo, and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.
space
Restful webservice calling syntax
[POST] | /baseURL/ IPushAdminMessageManager/SetLogSettings
[JSON input data] pIPushAdminMessageManager:
lLogLevel:
lMaxSizeKB:
eDoArchive:
bstrArchiveDir: 		longValue, //interface address
longValue,
longValue,
longValue,
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.
[in] long lMaxSizeKB The maximum size in KB of the log file (default value is 20000 kB).
Any size below 1000 kB is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageManager
  • CreatePushAdminMessageManager

IPushAdminMessageManager::CreatePushAdminMessageManager property |  |  | space
This property has a Restful Webservice representation only! Creates an instance of the main IPushAdminMessageManager interface. To delete/invalidate this interface instance, the counterpart property PutDestructPushAdminMessageManager must be explicitly called, since the pIPushAdminMessageManager address has a global scope and is not automatically destructed. |  |  |
space
Restful webservice calling syntax |  |  |
[GET] | /baseURL/ IPushAdminMessageManager/GetCreatePushAdminMessageManager?param
[param] | pIPushAdminMessageManager= | longValue
[JSON result data] | pIPushAdminMessageManager: | longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IPushAdminMessageManager
  • DestructPushAdminMessageManager

IPushAdminMessageManager::DestructPushAdminMessageManager property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates a main instance of the IPushAdminMessageManager interface. Please note, that all dependent, active interface instances generated with IPushAdminMessageManager::GetPushAdminMessageRequest, all dependent, active interface instances generated with IPushAdminMessageRequest::GetCreateAddress and all IPushAdminMessageResult interface instances under this main instance, are automatically destructed as well. The counterpart property to generate a main interface instance is IPushAdminMessageManager::GetCreatePushAdminMessageManager. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IPushAdminMessageManager/PutDestructPushAdminMessageManager
[JSON input data] | pIPushAdminMessageManager: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IPushAdminMessageManager
  • DestructPushAdminMessageRequest

IPushAdminMessageManager::DestructPushAdminMessageRequest property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IPushAdminMessageRequest interface instance. The counterpart property to generate an IPushAdminMessageRequest interface instance is IPushAdminMessageManager::GetPushAdminMessageRequest. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IPushAdminMessageManager/PutDestructPushAdminMessageRequest
[JSON input data] | pIPushAdminMessageManager: pIPushAdminMessageRequest: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IPushAdminMessageManager
  • DestructPushAdminMessageResult

IPushAdminMessageManager::DestructPushAdminMessageResult property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IPushAdminMessageResult interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IPushAdminMessageManager/PutDestructPushAdminMessageResult
[JSON input data] | pIPushAdminMessageManager: pIPushAdminMessageResult: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IPushAdminMessageManager
  • ModuleLanguage

IPushAdminMessageManager::ModuleLanguage property | space
Get/Set the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by IPushAdminMessageRequest::Initialize) are independent and can be different!
space
Restful webservice calling syntax
[GET] | /baseURL/ IPushAdminMessageManager/GetModuleLanguage?param
[param] pIPushAdminMessageManager= longValue
[JSON result data] peModuleLanguage: longValue
[PUT] | /baseURL/ IPushAdminMessageManager/PutModuleLanguage
[JSON input data] pIPushAdminMessageManager:
eModuleLanguage: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *peModuleLanguage );
[put] HRESULT | ModuleLanguage( LanguageType eModuleLanguage );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LanguageType | *peModuleLanguage
[in] LanguageType | eModuleLanguage
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType lModuleLanguage);
space


  • IPushAdminMessageManager
  • ModuleVersion

IPushAdminMessageManager::ModuleVersion property | space
Get the version of the PushAdminMessageManager module.
space
Restful webservice calling syntax
[GET] | /baseURL/ IPushAdminMessageManager/GetModuleVersion?param
[param] pIPushAdminMessageManager= longValue
[JSON result data] pbstrModuleVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *pbstrModuleVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersion
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IPushAdminMessageManager
  • ModuleVersionText

IPushAdminMessageManager::ModuleVersionText property | space
Get the version of the PushAdminMessageManager module in textual form.
space
Restful webservice calling syntax
[GET] | /baseURL/ IPushAdminMessageManager/GetModuleVersionText?param
[param] pIPushAdminMessageManager= longValue
[JSON result data] pbstrModuleVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *pbstrModuleVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersionText
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IPushAdminMessageManager
  • Modus

IPushAdminMessageManager::Modus property | space
Gets/Sets the operation modus of the module.

The default modus is enProduction whereas for developing/debugging purposes enTest can be set.
space
Restful webservice calling syntax
[GET] | /baseURL/ IPushAdminMessageManager/GetModus?param
[param] pIPushAdminMessageManager= longValue
[JSON result data] peModus: longValue
[PUT] | /baseURL/ IPushAdminMessageManager/PutModus
[JSON input data] pIPushAdminMessageManager:
eModus: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Modus( ModusType *peModus );
[put] HRESULT | Modus( ModusType eModus );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ModusType | *peModus
[in] ModusType | eModus
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ModusType *GetModus(void);
  • void PutModus( ModusType lModus);
space


  • IPushAdminMessageManager
  • PushAdminMessageRequest

IPushAdminMessageManager::PushAdminMessageRequest property | space
Gets the IPushAdminMessageRequest interface instance.

This property is called if the data are defined from scratch. The same interface instance is returned when the IPushAdminMessageManager::LoadXML method is called.
space
Restful webservice calling syntax
[GET] | /baseURL/ IPushAdminMessageManager/GetPushAdminMessageRequest?param
[param] pIPushAdminMessageManager= longValue
[JSON result data] pIPushAdminMessageRequest: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | PushAdminMessageRequest( IPushAdminMessageRequest **pePushAdminMessageRequest );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IPushAdminMessageRequest | **pePushAdminMessageRequest | The created instance of the IPushAdminMessageRequest interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IPushAdminMessageRequest **GetPushAdminMessageRequest(void);
space


  • IPushAdminMessageRequest

IPushAdminMessageRequest interface |  | V5.00/27 Nov 2024
With the IPushAdminMessageRequest interface all administrative message related data and parameters can be set by the available interface methods like SetPatient, SetDebitor,SetMessage4Stationary,... Alternatively to producing the data from scratch, the data of a previously generated XML infoset can be loaded with the IPushAdminMessageManager::LoadXML method and thereafter data can selectively be changed. |  | space
space
Methods |  | 13 methods
Finalize | Finalizes and validates all data set so far in the IPushAdminMessageRequest interface |
GetAbortInfo | Get the abort information string with the error coded in the module language |
Initialize | Initializes all input data in the IPushAdminMessageRequest interface |
SetBillerGLN | Sets the biller's structured address as well as its mandatory GLN |
SetBillerZSR | Sets the biller's structured address as well as its mandatory ZSR |
SetDebitor | Sets the debitor's GLN and the structured address |
SetLaw | Sets the data about the applied law and its dependent information |
SetMessage4Ambulatory | Sets and defines the primary administrative message parameters for an ambulatory treatment. |
SetMessage4Stationary | Sets and defines the primary administrative message parameters for a stationary treatment. |
SetPatient | Sets the primary parameters and structured address of the patient |
SetProviderGLN | Sets the provider's structured address as well as its mandatory GLN |
SetProviderZSR | Sets the provider's structured address as well as its mandatory ZSR |
SetTransport | Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to) |
space
Properties |  | 3 properties
[get] CreateAddress | Creates an instance of the IAddress interface |
[put] DestructAddress | Destructs/invalidates the IAddress interface instance |
[put] DestructPushAdminMessageRequest | Destructs/invalidates this IPushAdminMessageRequest interface instance |
space |


  • IPushAdminMessageRequest
  • Finalize

IPushAdminMessageRequest::Finalize method |  |  | space
Finalizes and validates all data set so far in the IPushAdminMessageRequest interface. This method is the counterpart to the Initialize method. This method should be called after all data have been set in the IPushAdminMessageRequest interface since higher-level validation rules can only be called at the end of input phase. Therefore, be prepared to get validation errors at that point. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/Finalize
[JSON input data] | pIPushAdminMessageRequest: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Finalize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • GetAbortInfo

IPushAdminMessageRequest::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/GetAbortInfo
[JSON input data] | pIPushAdminMessageRequest: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
space |


  • IPushAdminMessageRequest
  • Initialize

IPushAdminMessageRequest::Initialize method |  |  | space
Initializes all input data in the IPushAdminMessageRequest interface. This method is the counterpart to the Finalize method. This method should be called before any input is set in the IPushAdminMessageRequest interface. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/Initialize
[JSON input data] | pIPushAdminMessageRequest: eDataLanguage: bstrRemark: | longValue, //interface address longValue, "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | LanguageType BSTR VARIANT_BOOL | eDataLanguage, bstrRemark, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LanguageType | eDataLanguage | Sets the language in which the data part is coded. It is exactly the language in which the request is formulated. Note, that the data language and the module language (given by IPushAdminMessageManager::SetModuleLanguage property) are independent and can be different! |
[in] BSTR | bstrRemark | An overall optional remark for this process |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetBillerGLN

IPushAdminMessageRequest::SetBillerGLN method |  |  | space
Sets the biller's structured address as well as its mandatory GLN. Please note that the biller's GLN address does not include a ZSR. Furthermore, the structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetBillerGLN
[JSON input data] | pIPushAdminMessageRequest: bstrGLN: pIAddress: | longValue, //interface address "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetBillerGLN( | BSTR IAddress VARIANT_BOOL | bstrGLN, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrGLN | The GLN of the biller as supplied by Stiftung Refdata |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetBillerZSR

IPushAdminMessageRequest::SetBillerZSR method |  |  | space
Sets the biller's structured address as well as its mandatory ZSR. Please note that the biller's ZSR address does not include a GLN. Furthermore, the structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. Note that the billers's ZSR address is optional in terms of the XSD schema definition. However, it may be the case that the underlying tariff contracts, applied law and/or special contracts between service providers and insurances change the optionality into a mandatory data specification. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetBillerZSR
[JSON input data] | pIPushAdminMessageRequest: bstrZSR: pIAddress: | longValue, //interface address "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetBillerZSR( | BSTR IAddress VARIANT_BOOL | bstrZSR, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrZSR | The mandatory ZSR number of the biller as supplied by Santesuisse |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetDebitor

IPushAdminMessageRequest::SetDebitor method |  |  | space
Sets the debitor's GLN and the structured address. The structured address is defined via a Iaddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetDebitor
[JSON input data] | pIPushAdminMessageRequest: bstrGLN: bstrUID: pIAddress: | longValue, //interface address "utf8StringValue", "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetDebitor( | BSTR BSTR IAddress VARIANT_BOOL | bstrGLN, bstrUID, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrGLN | The GLN of the debitor as supplied by Stiftung Refdata |
[in] BSTR | bstrUID | The optional UID of the debitor as supplied by UID Register of the BfS. |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetLaw

IPushAdminMessageRequest::SetLaw method |  |  | space
Sets the data about the applied law and its dependent information |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetLaw
[JSON input data] | pIPushAdminMessageRequest: eLawType: dCaseDate: bstrCaseID: bstrInsuredID: | longValue, //interface address longValue, variantDateValue | "stringISODateValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetLaw( | LawType DATE BSTR BSTR VARIANT_BOOL | eLawType, dCaseDate, bstrCaseID, bstrInsuredID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LawType | eLawType | The type of law to set from the LawType enumeration |
[in] DATE | dCaseDate | The case date of the insurance (e.g. date of accident in UVG) This date might be undefined for certain laws (e.g. KVG|VVG) and left empty in such a case |
[in] BSTR | bstrCaseID | The case ID of the insurance (e.g. accident number in UVG) This ID might be undefined for certain laws (e.g. KVG|VVG) and left empty in such a case |
[in] BSTR | bstrInsuredID | bstrInsuredID defines the required 20-digits official card ID of the patient. If this ID is unknown or unavailable then supply the old proprietary 7-digits insurance ID identifying the patient at the insurance. This insuredID might be undefined for certain laws (e.g. UVG|MVG) and left empty in such a case. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetMessage4Ambulatory

IPushAdminMessageRequest::SetMessage4Ambulatory method |  |  | space
Sets and defines the primary administrative message parameters for an ambulatory treatment. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetMessage4Ambulatory
[JSON input data] | pIPushAdminMessageRequest: eMessageAction: dMessageDate: eTreatmentReason: | longValue, //interface address longValue, variantDateValue | "stringISODateValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetMessage4Ambulatory( | MessageActionType DATE TreatmentReasonType VARIANT_BOOL | eMessageAction, dMessageDate, eTreatmentReason, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] MessageActionType | eMessageAction | The message action is the principle action of message encoded by the MessageActionType enumeration |
[in] DATE | dMessageDate | The message date is the date and time when the message's action is performed/defined almost like 'message_type::message_action@message_date' |
[in] TreatmentReasonType | eTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetMessage4Stationary

IPushAdminMessageRequest::SetMessage4Stationary method |  |  | space
Sets and defines the primary administrative message parameters for a stationary treatment. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetMessage4Stationary
[JSON input data] | pIPushAdminMessageRequest: eMessageAction: dMessageDate: eTreatmentReason: eHospitalizationType: eHospitalizationMode: eHospitalizationClass: bstrSectionMajor: eResidenceCode: | longValue, //interface address longValue, variantDateValue | "stringISODateValue", longValue, longValue, longValue, longValue, "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetMessage4Stationary( | MessageActionType DATE TreatmentReasonType HospitalizationType HospitalizationModeType HospitalizationClassType BSTR ResidenceCodeType VARIANT_BOOL | eMessageAction, dMessageDate, eTreatmentReason, eHospitalizationType, eHospitalizationMode, eHospitalizationClass, bstrSectionMajor, eResidenceCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] MessageActionType | eMessageAction | The message action is the principle action of message encoded by the MessageActionType enumeration |
[in] DATE | dMessageDate | The message date is the date and time when the message's action is performed/defined almost like 'message_type::message_action@message_date' |
[in] TreatmentReasonType | eTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration |
[in] HospitalizationType | eHospitalizationType | The type/reason of hospitalization given by the HospitalizationType enumeration |
[in] HospitalizationModeType | eHospitalizationMode | The mode/indication of hospitalization given by the HospitalizationMode enumeration. |
[in] HospitalizationClassType | eHospitalizationClass | The hospitalization class given by the HospitalizationClass enumeration. |
[in] BSTR | bstrSectionMajor | The optional bstrSectionCode stems from a variable set defined by "OAAT-OTMA - Reglement Fachbereiche", that designates the service-providing department within a hospital or medical practice, e.g. 'M100.06' for the gastroenterology department. The list of all departments is documented elsewhere on the "OAAT-OTMA" website, whereby the tariffs used, the law applied or special contracts stipulates the application/usage of the section code (primarily for body@role=hospital, body@role=rehab_clinic, body@role=psychiatric_clinic). |
[in] ResidenceCodeType | eResidenceCode | The ResidenceCode defines the relevant admission or discharge location where the patient stayed before admission or is discharged to, encoded by the ResidenceCode enumeration. Please note that if eMessageAction=enActionStart, the ResidenceCode specifies an admission location, while eMessageAction=enActionEnd forces a ResidenceCode that corresponds to a discharge location. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetPatient

IPushAdminMessageRequest::SetPatient method | space
Sets the primary parameters and structured address of the patient.

The address is defined via an IAddress interface pointer and the address data must be defined prior to call this method.
space
Restful webservice calling syntax
[POST] | /baseURL/ IPushAdminMessageRequest/SetPatient
[JSON input data] pIPushAdminMessageRequest:
eSexType:
eGenderType:
dBirthdate:
bstrSSN:
pIAddress: 		longValue, //interface address
longValue,
longValue,
variantDateValue | "stringISODateValue",
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetPatient( SexType
GenderType
DATE
BSTR
IAddress
VARIANT_BOOL 		eSexType,
eGenderType,
dBirthdate,
bstrSSN,
*pIAddress,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] SexType | eSexType | The patient's medical sex (pre-dominantly induced by the actual hormonal balance of the body) encoded by a terminal set of tokens.
[in] GenderType | eGenderType | The patient's social gender encoded by a terminal set of tokens
[in] DATE | dBirthdate | The patient's birthdate.
[in] BSTR bstrSSN Defines the required patient's social security number (SSN) whereupon 3 distinguished types are allowed:
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438

If for any reasons the SSN of the patient is unknown, than the unknownSSN = 7569999999991 must be defined to satisfy the schema validity!
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageRequest
  • SetProviderGLN

IPushAdminMessageRequest::SetProviderGLN method |  |  | space
Sets the provider's structured address as well as its mandatory GLN. Please note that the provider's GLN address does not include a ZSR. Furthermore, the structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetProviderGLN
[JSON input data] | pIPushAdminMessageRequest: bstrGLN: bstrGLNLocation: bstrUID: bstrMainProvider: pIAddress: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetProviderGLN( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrGLN, bstrGLNLocation, bstrUID, bstrMainProvider, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrGLN | The GLN of the provider as supplied by Stiftung Refdata |
[in] BSTR | bstrGLNLocation | The bstrGLNLocation codes the provider's workplace by a required GLN as defined by RefData If there is no such specific workplace defined then input the bstrGLN as its GLN location, basically defining the default workplace/location. |
[in] BSTR | bstrUID | The optional UID of the debitor as supplied by UID Register of the BfS. |
[in] BSTR | bstrMainProvider | The optional main treating provider is the full name of the case leading provider should that name be different from the one given in the address section |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetProviderZSR

IPushAdminMessageRequest::SetProviderZSR method |  |  | space
Sets the provider's structured address as well as its mandatory ZSR. Please note that the provider's ZSR address does not include a GLN. Furthermore, the structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. Note that the providers's ZSR address is optional in terms of the XSD schema definition. However, it may be the case that the underlying tariff contracts, applied law and/or special contracts between service providers and insurances change the optionality into a mandatory data specification. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageRequest/SetProviderZSR
[JSON input data] | pIPushAdminMessageRequest: bstrZSR: pIAddress: | longValue, //interface address "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetProviderZSR( | BSTR IAddress VARIANT_BOOL | bstrZSR, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrZSR | The mandatory ZSR number of the provider as supplied by Santesuisse |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageRequest
  • SetTransport

IPushAdminMessageRequest::SetTransport method | space
Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). All the involved parties are defined by GLN numbers as defined by Stiftung Refdata.

Furthermore, this method allows to define the parameters needed for sign and/or encrypt the resulting XML infoset. Therefore, read the notes about signature and encryption to get familiar with these concepts.

Important new feature: the electronic reachability of a recipient for a certain version of pushAdminMessage is kind of a chicken and egg problem. To solve this connectivity problem, the service medSRS (medical Standard Routing Service) has been created. By using the RESTful webservice method queryRHS one can find out, how and whether a specific recipient can be reached electronically. Please refer to the website medSRS.ch for getting an introduction to the topic or detailed information about the functionality of the webservice.

Instead of inputting the bstrToEan GLN literal, the query call queryRHS(glnBiller,glnRecipient) is supplied instead - cf. description of bstrToEAN below.

The usage of the patch can generate a new error code 'ERROR_RECIPIENTRHS_NOTAVAILABLE' indicating that a given recipient is not reachable. It is the decision of the calling program whether the error 'ERROR_RECIPIENTRHS_NOTAVAILABLE' will be considered or not.

space
Restful webservice calling syntax
[POST] | /baseURL/ IPushAdminMessageRequest/SetTransport
[JSON input data] pIPushAdminMessageRequest:
bstrFromGLN:
bstrFromPFXFile:
bstrFromPFXPassword:
bstrViaGLN:
bstrToGLN:
bstrToBinDERFile: 		longValue, //interface address
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetTransport( BSTR
BSTR
BSTR
BSTR
BSTR
BSTR
VARIANT_BOOL 		bstrFromGLN,
bstrFromPFXFile,
bstrFromPFXPassword,
bstrViaGLN,
bstrToGLN,
bstrToBinDERFile,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrFromGLN | The GLN of the sender as supplied by Stiftung Refdata
[in] BSTR bstrFromPFXFile The file name of the PFX certificate that is the private certificate of the "from" entity.
If the variable is empty or NULL then no signature is applied otherwise a signature might be applied depending on the lXMLGenerationAttributes of the GetXML method.
[in] BSTR | bstrFromPFXPassword | The password to open the PFX certificate. The password is only used if a PFX certificate is supplied.
[in] BSTR | bstrViaGLN | The GLN of the first intermediate as supplied by Stiftung Refdata
[in] BSTR bstrToGLN The GLN of the receiver as supplied by Stiftung Refdata
  • bstrToGLN='2005555555003' forces routing to the print center (mnemonic 'printCenterGLN')
  • bstrToGLN='2006666666008' forces routing to /dev/null aka deletion (mnemonic 'noRecipientGLN')
[in] BSTR bstrToBinDERFile The file name of the binary DER certificate that is the public certificate of the "to" entity.
If the variable is empty or NULL then no encryption is applied otherwise encryption might be applied depending on the lXMLGenerationAttributes of the GetXML
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageRequest
  • CreateAddress

IPushAdminMessageRequest::CreateAddress property | space
Creates an instance of the IAddress interface.

Any address data is specified or retrieved using properties and methods of this interface. The interface is reusable for any semantic type of address. Just call the IAddress:Initialize method before starting to input new address data.
space
Restful webservice calling syntax
[GET] | /baseURL/ IPushAdminMessageRequest/GetCreateAddress?param
[param] pIPushAdminMessageRequest= longValue
[JSON result data] pIAddress: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateAddress( IAddress **peCreateAddress );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IAddress **peCreateAddress The instance of an IAddress interface that allows to read back the structured address data.
If no address is defined then the handle is NULL.
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IAddress **GetCreateAddress(void);
space


  • IPushAdminMessageRequest
  • DestructAddress

IPushAdminMessageRequest::DestructAddress property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates the IAddress interface instance. The counterpart property to generate an IAddress interface instance is IPushAdminMessageRequest::GetCreateAddress. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IPushAdminMessageRequest/PutDestructAddress
[JSON input data] | pIPushAdminMessageRequest: pIAddress: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IPushAdminMessageRequest
  • DestructPushAdminMessageRequest

IPushAdminMessageRequest::DestructPushAdminMessageRequest property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IPushAdminMessageRequest interface instance. The counterpart property to generate an IPushAdminMessageRequest interface instance is IPushAdminMessageManager::GetPushAdminMessageRequest. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IPushAdminMessageRequest/PutDestructPushAdminMessageRequest
[JSON input data] | pIPushAdminMessageRequest: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IPushAdminMessageResult

IPushAdminMessageResult interface |  | V5.00/27 Nov 2024
The IPushAdminMessageResult interface allows to read back all data that have been set by the IPushAdminMessageRequest interface or by loading a previously generated XML infoset with the IPushAdminMessageManager::LoadXML method. |  | space
space
Methods |  | 13 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetBillerGLN | Gets the biller's structured address as well as its mandatory GLN |
GetBillerZSR | Gets the biller's structured address as well as its mandatory ZSR |
GetDebitor | Retrieves the debitor's GLN identifier as well as the structured address |
GetLaw | Retrieves the data about the applied law and its dependent information |
GetMessage4Ambulatory | Retrieves the primary administrative message parameters for an ambulatory treatment |
GetMessage4Stationary | Retrieves the primary administrative message parameters for a stationary treatment |
GetPatient | Retrieves the patient's primary parameters (sex, gender, birthdate, SSN) as well as the structured address |
GetProviderGLN | Gets the provider's structured address as well as ist mandatory GLN |
GetProviderZSR | Sets the provider's structured address as well as its mandatory ZSR |
GetRequest | Returns the primary parameters of the request, namely the language the data is supplied, besides the GUID of the XML infoset and an optional remark. |
GetTransport | Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to) |
GetTreatmentType | Retrieves the treatment type of the loaded administrative message, e.g |
space
Properties |  | 1 properties
[put] DestructPushAdminMessageResult | Destructs/invalidates this IPushAdminMessageResult interface instance. |
space |


  • IPushAdminMessageResult
  • GetAbortInfo

IPushAdminMessageResult::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetAbortInfo
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error-in-error situation occurred. |
space |


  • IPushAdminMessageResult
  • GetBillerGLN

IPushAdminMessageResult::GetBillerGLN method |  |  | space
Gets the biller's structured address as well as its mandatory GLN. Please note that the biller's GLN address does not include a ZSR. Furthermore, the structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetBillerGLN
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | pbstrGLN: pIAddress: pbStatus: | "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetBillerGLN( | BSTR IAddress VARIANT_BOOL | *pbstrGLN, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrGLN | The GLN of the biller as supplied by Stiftung Refdata |
[out] IAddress | **pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetBillerZSR

IPushAdminMessageResult::GetBillerZSR method |  |  | space
Gets the biller's structured address as well as its mandatory ZSR. Please note that the biller's ZSR address does not include a GLN. Furthermore, the structured address is defined via a Iaddress interface instance and the address data must be defined prior to call this method. Note that the billers's ZSR address is optional in terms of the XSD schema definition. However, it may be the case that the underlying tariff contracts, applied law and/or special contracts between service providers and insurances change the optionality into a mandatory data specification. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetBillerZSR
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | pbstrZSR: pIAddress: pbStatus: | "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetBillerZSR( | BSTR IAddress VARIANT_BOOL | *pbstrZSR, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrZSR | The mandatory ZSR number of the biller as supplied by Santesuisse |
[out] IAddress | **pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetDebitor

IPushAdminMessageResult::GetDebitor method |  |  | space
Retrieves the debitor's GLN identifier as well as the structured address. The structured address data is read via the methods of the returned IAddress interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetDebitor
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | pbstrGLN: pbstrUID: pIAddress: pbStatus: | "utf8StringValue", "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetDebitor( | BSTR BSTR IAddress VARIANT_BOOL | *pbstrGLN, *pbstrUID, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrGLN | The GLN of the debitor as supplied by Stiftung Refdata. If the debitor's GLN is undefined than GLN from the private segment should be used (e.g. 2000000000008). |
[out] BSTR | *pbstrUID | The optional UID of the debitor as supplied by UID Register of the BfS. |
[out] IAddress | **pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetLaw

IPushAdminMessageResult::GetLaw method |  |  | space
Retrieves the data about the applied law and its dependent information |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetLaw
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | peLawType: pdCaseDate: pbstrCaseID: pbstrInsuredID: pbStatus: | longValue, "stringISODateValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetLaw( | LawType DATE BSTR BSTR VARIANT_BOOL | *peLawType, *pdCaseDate, *pbstrCaseID, *pbstrInsuredID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] LawType | *peLawType | Defines the type of law as given by the LawType enumeration. |
[out] DATE | *pdCaseDate | The case date of the insurance (e.g. date of accident in UVG) This date might be undefined for certain laws and is than left empty |
[out] BSTR | *pbstrCaseID | The case ID of the insurance (e.g. accident number in UVG) This caseID might be undefined for certain laws and is than left empty |
[out] BSTR | *pbstrInsuredID | The patient's insurance ID, where in most cases this is the 20-digits official card ID or if this one is unknown/unavailable then the old proprietary 7-digits insurance ID is given |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetMessage4Ambulatory

IPushAdminMessageResult::GetMessage4Ambulatory method |  |  | space
Retrieves the primary administrative message parameters for an ambulatory treatment. Call the property GetTreatmentType first to test it is a ambulatory or stationary treatment. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetMessage4Ambulatory
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | peMessageAction: pdMessageDate: peTreatmentReason: pbStatus: | longValue, "stringISODateValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetMessage4Ambulatory( | MessageActionType DATE TreatmentReasonType VARIANT_BOOL | *peMessageAction, *pdMessageDate, *peTreatmentReason, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] MessageActionType | *peMessageAction | The message action is the principle action of message encoded by the MessageActionType enumeration |
[out] DATE | *pdMessageDate | The message date is the date and time when the message's action is performed/defined almost like 'message_type::message_action@message_date' |
[out] TreatmentReasonType | *peTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetMessage4Stationary

IPushAdminMessageResult::GetMessage4Stationary method |  |  | space
Retrieves the primary administrative message parameters for a stationary treatment. Call the property GetTreatmentType first to test it is a ambulatory or stationary treatment. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetMessage4Stationary
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | peMessageAction: pdMessageDate: peTreatmentReason: peHospitalizationType: peHospitalizationMode: peHospitalizationClass: pbstrSectionMajor: peResidenceCode: pbStatus: | longValue, "stringISODateValue", longValue, longValue, longValue, longValue, "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetMessage4Stationary( | MessageActionType DATE TreatmentReasonType HospitalizationType HospitalizationModeType HospitalizationClassType BSTR ResidenceCodeType VARIANT_BOOL | *peMessageAction, *pdMessageDate, *peTreatmentReason, *peHospitalizationType, *peHospitalizationMode, *peHospitalizationClass, *pbstrSectionMajor, *peResidenceCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] MessageActionType | *peMessageAction | The message action is the principle action of message encoded by the MessageActionType enumeration |
[out] DATE | *pdMessageDate | The message date is the date and time when the message's action is performed/defined almost like 'message_type::message_action@message_date' |
[out] TreatmentReasonType | *peTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration |
[out] HospitalizationType | *peHospitalizationType | The type/reason of hospitalization given by the HospitalizationType enumeration |
[out] HospitalizationModeType | *peHospitalizationMode | The mode/indication of hospitalization given by the HospitalizationMode enumeration. |
[out] HospitalizationClassType | *peHospitalizationClass | The hospitalization class given by the HospitalizationClass enumeration. |
[out] BSTR | *pbstrSectionMajor | The optional bstrSectionCode stems from a variable set defined by "OAAT-OTMA - Reglement Fachbereiche", that designates the service-providing department within a hospital or medical practice, e.g. 'M100.06' for the gastroenterology department. The list of all departments is documented elsewhere on the "OAAT-OTMA" website, whereby the tariffs used, the law applied or special contracts stipulates the application/usage of the section code (primarily for body@role=hospital, body@role=rehab_clinic, body@role=psychiatric_clinic). |
[out] ResidenceCodeType | *peResidenceCode | The ResidenceCode defines the relevant admission or discharge location where the patient stayed before admission or is discharged to, encoded by the ResidenceCode enumeration. Please note that if eMessageAction=enActionStart, the ResidenceCode specifies an admission location, while eMessageAction=enActionEnd forces a ResidenceCode that corresponds to a discharge location. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetPatient

IPushAdminMessageResult::GetPatient method | space
Retrieves the patient's primary parameters (sex, gender, birthdate, SSN) as well as the structured address.

The structured address data is read via the methods of the returned Iaddress interface instance.
space
Restful webservice calling syntax
[POST] | /baseURL/ IPushAdminMessageResult/GetPatient
[JSON input data] pIPushAdminMessageResult: longValue, //interface address
[JSON result data] peSexType:
peGenderType:
pdBirthdate:
pbstrSSN:
pIAddress:

pbStatus: 		longValue,
longValue,
"stringISODateValue",
"utf8StringValue",
{
pbIsPrivateAddress: true,
pbstrCompanyName: "utf8StringValue",
pbstrDepartment: "utf8StringValue",
pbstrSalutation: "utf8StringValue",
pbstrTitle: "utf8StringValue",
pbstrFamilyname: "utf8StringValue",
pbstrGivenname: "utf8StringValue",
pbstrSubaddressing: "utf8StringValue",
pbstrStreet: "utf8StringValue",
pbstrPoBox: "utf8StringValue",
pbstrZip: "utf8StringValue",
pbstrCity: "utf8StringValue",
pbstrStateCode: "utf8StringValue",
pbstrCountryCode: "utf8StringValue",
pbstrPhone1: "utf8StringValue",
pbstrPhone2: "utf8StringValue",
pbstrPhone3: "utf8StringValue",
pbstrFax: "utf8StringValue",
pbstrEMail: "utf8StringValue",
pbstrUrl: "utf8StringValue"
},
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetPatient( SexType
GenderType
DATE
BSTR
IAddress
VARIANT_BOOL 		*peSexType,
*peGenderType,
*pdBirthdate,
*pbstrSSN,
**pIAddress,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] SexType | *peSexType | The patient's medical sex (pre-dominantly induced by the actual hormonal balance of the body) encoded by a terminal set of tokens.
[out] GenderType | *peGenderType | The patient's social gender encoded by a terminal set of tokens
[out] DATE | *pdBirthdate | The patient's birthdate.
[out] BSTR *pbstrSSN The patient's social security number (SSN) in its printed form whereupon 3 distinguished types are possible:
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
[out] IAddress **pIAddress The IAddress interface handle that allows to get the structured address data back.
If no address is defined then the handle is NULL.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IPushAdminMessageResult
  • GetProviderGLN

IPushAdminMessageResult::GetProviderGLN method |  |  | space
Gets the provider's structured address as well as ist mandatory GLN. Please note that the provider's GLN address does not include a ZSR. Furthermore, the structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetProviderGLN
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | pbstrGLN: pbstrGLNLocation: pbstrUID: pbstrMainProvider: ppIAddress: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetProviderGLN( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrGLN, *pbstrGLNLocation, *pbstrUID, *pbstrMainProvider, **ppIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrGLN | The GLN of the provider as supplied by Stiftung Refdata |
[out] BSTR | *pbstrGLNLocation | The bstrGLNLocation codes the provider's workplace by a required GLN as defined by RefData If there is no such specific workplace defined then the bstrGLN is used as ist GLN location, basically defining the default workplace/location. |
[out] BSTR | *pbstrUID | The optional UID of the debitor as supplied by UID Register of the BfS. |
[out] BSTR | *pbstrMainProvider | The optional main treating provider is the full name of the case leading provider should that name be different from the one given in the address section |
[out] IAddress | **ppIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetProviderZSR

IPushAdminMessageResult::GetProviderZSR method |  |  | space
Sets the provider's structured address as well as its mandatory ZSR. Please note that the provider's ZSR address does not include a GLN. Furthermore, the structured address is defined via a IAddress interface instance and the address data must be defined prior to call this method. Note that the providers's ZSR address is optional in terms of the XSD schema definition. However, it may be the case that the underlying tariff contracts, applied law and/or special contracts between service providers and insurances change the optionality into a mandatory data specification. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetProviderZSR
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | pbstrZSR: ppIAddress: pbStatus: | "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetProviderZSR( | BSTR IAddress VARIANT_BOOL | *pbstrZSR, **ppIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrZSR | The mandatory ZSR number of the provider as supplied by Santesuisse |
[out] IAddress | **ppIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetRequest

IPushAdminMessageResult::GetRequest method |  |  | space
Returns the primary parameters of the request, namely the language the data is supplied, besides the GUID of the XML infoset and an optional remark. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetRequest
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | peDataLanguage: pbstrRemark: pbstrGUID: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRequest( | LanguageType BSTR BSTR VARIANT_BOOL | *peDataLanguage, *pbstrRemark, *pbstrGUID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] LanguageType | *peDataLanguage | Gets the language in which the data part is coded. It is exactly the language in which the request is formulated. Note, that the data language and the module language (given by IGeneralInvoiceRequestManager::SetModuleLanguage) are independent and can be different! |
[out] BSTR | *pbstrRemark | An overall optional remark for the admin message |
[out] BSTR | *pbstrGUID | Gets the unique GUID (Globally Unique IDentifier) allocated to the current XML infoset defined as a 32 hex-digit string covered by the pattern [A-Fa-f0-9]{32}. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetTransport

IPushAdminMessageResult::GetTransport method |  |  | space
Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to). All the involved parties are defined by EAN numbers as defined by Stiftung Refdata. If the parameters for the signature and encryption were set then these data are returned as well otherwise the corresponding variables are empty. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetTransport
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | pbstrFromGLN: pbstrFromPFXFile: pbstrFromPFXPassword: pbstrViaGLN: pbstrToGLN: pbstrToBinDERFile: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTransport( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFromGLN, *pbstrFromPFXFile, *pbstrFromPFXPassword, *pbstrViaGLN, *pbstrToGLN, *pbstrToBinDERFile, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrFromGLN | The GLN of the sender as supplied by Stiftung Refdata |
[out] BSTR | *pbstrFromPFXFile | The file name of the PFX certificate used for signing that is the private certificate of the "from" entity. If the request is not signed than this parameter is empty |
[out] BSTR | *pbstrFromPFXPassword | The password to open the PFX certificate. If the request is not signed than this parameter is empty |
[out] BSTR | *pbstrViaGLN | The GLN of the first intermediate as supplied by Stiftung Refdata |
[out] BSTR | *pbstrToGLN | The GLN of the receiver as supplied by Stiftung Refdata |
[out] BSTR | *pbstrToBinDERFile | The file name of the binary DER certificate used for encryption that is the public certificate of the "to" entity |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • GetTreatmentType

IPushAdminMessageResult::GetTreatmentType method |  |  | space
Retrieves the treatment type of the loaded administrative message, e.g. either 'ambulatory' or 'stationary' |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IPushAdminMessageResult/GetTreatmentType
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[JSON result data] | peTreatmentType: pbStatus: | longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTreatmentType( | TreatmentType VARIANT_BOOL | *peTreatmentType, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] TreatmentType | *peTreatmentType | The treatment type ('ambulatory' or 'stationary') given by the TreatmentType enumeration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IPushAdminMessageResult
  • DestructPushAdminMessageResult

IPushAdminMessageResult::DestructPushAdminMessageResult property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IPushAdminMessageResult interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IPushAdminMessageResult/PutDestructPushAdminMessageResult
[JSON input data] | pIPushAdminMessageResult: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • Type definitions

Builtin, composite & enumeration types |  | V5.00/27 Nov 2024
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
space
Data types |  | 24 types
[enumeration] AddressType | Enumerates the defined types of addresses. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[builtin] DATE | DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. |
[enumeration] GenderType | Enumerates the defined social gender types encoded by a terminal set of tokens |
[enumeration] generationAttributes | List of options with which the standard generation of the XML infoset and/or print process can be oversteered. |
[enumeration] HospitalizationClassType | Enumerates the defined classes/types of hospitalization |
[enumeration] HospitalizationModeType | Enumerates the defined modes/indications of the hospitalization |
[enumeration] HospitalizationType | Enumerates the defined types/reasons of the hospitalization |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning |
[builtin] IAddress | The IAddress interface object |
[builtin] IPushAdminMessageRequest | The IPushAdminMessageRequest interface object |
[builtin] IPushAdminMessageResult | The IPushAdminMessageResult interface object |
[enumeration] LanguageType | Enumerates all supported languages. |
[enumeration] LawType | Enumerates the supported legal law set. |
[builtin] long | A 4-byte integer value. |
[enumeration] MessageActionType | Enumerates the defined message actions |
[enumeration] MessageType | Enumerates the defined principle message types |
[enumeration] ModusType | Enumerates the defined operation modus types |
[enumeration] ResidenceCodeType | Enumerates the defined admission or discharge locations where the patient is coming from or discharged to encoded by a terminal set of tokens |
[enumeration] SexType | Enumerates the defined basic gender types. |
[enumeration] TreatmentReasonType | Enumerates the list of defined treatment reasons. |
[enumeration] TreatmentType | Enumerates the top level treatment types. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator. |
space |


  • Type definitions
  • AddressType

AddressType enumeration type |  |
Enumerates the defined types of addresses. |  | space
space
Set of enumeration values |  | 3 elements
enAddressUndefined: 0 | Address type is undefined or unknown. |
enAddressPerson: 1 | Address of a person |
enAddressCompany: 2 | Address of a company |
space


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space
space
space


  • Type definitions
  • DATE

DATE type |
DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. | space
space
space


  • Type definitions
  • GenderType

GenderType enumeration type |  |
Enumerates the defined social gender types encoded by a terminal set of tokens |  | space
space
Set of enumeration values |  | 3 elements
enGenderMale: 0 | the social gender is male |
enGenderFemale: 1 | the social gender is female |
enGenderDiverse: 2 | the social gender is diverse |
space


  • Type definitions
  • generationAttributes

generationAttributes enumeration type |  |
List of options with which the standard generation of the XML infoset and/or print process can be oversteered. |  | space
space
Set of enumeration values |  | 2 elements
enGenerateXMLWithoutSignature: 131072 | The XML infoset is generated without applying a signature even if the signature parameters have been set in the IPushAdminMessageRequest::SetTransport method. |
enGenerateXMLWithoutEncryption: 262144 | The XML infoset is generated without applying encryption even if the encryption parameters have been set in the IPushAdminMessageRequest::SetTransport method. |
space


  • Type definitions
  • HospitalizationClassType

HospitalizationClassType enumeration type |  |
Enumerates the defined classes/types of hospitalization |  | space
space
Set of enumeration values |  | 5 elements
enGeneral: 0 | The general hospitalization class is used |
enSemiPrivate: 1 | The semi-private hospitalization class is used |
enPrivate: 2 | The private hospitalization class is used |
enHospitalComfort: 3 | The comfort hospitalization class is used |
enFreeMDChoice: 4 | The hospitalization class with free choice of physician is used |
space


  • Type definitions
  • HospitalizationModeType

HospitalizationModeType enumeration type |  |
Enumerates the defined modes/indications of the hospitalization |  | space
space
Set of enumeration values |  | 3 elements
enCantonal: 0 | Mode of hospitalization is cantonal |
enIndicated: 1 | Mode of hospitalization is non-cantonal (person living in another canton then treated) but indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |
enNonIndicated: 2 | Mode of hospitalization is non-cantonal (person living in another canton then treated) and not indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |
space


  • Type definitions
  • HospitalizationType

HospitalizationType enumeration type |  |
Enumerates the defined types/reasons of the hospitalization |  | space
space
Set of enumeration values |  | 3 elements
enRegular: 0 | The reason of the hospitalization is regular and planned |
enEmergency: 1 | The reason of the hospitalization is due to an emergency |
enWelfare: 2 | The reason of the hospitalization is due to welfare ("Freiheitsenzug") |
space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning | space
space
space


  • Type definitions
  • IAddress

IAddress type |
The IAddress interface object | space
space
space


  • Type definitions
  • IPushAdminMessageRequest

IPushAdminMessageRequest type |
The IPushAdminMessageRequest interface object | space
space
space


  • Type definitions
  • IPushAdminMessageResult

IPushAdminMessageResult type |
The IPushAdminMessageResult interface object | space
space
space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
space
Set of enumeration values |  | 3 elements
enGerman: 1 | The language is German |
enFrench: 2 | The language is French |
enItalian: 3 | The language is Italian |
space


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal law set. |  | space
space
Set of enumeration values |  | 6 elements
enKVG: 0 | KVG - "Krankenversicherungsgesetz" |
enUVG: 1 | UVG - "Unfallversicherungsgesetz" |
enMVG: 2 | MVG - "Militäversicherungsgesetz" |
enIVG: 3 | IVG - "Invalidenversicherungsgesetz" |
enVVG: 4 | VVG - "Versicherungsvertragsgesetz" |
enORG: 5 | ORG - "Obligationenrecht" This is primarily for invoices e.g. of dentists. |
space


  • Type definitions
  • long

long type |
A 4-byte integer value. | space
space
space


  • Type definitions
  • MessageActionType

MessageActionType enumeration type |  |
Enumerates the defined message actions |  | space
space
Set of enumeration values |  | 4 elements
enActionScheduled: 0 | The message action is scheduled meaning that the given 'Message' is scheduled for the given 'Message Date' |
enActionCanceled: 1 | The message action is canceled meaning a prior scheduled 'Message' is now canceled |
enActionStart: 2 | The message action is start meaning that the given 'Message' begins now aka 'Message Date' |
enActionEnd: 3 | The message action is end meaning that the given 'Message' ends now aka at 'Message Date' |
space


  • Type definitions
  • MessageType

MessageType enumeration type |  |
Enumerates the defined principle message types |  | space
space
Set of enumeration values |  | 1 elements
enMessageTreatment: 0 | The message type is Treatment meaning that all message actions are related to a treatment |
space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined operation modus types |  | space
space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus - the data should not be forwarded to the receiver. |
space


  • Type definitions
  • ResidenceCodeType

ResidenceCodeType enumeration type |  |
Enumerates the defined admission or discharge locations where the patient is coming from or discharged to encoded by a terminal set of tokens |  | space
space
Set of enumeration values |  | 14 elements
enResidenceHome: 0 | the admission/discharge location is home |
enResidenceHomeSpitex: 1 | the admission/discharge location is home but having a spitex care as support |
enResidenceHospitalSame: 2 | the admission/discharge location is the same hospital as the current location |
enResidenceHospitalOther: 3 | the admission/discharge location is a different hospital to the current location |
enResidenceRetirementHome: 4 | the admission/discharge location is a retirement home |
enResidenceNursingHome: 5 | the admission/discharge location is a nursing home |
enResidencePsychiatricClinicSame: 6 | the admission/discharge location is the same psychiatric clinic as the current location |
enResidencePsychiatricClinicOther: 7 | the admission/discharge location is a different psychiatric clinic to the current location |
enResidenceRehabClinicSame: 8 | the admission/discharge location is the same rehabilitation clinic as the current location |
enResidenceRehabClinicOther: 9 | the admission/discharge location is a different rehabilitation clinic to the current location |
enResidenceBirthHouse: 10 | the admission/discharge location is a birth house |
enResidenceCorrectionalFacility: 11 | the admission/discharge location is a correctional facility |
enResidenceOther: 12 | the admission/discharge location is not mentioned above |
enResidenceUnknown: 13 | the admission/discharge location is unknown |
space


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined basic gender types. |  | space
space
Set of enumeration values |  | 2 elements
enMale: 0 | Male. |
enFemale: 1 | Female. |
space


  • Type definitions
  • TreatmentReasonType

TreatmentReasonType enumeration type |  |
Enumerates the list of defined treatment reasons. |  | space
space
Set of enumeration values |  | 6 elements
enDisease: 0 | The treatment reason is due to a disease. |
enAccident: 1 | The treatment reason is due to an accident |
enMaternity: 2 | The treatment reason is due to maternity |
enPrevention: 3 | The treatment reason is due to a prevention. |
enBirthdefect: 4 | The treatment reason is due to a birth defect |
enUnknown: 5 | The treatment reason is unknown |
space


  • Type definitions
  • TreatmentType

TreatmentType enumeration type |  |
Enumerates the top level treatment types. |  | space
space
Set of enumeration values |  | 2 elements
enAmbulatory: 0 | Ambulatory (out-patient) treatment. |
enStationary: 1 | Stationary (in-patient) treatment. |
space


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space
space
space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |
space


 Visual Basic code snippet for generating a pushAdminMessage XML infoset

Private Sub Command1_Click()

On Error GoTo Err_Trap

'### create main PushAdminMessageManager interface
Dim pushAdminMessageManagerEx As PUSHADMINMESSAGEMANAGER500Lib.PushAdminMessageManager
Set pushAdminMessageManagerEx = New PushAdminMessageManager

'### Set the module language to german
pushAdminMessageManagerEx.ModuleLanguage = enGerman

'### StatusRequest interface
Dim pushAdminMessageRequestEx As PUSHADMINMESSAGEMANAGER500Lib.PushAdminMessageRequest
Set pushAdminMessageRequestEx = pushAdminMessageManagerEx.PushAdminMessageRequest

'### Initialize the StatusRequest!!!
pushAdminMessageRequestEx.Initialize(enGerman)

'### create an address interface that is need to add all the following addresses
'### do not forget to initialize the IAddress interface befor using it
Dim addressEx As PUSHADMINMESSAGEMANAGER500Lib.Address
Set addressEx = pushAdminMessageRequestEx.CreateAddress

'### define the 'biller' of the ad minitrative message(required)
'### note that phone, fax and online data are optional
addressEx.Initialize
bStatus = addressEx.SetCompany("Biller AG", "Abteilung Inkasso", "")
bStatus = addressEx.SetPostal("Billerweg 128", "", "4414", "Frenkendorf", "", "")
bStatus = addressEx.AddPhone("956 99 00", "061", "", "")
bStatus = addressEx.SetOnline("info@biller.ch", "")
bStatus = pushAdminMessageRequestEx.SetBillerGLN("2011234567890", "H-1211-11", "", "", addressEx)

'### define the health insurance (required  as debitor address)
addressEx.Initialize
bStatus = addressEx.SetCompany("Krankenkasse AG", "Sektion Basel", "")
bStatus = addressEx.SetPostal("Kassengraben 222", "", "4000", "Basel", "", "")
bStatus = pushAdminMessageRequestEx.SetDebitor("2034567890222", "",addressEx)

'### define the patient (required)
'### note that more data are needed here (sex, birthdate,ssn). data from the insurance
'### card can be supplied as well
Dim dBirthdate As Date
dBirthdate = DateValue("1964-2-28")
addressEx.Initialize
bStatus = addressEx.SetPerson("Muster", "Peter", "Herr", "", "c/o Mieter Karl")
bStatus = addressEx.SetPostal("Musterstrasse 5", "", "7304", "Maienfeld", "", "")
bStatus = pushAdminMessageRequestEx.SetPatient(enMale,enGenderMale, dBirthdate, "756.1234.5678.90", addressEx)

'### set the applicable law (required)
bStatus = pushAdminMessageRequestEx.SetLaw(enKVG, 0, "", "123.45.678-012")

'### add the primary administrative message for a statioanry treatment
bStatus = pushAdminMessageRequestEx.SetMessage4Stationary(enActionStart, DateValue("2020-05-05"), enDisease, _
                                                          enRegular, enCantonal, enHospitalComfort, "M100",  _
                                                          "1.2.V02=3")

Dim bStatus As Boolean
'### set the transport, this is just an example
bStatus = pushAdminMessageRequestEx.SetTransport("2012345678901", "7601001304307", _
                                                 "7601001302112")

'### Finalize!!!
bStatus = pushAdminMessageRequestEx.Finalize()

'### PushAdminMessageResult interface
Dim pushAdminMessageResultEx As PUSHADMINMESSAGEMANAGER500Lib.PushAdminMessageResult

'### write eveything to a file
Dim lValidationError As Long
Dim lTimestamp As Long
Dim strTmpFile As String
Dim strUsedXSDSchema As String
bStatus = pushAdminMessageManagerEx.GetXML(0,strTmpFile, lValidationError, lTimestamp, _
                                           strUsedXSDSchema, pushAdminMessageResultEx)

'### release resources
Set pushAdminMessageRequestEx = Nothing
Set pushAdminMessageResultEx = Nothing
Set pushAdminMessageManagerEx = Nothing

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)
'### release resources
Set pushAdminMessageRequestEx = Nothing
Set pushAdminMessageResultEx = Nothing
Set pushAdminMessageManagerEx = Nothing

End Sub


 General use of the pushAdminMessage ATL COM module

The pushAdminMessageManager is an ATL COM module which provides methods to generate administrative messages like the starting or ending of a treatment. Such an administrative message is printed or a XML infoset is produced and pushed electronically to a recipient. In the latter case the info object optionally can be signed and/or encrypted. It is a design goal to keep the message parsing system standard minimal and thus to guarantee a very low-threshold and agile implementation.

To produce such an infoset, firstly an instance of the IPushAdminMessageRequest interface is retrieved by the property IPushAdminMessageManager::GetPushAdminMessageRequest. All the requested addresses and the primary administrative message can be set and defined by the supplied interface methods as SetPatient, SetMessage4Stationary,... The transport/routing information is set by the SetTransport method, whereas the reachability problem can be overcome by internally using the medSRS RESTful webservice queryRHS().

After all data are set, a XML file with a pushAdminMessage XML infoset is generated by the GetXML method. All data that was set via the IPushAdminMessageRequest interface can be read back with the IPushAdminMessageResult interface.

To get a starting point with the pushAdminMessageManager module there is a Visual Basic code snippet provided that demonstrates the principles for generating an administrative message XML infoset.


 How to generate PDF archive files of a request

To generate PDF archive files of a request in the pushAdminMessageManager use a special print object name (cf. Syntax of the printTemplate variable for an overview).

(PDF=PDF_file_to_generate;)
or
(PDF_NOPRINT=PDF_file_to_generate;)
is used as a print object name on the printTemplate variable of the Print method.

The "PDF" token means to print the request and generate the PDF files, whereas the "PDF_NOPRINT" token only generates the PDF file without physical printing.
This object definition is only used while printing and is ignored in the preview mode!

In its simplest form this means

     BSTR bstrPrintTemplate = "(PDF="+bstrPDFFile+";)";

     IHospitalMCDRequestManager::Print(bstrPrintTemplate,...);
in order to generate a PDF archive file of request.

Since the PDF generation is not the main purpose of the Print method this PDF feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • Only active in printing mode
  • No error propagation
  • The supplied PDF archive name must not exist
  • The directory where the PDF is stored must be writable


 How to print webstamps onto a request

To print a webstamp onto a request in the pushAdminMessageManager use a special print object name (cf. Syntax of the printTemplate variable for an overview).

(WEBSTAMP=file_path_of_BMP_file;)
as a print object name on the printTemplate variable of the Print method.

In its simplest form e.g. in the pushAdminMessageManager code this means

     BSTR bstrPrintTemplate = "(WEBSTAMP="+bstrBMPFile+";)";

     IPushAdminMessageManager::Print(bstrPrintTemplate,...);
in order to print a webstamp onto the first page.

Since the webstamp printing is not the main purpose of the Print method this feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped to the log file!

Boundary conditions:

  • No error propagation
  • The supplied BMP webstamp must exist


 Syntax of the printTemplate variable of the Print method

bstrPrintTemplate argument of the IPushAdminMessageManager::Print is either empty or of the general form given below.

If the bstrPrintTemplate variable is empty then the default print template (using the data language as language switch) is used.
However, bstrPrintTemplate can be used to change the normal printing behavior or changing printing objects dynamically. The following syntax is used as content of the bstrPrintTemplate variable:

[logTpl][(objectName1=text;...)][=printTemplateFile][#INIPATH=inipath]

where a [] pair defines an optional part. The commands are case insensitive.
  • logTpl: is the logical template name. Currently only logTpl=Detail is allowed.
  • objectName1=text; does a substitution of the content of the print object objectName1 by text. A print object is terminated by a semicolon and all print objects are enclosed in a () pair.

    There are 2 predefined pseudo print objects with a special meaning:

    • PDF for generating PDF files
    • WEBSTAMP for printing electronic stamps

  • printTemplateFile is an external print template file name (full path + name!). If an external print template is supplied it must be mapped against a logical template. Therefore detail=full_vps_file must be used!
  • #INIPATH=inipath defines a fully qualified path to a directory where the report engine searches the corresponding .vpd print template INI file. This allows for global settings of a print template in a LAN. The default inipath is the install directory of the Dll

Here are some usage examples:
  • bstrPrintTemplate: "" or bstrPrintTemplate: Detail
    denotes a standard printing situation
  • bstrPrintTemplate: (DOCUMENT_TITLE=Alternate title;) prints a substituted title as given above.
  • bstrPrintTemplate: detail=C:\myForms\myPrintForm.vps
    uses the print template "C:\myForms\myPrintForm.vps". An optional INI file with the name "C:\myForms\myPrintForm.vpd" is searched under this condition.
  • bstrPrintTemplate: #INIPATH=\\host1\\myForms\
    the default path for the ini files (place of the installed component) is changed to "\\host1\\myForms\". If "\\host1\\myForms\" is accessible by all hosts of the LAN then the same INI settings can be used.


 Introduction, overview and usage of the Restful Webservice Server

The application pushAdminMessageManagerServer500.exe is a Restful Webservice Server, that has the same interface methods/properties as the COM module pushAdminMessageManager500.dll.
This allows to create a programming semantically similar to the COM approach but under the Restful Webservice paradigm. Consequently, on the Restful Client side there are no prevailing dependencies on Microsoft platforms and/or on Microsoft resources such as the database technology. Of course, the installation location of the server software is still subject to these restrictions.

In the next section of this document, the installation, configuration and operation of pushAdminMessageManagerServer500.exe will be addressed.

Installation, registration and parameterization:
By installing the installer object pushAdminMessageManager500 the COM module pushAdminMessageManager500.dll as well as the out-of-process proxy component oopPushAdminMessageeManager500.exe is automatically installed/registered in the system. However, the pushAdminMessageManagerServer500.exe must be installed manually as a system service.
pushAdminMessageManagerServer500.exe -help | Creates a help window with the the name and full version of the applicationb as well as the currently define Webservice Endpoint. Furthermore the complete list of command line switches is shown.
pushAdminMessageManagerServer500.exe -install | Installs/registers the Restful Webservice Server as a system service. Please take into account, that the installation must be performed under administrator privileges
pushAdminMessageManagerServer500.exe -uninstall | Uninstalls the system service component. Please take into account, that the uninstallation must be performed under administrator privileges
pushAdminMessageManagerServer500.exe -setport X | Sets the port X as part of the Webservice Endpoint
Restful Webservice Endpoint:
Installing pushAdminMessageManagerServer500.exe as a service activates the Restful Webservice Endpoint:
http://localhost:35458/pushAdminMessageManagerServer500
which is subsumed as baseURL in the subsequent API documentation.

To run the webservice under a different URL or under https protocol, a permanent webservice target endpoint mapping is performed on the target system.
For example, under Apache, the following rewrite rule is defined:
<VirtualHost *:*>
    ProxyPreserveHost Off
    Header always set Access-Control-Allow-Origin "*"
    Header always set Access-Control-Max-Age "1000"
    Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

    ProxyPass /pushAdminMessageManager/500/ http://localhost:35458/pushAdminMessageManagerServer500/
    ProxyPassReverse /pushAdminMessageManager/500/ http://localhost:35458/pushAdminMessageManagerServer500/
</VirtualHost>
Restful Webservice Operation:
The service might be modified after installation, for example to start under a different account, to extend the recovery properties or to change the startup type. Finally, this should be set to 'Automatic' or 'Automatic (Delayed start)' so that the service is automatically available after a system restart.
Remarks about programming:
In the rest of this document we will discuss programming of the Restful web service and the differences to the C/C++ programming of the classic COM component.

As already mentioned, Restful programming is analogous to C++ programming with the addition that each instance of an interface (including the main interface) is created via the corresponding GET function. For example, an instance of the main interface is created with:
baseURL/IPushAdminMessageManager/GetCreatePushAdminMessageManager | returns the instance address as JSON out{pIPushAdminMessageManager: longValue,...}
In every further call of a method or a property of the main interface this instance address must be included as part of the JSON-In. The termination/deletion of an instance must be done via the corresponding PUT Destruct property:
baseURL/IPushAdminMessageManager/PutDestructPushAdminMessageManager | with JSON-In{pIPushAdminMessageManager: longValue}, deletes the corresponding main instance AND all at that moment still active dependent subinstances (subinstances which have been generated by the explicit main instance).
It should be noted that the webserver pushAdminMessageManagerServer500.exe performs an internal management of the generated instances and automatically deletes instances that have no activity for a defined period of 1 hour. If after the deletion a rest call with such an instance is made, an error (HTTP Status >= 400) is generated and the instance address is marked as unknown.
Code snippet:
Minimal code snippet to load an XML and produce a PDF representation of that input data:

    http://localhost:35458/pushAdminMessageManagerServer500/IPushAdminMessageManager/GetModuleVersion?pIPushAdminMessageManager=45467
        returns JSON-Out{pbstrModuleVersion: "1.00.010"}

    http://localhost:35458/pushAdminMessageManagerServer500/IPushAdminMessageManager/GetModuleLanguage?pIPushAdminMessageManager=45467
        returns JSON-Out{peLanguage: "1"}

    http://localhost:35458/pushAdminMessageManagerServer500/IPushAdminMessageManager/LoadXML?pIPushAdminMessageManager=45467&bstrInputFile=C%3A%5Ctest.xml&bstrToPFXFile=&bstrToPFXPassword=
        +  C:\test.xml
        returns JSON-Out{pIPushAdminMessage: 5788991}

    http://localhost:35458/pushAdminMessageManagerServer500/IPushAdminMessage/PutDestructPushAdminMessage
        JSON-IN(pIPushAdminMessage: 5788991}

    http://localhost:35458/pushAdminMessageManagerServer500/IPushAdminMessageManager/PutDestructPushAdminMessageManager
        JSON-IN{pIPushAdminMessageManager:45467}