 API browser of statusResponse430 COM module
Interface version: | 4.30
Interface date: | 26 Aug 2010

The StatusResponseManager is an ATL COM module which provides methods to load and analyze XML infosets of type statusResponse_430 where the queried request objects of type credit, invoice, reminder, and/or MCD enhanced by a processing status are supplied. The subchapter object reference provides an in-depth description of the concept of "object reference". If an insurance decides not to support the statusRequest/statusResponse system then a StatusResponse is returned where each given object reference has a status "unsupported". This status code basically signals that a status system is not implemented! |  | space
Interfaces |  | 2 interface
IStatusResponse | The interface IStatusResponse allows to read back all data that have been loaded with the IStatusResponseManager::LoadXML method. |
IStatusResponseManager | The main interface IStatusResponseManager -creatable in its own right- allows to load and analyze a XML infoset of type statusResponse_430. |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important information about the usage and handling of the module |  |
Document | General usage of the statusResponse COM module - an overview |
Document | VB code snippet for using the statusResponse COM module |
Document | Overview of the concept of "Object reference" |

© by sumex1.net - all rights reserved


  • statusResponse430
  • IStatusResponse

IStatusResponse interface |  | V4.30/26 Aug 2010
The IStatusResponse interface allows to read back all data that have been loaded with the IStatusResponseManager::LoadXML method. Primarily the status of the queried object references along with the object reference parameters are returned with the iterator pair GetFirstQueryObject / GetNextQueryObject. |  | space
Methods |  | 5 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetFirstQueryObject | Retrieves the first "response" object which is the request object enhanced with a status qualification |
GetNextQueryObject | Retrieves the next "response" object which is the request object enhanced with a status qualification |
GetResponse | Returns the primary parameters of the response infoset, namely the operation modus and language the infoset is formulated. |
GetTransport | Returns the transport information that defines the routing of the infoset |
Properties |  | 0 properties


  • IStatusResponse
  • GetAbortInfo

IStatusResponse::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponse
  • GetFirstQueryObject

IStatusResponse::GetFirstQueryObject method |  |  |
Retrieves the first "response" object which is the request object enhanced with a status qualification. VARIANT_FALSE is returned if the end of the object list is reached |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetFirstQueryObject( | ObjectType BSTR DATE long StatusType VARIANT_BOOL | *peObjectType, *pbstrRequestID, *pdRequestDate, *plRequestTimestamp, *peStatusType, *pbStatus); |
Calling argument description |  |  |
[out] ObjectType | *peObjectType | Defines the type of the object request |
[out] BSTR | *pbstrRequestID | The request ID is the identification of a request of that type (e.g. the invoice or reminder identification). This is one of 3 identifiers that form an object reference. The request ID is always defined by the sender of the original request since the object reference from the request is mirrored in the response. |
[out] DATE | *pdRequestDate | The request date is the date of a request of that type (e.g. the invoice or reminder date). This is one of 3 identifiers that form an object reference. The request date is always defined by the sender of the original request since the object reference from the request is mirrored in the response. |
[out] long | *plRequestTimestamp | The request timestamp is a UNIX timestamp defined at the moment of the XML infoset generation. This is one of 3 identifiers that form an object reference. The request timestamp is always defined by the sender of the original request since the object reference from the request is mirrored in the response. |
[out] StatusType | *peStatusType | The status of the queried request object valid encoded by a terminal set of status tokens. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponse
  • GetNextQueryObject

IStatusResponse::GetNextQueryObject method |  |  |
Retrieves the next "response" object which is the request object enhanced with a status qualification. VARIANT_FALSE is returned if the end of the object list is reached |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetNextQueryObject( | ObjectType BSTR DATE long StatusType VARIANT_BOOL | *peObjectType, *pbstrRequestID, *pdRequestDate, *plRequestTimestamp, *peStatusType, *pbStatus); |
Calling argument description |  |  |
[out] ObjectType | *peObjectType | Defines the type of the object request |
[out] BSTR | *pbstrRequestID | The request ID is the identification of a request of that type (e.g. the invoice or reminder identification). This is one of 3 identifiers that form an object reference. The request ID is always defined by the sender of the original request since the object reference from the request is mirrored in the response. |
[out] DATE | *pdRequestDate | The request date is the date of a request of that type (e.g. the invoice or reminder date). This is one of 3 identifiers that form an object reference. The request date is always defined by the sender of the original request since the object reference from the request is mirrored in the response. |
[out] long | *plRequestTimestamp | The request timestamp is a UNIX timestamp defined at the moment of the XML infoset generation. This is one of 3 identifiers that form an object reference. The request timestamp is always defined by the sender of the original request since the object reference from the request is mirrored in the response. |
[out] StatusType | *peStatusType | The status of the queried request object valid encoded by a terminal set of status tokens. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponse
  • GetResponse

IStatusResponse::GetResponse method |  |  |
Returns the primary parameters of the response infoset, namely the operation modus and language the infoset is formulated. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetResponse( | LanguageType ModusType VARIANT_BOOL | *peDataLanguage, *peModusType, *pbStatus); |
Calling argument description |  |  |
[out] LanguageType | *peDataLanguage | The language in which the response is formulated. Note, that the data language and the module language (given by IStatusResponseManager::SetModuleLanguage) are independent and can be different! |
[out] ModusType | *peModusType | The operation modus. The default modus is enProduction whereas for developing/debugging purposes enTest has to be set. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponse
  • GetTransport

IStatusResponse::GetTransport method |  |  |
Returns the transport information that defines the routing of the infoset. In fact the meaning and the data is mirrored from the corresponding request thus the initial sender becomes the recipient and the initial recipient becomes the sender. Furthermore the chain of intermediates from the request is reversed and the infoset is sent to the first intermediate of the reversed list. The given intermediate here is therefore the last one before reaching the receiver. All the involved parties are defined by EAN numbers as defined by www.medwin.ch. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetTransport( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrFromEAN, *pbstrViaEAN, *pbstrToEAN, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrFromEAN | The EAN number of the sender. Note that this is the initial receiver of the request since the transport information from the request is mirrored in the response |
[out] BSTR | *pbstrViaEAN | The EAN number of the last intermediate. Note that this is the initial (first) intermediate of the request since the transport information from the request is mirrored in the response |
[out] BSTR | *pbstrToEAN | The EAN number of the receiver. Note that this is the initial sender of the request since the transport information from the request is mirrored in the response |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponseManager

IStatusResponseManager interface | V4.30/26 Aug 2010
The IStatusResponseManager interface allows to load and analyze a XML infoset of type statusResponse_430. Such an infoset supplies the status of a set of object references that have been sent to an insurance. The type of query objects covers credit, invoice, reminder, and MCD object references.

The subchapter object reference provides an in-depth description of the concept of "object reference".

To analyze such an infoset, firstly the file is loaded into memory by the LoadXML method. This method -upon successful loading- returns the IStatusResponse interface. Using this interface all data especially the object references enhanced with a processing status can be extracted.

If an insurance decides not to support the statusRequest/statusResponse system then a StatusResponse is returned where each given object reference has a status "unsupported". This status code basically signals that a status system is not implemented!

space
Methods | 5 methods
GetAbortInfo | Get the abort information string with the error coded in the module language
GetLogSettings | Get the log settings for the module.
GetXMLInfo | Preloads and analyzes a XML infoset regarding the full schema name and version
LoadXML | Loads a received XML infoset of type statusRequest_430.xsd into memory for further processing via the returned interface handle.
SetLogSettings | Set the log settings for the module
Properties | 3 properties
[get/put] ModuleLanguage | Get/Set the language for the module i.e
[get] ModuleVersion | Gets the version of the StatusResponseManager module.
[get] ModuleVersionText | Get the textual version of the StatusResponseManager module.


  • IStatusResponseManager
  • GetAbortInfo

IStatusResponseManager::GetAbortInfo method |  |  |
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string coded in the module language. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponseManager
  • GetLogSettings

IStatusResponseManager::GetLogSettings method
Get the log settings for the module. | space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
Calling argument description
[out] long *plLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] long | *plMaxSizeKB | The maximum size in KB of the log file.
[out] YesNoType | *peDoArchive | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] BSTR | *pbstrArchiveDir | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IStatusResponseManager
  • GetXMLInfo

IStatusResponseManager::GetXMLInfo method |  |  |
Preloads and analyzes a XML infoset regarding the full schema name and version. If the XML infoset is of the correct type statusRequest_430.xsd then the transport information fromEAN and toEAN are additionally extracted. The XSD name is set even if an error is generated. |  |  | space
C/C++ calling syntax |  |  |
HRESULT GetXMLInfo( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrInputFile, *pbstrUsedSchema, *pbstrFromEAN, *pbstrToEAN, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrInputFile | The full file name (path + name) of a XML infoset of type statusResponse_430.xsd |
[out] BSTR | *pbstrUsedSchema | The full XSD name of the loaded XML file. Only statusResponse_430.xsd is currently allowed. |
[out] BSTR | *pbstrFromEAN | The EAN number of the sender. Note that this is the initial receiver of the request since the transport information from the request is mirrored in the response |
[out] BSTR | *pbstrToEAN | The EAN number of the receiver. Note that this is the initial sender of the request since the transport information from the request is mirrored in the response |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponseManager
  • LoadXML

IStatusResponseManager::LoadXML method |  |  |
Loads a received XML infoset of type statusRequest_430.xsd into memory for further processing via the returned interface handle. |  |  | space
C/C++ calling syntax |  |  |
HRESULT LoadXML( | BSTR IStatusResponse VARIANT_BOOL | bstrInputFile, **ppIStatusResponse, *pbStatus); |
Calling argument description |  |  |
[in] BSTR | bstrInputFile | The full file name (path + name) of a XML infoset of type statusResponse_430.xsd |
[out] IStatusResponse | **ppIStatusResponse | The IStatusResponse interface handle that allows to get all loaded data back. The handle is NULL if an error occurred. |
[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
C/C++ return value |  |  |
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE. |  |
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE. |  |
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |  |


  • IStatusResponseManager
  • SetLogSettings

IStatusResponseManager::SetLogSettings method
Set the log settings for the module.

The defaults for the log activity are: level=1, lMaxSizeKB=1000,eDoArchive=enNo,
and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.

space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.

[in] long lMaxSizeKB The maximum size in KB of the log file.
Any size below 1000 KB (= the default value) is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!

[out, retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


  • IStatusResponseManager
  • ModuleLanguage

IStatusResponseManager::ModuleLanguage property
Get/Set the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by IStatusResponse::GetResponse) are independent and can be different!

space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *aLanguageType);
[put] HRESULT | ModuleLanguage( LanguageType aLanguageType);
space
Calling argument description
[out,retval] LanguageType | *aLanguageType
[in] LanguageType | aLanguageType
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType aLanguageType);
space


  • IStatusResponseManager
  • ModuleVersion

IStatusResponseManager::ModuleVersion property
Gets the version of the StatusResponseManager module. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IStatusResponseManager
  • ModuleVersionText

IStatusResponseManager::ModuleVersionText property
Get the textual version of the StatusResponseManager module. | space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *aBSTR);
space
Calling argument description
[out, retval] BSTR | *aBSTR
C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • Type definitions

Builtin, composite & enumeration types |  | V4.30/26 Aug 2010
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
Data types |  | 11 types
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[builtin] DATE | A value denoting a date and time was specified |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning. |
[builtin] IStatusResponse | The IStatusResponse interface |
[enumeration] LanguageType | Enumerates all supported languages. |
[builtin] long | A 4-byte integer value. |
[enumeration] ModusType | Enumerates the defined modus types. |
[enumeration] ObjectType | Enumerates the defined object types that can be queried |
[enumeration] StatusType | Enumerates the defined status types that a queried request object can posses |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator. |


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space


  • Type definitions
  • DATE

DATE type |
A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date. | space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning. | space


  • Type definitions
  • IStatusResponse

IStatusResponse type |
The IStatusResponse interface | space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
Set of enumeration values |  | 3 elements
enGerman: 1 | German. |
enFrench: 2 | French. |
enItalian: 3 | Italian. |


  • Type definitions
  • long

long type |
A 4-byte integer value. | space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined modus types. |  | space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus the invoice will not be forwarded to the receiver. |


  • Type definitions
  • ObjectType

ObjectType enumeration type |  |
Enumerates the defined object types that can be queried |  | space
Set of enumeration values |  | 4 elements
enObjectCredit: 1 | The object is of type credit. |
enObjectInvoice: 2 | The object is of type invoice. |
enObjectReminder: 3 | The object is of type reminder. |
enObjectMCD: 4 | The object is of type MCD (Minimal Clinical Dataset). |


  • Type definitions
  • StatusType

StatusType enumeration type |  |
Enumerates the defined status types that a queried request object can posses |  | space
Set of enumeration values |  | 10 elements
enStatusUnsupported: 1 | The status is unsupported is supplied if and only if the insurance does not support the status system at all |
enStatusUnknown: 2 | The status is unknown meaning that the given object reference is unknown. |
enStatusAmbiguous: 3 | The status is ambiguous meaning that the given object reference delivers more than one result. |
enStatusReceived: 4 | The status is received meaning that nothing has been done so far except receiving the request. |
enStatusFrozen: 5 | The status is frozen meaning that the request is not processed until further data is provided - an appropriate response of that type was sent. |
enStatusProcessed: 6 | The status is processed meaning that the request has passed all processing and analysis but has not reached the granted or canceled state. |
enStatusGranted: 7 | The status is granted meaning that the request is accepted and archived. If the request was an invoice or reminder then the requested amount was paid to the biller. |
enStatusCanceled: 8 | The status is canceled meaning that the request is canceled and archived with reject status - an appropriate response of that type was sent |
enStatusClaimed: 9 | The status is claimed meaning that a reimbursement process was invoked by sending back the payback information. This status can only be used for invoices and reminders |
enStatusReimbursed: 10 | The status is reimbursed meaning that the reimbursement process was completed as the amount was paid back by the biller. This status can only be used for invoices and reminders |


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |


 VB code snippet for using the statusResponseManager

Private Sub StatusResponseExampleBtn_Click()

On Error GoTo Err_Trap

'### StatusResponseManager Interface
Dim statusResponseManagerEx As STATUSRESPONSEMANAGER430Lib.StatusResponseManager
Set statusResponseManagerEx = New StatusResponseManager

'### StatusResponse Interface
Dim statusResponseEx As StatusResponse
Dim bStatus As Boolean

Dim strOutput As String
strOutput = ""

'### Open the response xml File
bStatus = statusResponseManagerEx.LoadXML("response01.xml", statusResponseEx)
If (bStatus) Then
    Dim pObjectType As STATUSRESPONSEMANAGER430Lib.ObjectType
    Dim pStatusType As STATUSRESPONSEMANAGER430Lib.StatusType
    Dim lTimestamp As Long
    Dim dRequestDate As Date
    Dim strRequestID As String

    '### Get the first entry
    bStatus = statusResponseEx.GetFirstQueryObject(pObjectType, strRequestID, dRequestDate,  _
                                                   lTimestamp, pStatusType)
    If (bStatus) Then
         strOutput = strOutput + strRequestID + " " + Str(lTimestamp) + " " +  _
                     Format(dRequestDate, "YYYY-MM-DDTHH:MM:SS") + vbCrLf
        '### Loop through all remaining entries
        Do While statusResponseEx.GetNextQueryObject(pObjectType, strRequestID, dRequestDate,  _
                                                     lTimestamp, pStatusType)
            strOutput = strOutput + strRequestID + " " + Str(lTimestamp) + " " +  _
                        Format(dRequestDate, "YYYY-MM-DDTHH:MM:SS") + vbCrLf
        Loop
    Else
        strOutput = "No results have been found"
    End If
Else
    strOutput = "Failed to open document"
End If

MsgBox (strOutput)

'### relase resources
Set statusResponseEx = Nothing
Set statusResponseManagerEx = Nothing

Exit Sub

Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)
'### relase resources
Set statusResponseEx = Nothing
Set statusResponseManagerEx = Nothing

End Sub


 General use of the statusResponse ATL COM module

The StatusResponse ATL COM module provides methods to load and analyze XML infosets of type statusResponse_430. Such a XML infoset supplies the processing status of the queried request objects all of them of type credit, invoice, reminder, and/or MCD.

The subchapter object reference provides an in-depth description of the concept of "object reference".

To get the results of such an infoset, firstly the XML file is loaded into the module by the LoadXML method. Upon successful analyzing the file the method returns a IStatusResponse interface.

All data are returned with the various methods of that interface. E.g. the iterator pair GetFirstQueryObject / GetNextQueryObject returns the reference objects enhanced by a processing status of that object.

If an insurance decides not to support the statusRequest/statusResponse system then a StatusResponse is returned where each given object reference has a status "unsupported". This status code basically signals that a status system is not implemented!

To get a starting point with the statusResponse module there is a Visual Basic code snippet provided that demonstrates the principles for processing status response XML infosets.


 Object reference...

The following paragraph defines the concept of object reference. This concept is of high importance within the statusResponse COM module and its generated XML infosets.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each object reference of a request XML infoset is send back unaltered in the response, since the object reference uniquely identifies the request.

Each and every XML request of version 4.3 is defined by such an object reference. All XML responses are replies to the object reference of the corresponding request.

Thus the object reference is a clustered primary key of the request/response system!