Validators: tarmedTPV overview

 tarmedTPV module - API browser

Interface version: | 1.00
Interface date: | 1 Mar 2005
The tarmedTPV is an ATL COM module which provides methods to query and return Tarmed tax point values (TPV) in regard to some basic input parameters.

Interfaces | 1 interfaces
ITarmedTPV |
Types |
type definitions | list of all used builtin, composite and enumeration types
Important information about the usage and handling of the module
Document: | General useage of the tarmedTPV module

© by sumex1.net - all rights reserved


 ITarmedTPV interface

Description V1.00/ 1 Mar 2005
The ITarmedTPV interface handles connections to the tarmedTPV database and provides three search functions SearchTPVPhysician, SearchTPVHospital, and SearchTPVContract for querying the tax point values of a physician (inclusive a "Belegarzt"), a hospital, or by a Santésuisse contract id, respectively. The iterators getFirstTPV and getNextTPV than deliver the requested result information. Of course, a connection to the database must be opened prior to any query.
tarmedTPV
ITarmedTPV

Methods 9 methods
Close | OpenEx
GetAbortInfo | SearchTPVContract
GetFirstTPV | SearchTPVHospital
GetNextTPV | SearchTPVPhysician
Open |

Properties 7 properties
[get] | DBVersion | [get/put] | Language
[get] | DBVersionDate | [get] | ModuleVersion
[get] | DBVersionText | [get] | ModuleVersionText
[get/put] | EnableLog |  |


 ITarmedTPV::Close method

Closes the tarmed tpv database
tarmedTPV
ITarmedTPV
Close

C/C++ syntax
HRESULT Close( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::GetAbortInfo method

Get the abort information.
tarmedTPV
ITarmedTPV
GetAbortInfo

C/C++ syntax
HRESULT GetAbortInfo( | BSTR | *pbstrAbort,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | BSTR | *pbstrAbort | Abort information string
[out, retval] | VARIANT_BOOL | *pbStatus | Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::GetFirstTPV method

Retrieves the first tax point value record.
tarmedTPV
ITarmedTPV
GetFirstTPV

C/C++ syntax
HRESULT GetFirstTPV( | double | *pdTPV_MT,
 | double | *pdTPV_TT,
 | BSTR | *pbstrLocationID,
 | DATE | *pdDateValidFrom,
 | DATE | *pdDateValidTo,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | double | *pdTPV_MT | TPV of the medical part
[out] | double | *pdTPV_TT | TPV of the technical part
[out] | BSTR | *pbstrLocationID | If set then the returned TPV is specifically for the given location. Note that this parameter is currently set empty as there are not yet special tax point values defined per location
[out] | DATE | *pdDateValidFrom | TPV is valid from the given date on
[out] | DATE | *pdDateValidTo | TPV is valid until the given date
[out, retval] | VARIANT_BOOL | *pbStatus | Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::GetNextTPV method

Retrieves the next tax point value record.
tarmedTPV
ITarmedTPV
GetNextTPV

C/C++ syntax
HRESULT GetNextTPV( | double | *pdTPV_MT,
 | double | *pdTPV_TT,
 | BSTR | *pbstrLocationID,
 | DATE | *pdDateValidFrom,
 | DATE | *pdDateValidTo,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[out] | double | *pdTPV_MT | TPV of the medical part
[out] | double | *pdTPV_TT | TPV of the technical part
[out] | BSTR | *pbstrLocationID | If set then the returned TPV is specifically for the given location. Note that this parameter is currently set empty as there are not yet special tax point values defined per location
[out] | DATE | *pdDateValidFrom | TPV is valid from the given date on
[out] | DATE | *pdDateValidTo | TPV is valid until the given date
[out, retval] | VARIANT_BOOL | *pbStatus | Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::Open method

Opens the tarmedTPV database.
tarmedTPV
ITarmedTPV
Open

C/C++ syntax
HRESULT Open( VARIANT_BOOL *pbStatus);

Parameter description
[out, retval] VARIANT_BOOL *pbStatus Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::OpenEx method

Opens the tarmedTPV database by supplying the connect string to an ADO object directly
tarmedTPV
ITarmedTPV
OpenEx

C/C++ syntax
HRESULT OpenEx( | BSTR | bstrConnect,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | BSTR | bstrConnect | Connect string for the database. See the documentation of the Open method of an ADO Connection object for a detailed description.
[out, retval] | VARIANT_BOOL | *pbStatus | Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::SearchTPVContract method

Searches for tax point values in the given date interval for a contract id as defined by Santésuisse (KVG only). In order to supply UVG, IVG, and MVG data as well the virtual contract ids CHAE and CHOSPS have been defined for the physician's and hospital's tax point values, respecively.
tarmedTPV
ITarmedTPV
SearchTPVContract

C/C++ syntax
HRESULT SearchTPVContract( | BSTR | bstrContractID,
 | double | dDateValidFrom,
 | double | dDateValidTo,
 | long | *plNumRecords,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | BSTR | bstrContractID | Contract ID as defined by Santésuisse (KVG only) or "CHAE" and "CHOSPS" to request the physician's or hospital's UVG, IVG, and MVG tax point values, respecively.
[in] | double | dDateValidFrom | Starting date of requested date interval
[in] | double | dDateValidTo | Ending date of requested date interval
[out] | long | *plNumRecords | Number of result records
[out, retval] | VARIANT_BOOL | *pbStatus | Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::SearchTPVHospital method

Searches for tax point values in the given date interval for hospitals.
Please note that a "Belegarzt" must use the SearchMDTPV function to query for the correct tax point values (do not use the SearchHospitalTPV)!
tarmedTPV
ITarmedTPV
SearchTPVHospital

C/C++ syntax
HRESULT SearchTPVHospital( | BSTR | bstrLocationID,
 | LawType | eLaw,
 | CantonType | eCanton,
 | HospitalType | eHospitalType,
 | double | dDateValidFrom,
 | double | dDateValidTo,
 | long | *plNumRecords,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | BSTR | bstrLocationID | EAN or ZSR number of a specific location to search for special tax point values. Note that this location id is currently ignored as there are not yet special tax point values defined per location (use contracts instead)
[in] | LawType | eLaw | Law type
[in] | CantonType | eCanton | Canton type
[in] | HospitalType | eHospitalType | Hospital type
[in] | double | dDateValidFrom | Starting date of requested date interval
[in] | double | dDateValidTo | Ending date of requested date interval
[out] | long | *plNumRecords | Number of result records
[out, retval] | VARIANT_BOOL | *pbStatus | Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::SearchTPVPhysician method

Searches for tax point values in the given date interval for physicians.
Please note that a "Belegarzt" must use this function to query for the correct tax point values (do not use the SearchHospitalTPV)!
tarmedTPV
ITarmedTPV
SearchTPVPhysician

C/C++ syntax
HRESULT SearchTPVPhysician( | BSTR | bstrLocationID,
 | LawType | eLaw,
 | CantonType | eCanton,
 | double | dDateValidFrom,
 | double | dDateValidTo,
 | long | *plNumRecords,
 | VARIANT_BOOL | *pbStatus);

Parameter description
[in] | BSTR | bstrLocationID | EAN or ZSR number of a specific location to search for special tax point values. Note that this location id is currently ignored as there are not yet special tax point values defined per location (use contracts instead)
[in] | LawType | eLaw | Law type
[in] | CantonType | eCanton | Canton type
[in] | double | dDateValidFrom | Starting date of requested date interval
[in] | double | dDateValidTo | Ending date of requested date interval
[out] | long | *plNumRecords | Number of result records
[out, retval] | VARIANT_BOOL | *pbStatus | Return status

C/C++ return value
S_OK | This value is returned if the function call was successful or if the return value of a boolean method signalling a true value. In this case the VARIANT_BOOL is set to VARIANT_TRUE.
S_FALSE | This is the return value of a boolean method signalling a false return value. In this case the VARIANT_BOOL is set to VARIANT_FALSE.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.


 ITarmedTPV::DBVersion property

Get the version of the tarmedTPV database.
tarmedTPV
ITarmedTPV
DBVersion

C/C++ syntax
[get] HRESULT DBVersion( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetDBVersion(void);


 ITarmedTPV::DBVersionDate property

Get the version date of the tarmedTPV database.
tarmedTPV
ITarmedTPV
DBVersionDate

C/C++ syntax
[get] HRESULT DBVersionDate( DATE *aDATE);

Parameter description
[out, retval] DATE *aDATE

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • DATE *GetDBVersionDate(void);


 ITarmedTPV::DBVersionText property

Get the textual version of the tarmedTPV database.
tarmedTPV
ITarmedTPV
DBVersionText

C/C++ syntax
[get] HRESULT DBVersionText( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetDBVersionText(void);


 ITarmedTPV::EnableLog property

Get and Set the log activity for the module. The default log activity is enYes.
tarmedTPV
ITarmedTPV
EnableLog

C/C++ syntax
[get] HRESULT EnableLog( | YesNoType | *aYesNoType);
[put] HRESULT EnableLog( | YesNoType | aYesNoType);

Parameter description
[out,retval]
[in] 		YesNoType
YesNoType 		*aYesNoType
aYesNoType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • YesNoType *GetEnableLog(void);
  • void PutEnableLog(YesNoType aYesNoType);


 ITarmedTPV::Language property

Get and Set the language for the tarmedTPV module. The default language is enGerman.
tarmedTPV
ITarmedTPV
Language

C/C++ syntax
[get] HRESULT Language( | LanguageType | *aLanguageType);
[put] HRESULT Language( | LanguageType | aLanguageType);

Parameter description
[out,retval]
[in] 		LanguageType
LanguageType 		*aLanguageType
aLanguageType

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • LanguageType *GetLanguage(void);
  • void PutLanguage(LanguageType aLanguageType);


 ITarmedTPV::ModuleVersion property

Get the version of the tarmedTPV module.
tarmedTPV
ITarmedTPV
ModuleVersion

C/C++ syntax
[get] HRESULT ModuleVersion( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetModuleVersion(void);


 ITarmedTPV::ModuleVersionText property

Get the textual version of the tarmedTPV module.
tarmedTPV
ITarmedTPV
ModuleVersionText

C/C++ syntax
[get] HRESULT ModuleVersionText( BSTR *aBSTR);

Parameter description
[out, retval] BSTR *aBSTR

C/C++ return value
S_OK | This value is returned if the function call was successful.
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that an exception is thrown under these conditions if you are using SmartPointers.

Remarks
If you are using SmartPointers the function names and calls are rewritten by Microsoft into the form:
  • BSTR *GetModuleVersionText(void);


all type definitions

 All builtin, composite and enumeration types

The following list shows all used types either basic builtin, composite or enumeration that are used in the public interface of the ATL COM module.
tarmedTPV
Type definitions

All used types 12 types
[enumeration] | AbortValidateType | [builtin] | BSTR
[enumeration] | CantonType | [builtin] | DATE
[builtin] | double | [enumeration] | HospitalType
[builtin] | HRESULT | [enumeration] | LanguageType
[enumeration] | LawType | [builtin] | long
[builtin] | VARIANT_BOOL | [enumeration] | YesNoType


 AbortValidateType enumeration type

Enumerates the defined grounds for an aborted validation attempt.
tarmedTPV
Type definitions
AbortValidateType

Set of enumeration values 2 values
enDatabaseNotOpen | The database is not open.
enNoTPValueFound | The tax point value could not be determined.


 BSTR type

A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions.
BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms.
tarmedTPV
Type definitions
BSTR


 CantonType enumeration type

Enumerates the defined canton categories.
tarmedTPV
Type definitions
CantonType

Set of enumeration values 31 values
enCantonUndefined | enCantonUndefined (implicitly sets the canton=CH!)
enAG | AG
enAI | AI
enAR | AR
enBE | BE
enBL | BL
enBS | BS
enFR | FR
enGE | GE
enGL | GL
enGR | GR
enJU | JU
enLU | LU
enNE | NE
enNW | NW
enOW | OW
enSG | SG
enSH | SH
enSO | SO
enSZ | SZ
enTG | TG
enTI | TI
enUR | UR
enVD | VD
enVS | VS
enZG | ZG
enZH | ZH
enGermany | Germany
enItaly | Italy
enFrance | France
enLiechtenstein | Liechtenstein


 DATE type

A value denoting a date and time was specified. Dates are represented as double-precision numbers, where midnight, January 1, 1900 is 2.0, January 2, 1900 is 3.0, and so on. The value is passed in date.
tarmedTPV
Type definitions
DATE


 double type

An 8-byte IEEE real value.
tarmedTPV
Type definitions
double


 HospitalType enumeration type

Enumerates the supported hospital types
Type definitions
HospitalType

Set of enumeration values 2 values
enPublicHospital | Publicly owned hospital
enPrivateHospital | Privately owned hospital


 HRESULT type

The HRESULT data type is a 32-bit value that is used to describe an error or warning.
tarmedTPV
Type definitions
HRESULT


 LanguageType enumeration type

Enumerates all supported languages.
tarmedTPV
Type definitions
LanguageType

Set of enumeration values 3 values
enGerman | German
enFrench | French.
enItalian | Italian


 LawType enumeration type

Enumerates the supported legal set of applicable laws.
tarmedTPV
Type definitions
LawType

Set of enumeration values 5 values
enKVG | KVG
enUVG | UVG
enMVG | MVG
enIVG | IVG
enVVG | VVG


 long type

A 4-byte integer value.
tarmedTPV
Type definitions
long


 VARIANT_BOOL type

A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid.
tarmedTPV
Type definitions
VARIANT_BOOL


 YesNoType enumeration type

Boolean enumerator.
tarmedTPV
Type definitions
YesNoType

Set of enumeration values 2 values
enNo | No.
enYes | Yes.


General use of the tarmedTPV module/en

General use of the tarmedTPV ATL COM module

  • First create an instance of the tarmedTPV COM module.
  • Open the tarmedTPV database with the Open method from the ITarmedTPV interface. Set the localization language (if it differs from the default setting of German) using the SetLanguage from the ITarmedTPV interface.
  • The following steps may then be performed, until the tarmedTPV module instance is released:
  • Let the user search for a tax point values valid in a certain date interval by either using the ITarmedTPV::SearchTPVPhysician, ITarmedTPV::SearchTPVHospital or ITarmedTPV::SearchTPVContract methods.
    Note that the SearchMDTPValue method shhould be used for "Belegärzte".
  • Call the ITarmedTPV::GetFirstTPV, ITarmedTPV::GetNextTPV methods to retrieve all result records.
  • Release the tarmedTPV COM module instance.