 API browser of generalCreditRequest450 COM module
Interface version: | 4.50
Interface date: | 1 Nov 2019

The GeneralCreditRequestManager is an ATL COM module which provides methods to generate a general credit requests for all roles and places. Such a general credit object is printed or a XML infoset is produced which can be transported electronically to a recipient. In the latter case the object optionally can be signed and/or encrypted . Due to the processing attributes "storno" and "copy" a previously generated object can be canceled or a copy can be produced. The subchapter object reference provides an in-depth description of the concept of "object reference". |  | space
Interfaces |  | 4 interface
IAddress | The utility interface IAddress is available for setting and retrieving structured address data. |
IGeneralCreditRequest | With the IGeneralCreditRequest interface all general credit related data can be set/defined by the interface's methods. |
IGeneralCreditRequestManager | The main interface IGeneralCreditRequestManager -creatable in its own right- provides methods to generate a general credit for all roles and places. Furthermore, created XML infosets can be loaded back into memory for further processing. |
IGeneralCreditResult | The interface IGeneralCreditResult allows to read back all data that have been defined with the IGeneralCreditRequest interface or by loading a previously generated XML infoset. |
Types |  |
type definitions | List of all used builtin, composite and enumeration types |
Important documents about the usage and handling |  |
Document | General usage of the generalCreditRequest450 COM module - an overview |
Document | What to do in a 64bit environment - is there a 64bit Sumex1 COM dll? |
Document | Overview of the concept of "Object reference" |
Document | Notes about the processing attributes |
Document | Notes about the signature part of the XML infoset |
Document | Notes about the encryption part of the XML infoset |
Document | Overview about how to best generate a copy, storno,... |
Document | How to set the default printer for a care credit request |
Document | Syntax of the printTemplate variable of the Print method |
Document | How to print electronic stamps onto a care credit request |
Document | How to generate a PDF archive file of a care credit request |
Document | VB/CS code snippet for using the generalCreditRequest450 COM module |
Document | generalCreditRequestManagerServer450: Introduction, overview and usage of the Restful Webservice Server |
04.04.2020 - API Patch | Documentation: query/check the reachability of a recipient by using medSRS |
Important external documents |  |
CHM File | Schema documentation of generalCreditRequest_450 in CHM format |
ZIP Archive | Print template layout & documentation of generalCreditRequest_450 in PDF format |
ZIP Archive | ZIP archive with the generalCreditRequest_450.xsd schema and the accompanying auxiliary schema files |
ZIP Archive | ZIP archive with some XML test files and PDF output files of generalCreditRequest450 type |

© by sumex1.net - all rights reserved


  • generalCreditRequest450
  • IAddress

IAddress interface |  | V4.50/ 1 Nov 2019
With the IAddress interface structured address data can be set and retrieved. The whole address can be seen as a collection of substructures like the name, the postal part, a communication part etc. Where each of these sub structure can be set or retrieved by an interface method. The name part of a person is set by the method SetPerson and a company's name is entered by the method SetCompany. Before setting a new address the internal data has to be initialized by the method Initialize. |  | space
space
Methods |  | 16 methods
AddPhone | Adds a structured phone number |
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetCompany | Retrieves the company's naming part of the address |
GetFax | Retrieves the structured fax number |
GetFirstPhone | Retrieves the first phone number information |
GetNextPhone | Retrieves the next phone number information |
GetOnline | Retrieves the structured online part of the address |
GetPerson | Retrieves the person's naming part of the address |
GetPhones | Method for collecting all phone numbers covered by the address and returned as JSON array |
GetPostal | Retrieves the structured postal address part of the address. |
Initialize | Initializes all internal address variables |
SetCompany | Sets the company's naming part of the address |
SetFax | Sets a structured fax number |
SetOnline | Sets the structured online part of the address. |
SetPerson | Sets the person's naming part of the address |
SetPostal | Sets the structured postal address part |
space
Properties |  | 2 properties
[put] DestructAddress | Destructs/invalidates this IAddress interface instance |
[get] Type | GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all |
space |


  • IAddress
  • AddPhone

IAddress::AddPhone method |  |  | space
Adds a structured phone number. The Swiss international calling code +41 is filtered out in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/AddPhone
[JSON input data] | pIAddress: bstrNumber: bstrLocalCode: bstrInternationalCode: bstrExt: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrNumber | The pure phone number part of the telephone number. It is possible to set the full telephone number in this variable and leave the other parts of the telephone number empty |
[in] BSTR | bstrLocalCode | The local area code part of the telephone number. |
[in] BSTR | bstrInternationalCode | The international calling code part of the telephone number. |
[in] BSTR | bstrExt | The optional extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetAbortInfo

IAddress::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetAbortInfo
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IAddress
  • GetCompany

IAddress::GetCompany method |  |  | space
Retrieves the company's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetCompany
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrCompanyName: pbstrDepartment: pbstrSubaddressing: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetCompany( | BSTR BSTR BSTR VARIANT_BOOL | *pbstrCompanyName, *pbstrDepartment, *pbstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCompanyName | The company's name. |
[out] BSTR | *pbstrDepartment | The optional department part of the company. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetFax

IAddress::GetFax method |  |  | space
Retrieves the structured fax number. Empty variables are returned if there is no fax number available. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetFax
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure fax number part of the full fax number. It is possible that the full fax number is returned in this variable and the other parts of the fax number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the fax number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the fax number. |
[out] BSTR | *pbstrExt | The extension number part of the fax number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetFirstPhone

IAddress::GetFirstPhone method |  |  | space
Retrieves the first phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetFirstPhone
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetNextPhone

IAddress::GetNextPhone method |  |  | space
Retrieves the next phone number information. VARIANT_FALSE is returned if the end of the phone list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetNextPhone
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextPhone( | BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrNumber, *pbstrLocalCode, *pbstrInternationalCode, *pbstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetOnline

IAddress::GetOnline method |  |  | space
Retrieves the structured online part of the address. Empty variables are returned if there is no online information available. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetOnline
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrEMail: pbstrUrl: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetOnline( | BSTR BSTR VARIANT_BOOL | *pbstrEMail, *pbstrUrl, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEMail | A relevant email address. |
[out] BSTR | *pbstrUrl | A relevant URL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetPerson

IAddress::GetPerson method |  |  | space
Retrieves the person's naming part of the address. Call the property GetType first to test if GetPerson or GetCompany should be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPerson
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrFamilyname: pbstrGivenname: pbstrSalutation: pbstrTitle: pbstrSubaddressing: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFamilyname, *pbstrGivenname, *pbstrSalutation, *pbstrTitle, *pbstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrFamilyname | The family name (or last name) of the person. |
[out] BSTR | *pbstrGivenname | The given name (or first name) of the person. |
[out] BSTR | *pbstrSalutation | The optional salutation of the person. |
[out] BSTR | *pbstrTitle | The optional title of the person. |
[out] BSTR | *pbstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • GetPhones

IAddress::GetPhones method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all phone numbers covered by the address and returned as JSON array. Please note that IAddress::GetPhones takes over the functionality of the iterator pair IAddress::GetFirstPhone / IAddress::GetNextPhone with a single call, making the latter superfluous. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPhones
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result array] | { pbstrNumber: pbstrLocalCode: pbstrInternationalCode: pbstrExt: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrNumber | The pure phone number part of the full telephone number. It is possible that the full telephone number is returned in this variable and the other parts of the telephone number left empty. |
[out] BSTR | *pbstrLocalCode | The local area code part of the telephone number. |
[out] BSTR | *pbstrInternationalCode | The international calling code part of the telephone number. |
[out] BSTR | *pbstrExt | the extension number part of the telephone number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IAddress
  • GetPostal

IAddress::GetPostal method |  |  | space
Retrieves the structured postal address part of the address. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/GetPostal
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbstrStreet: pbstrPoBox: pbstrZip: pbstrCity: pbstrStateCode: pbstrCountryCode: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrStreet, *pbstrPoBox, *pbstrZip, *pbstrCity, *pbstrStateCode, *pbstrCountryCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrStreet | The street name part of an address. |
[out] BSTR | *pbstrPoBox | The P.O. box code part of an address. Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[out] BSTR | *pbstrZip | The ZIP code part of an address. |
[out] BSTR | *pbstrCity | The city name of an address. |
[out] BSTR | *pbstrStateCode | The optional state code part of an address. |
[out] BSTR | *pbstrCountryCode | The optional ISO country code part of an address. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • Initialize

IAddress::Initialize method |  |  | space
Initializes all internal address variables. This method should be called before new data is supplied to reset all internally stored data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/Initialize
[JSON input data] | pIAddress: | longValue, //interface address
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | VARIANT_BOOL | *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetCompany

IAddress::SetCompany method |  |  | space
Sets the company's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetCompany
[JSON input data] | pIAddress: bstrCompanyName: bstrDepartment: bstrSubaddressing: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetCompany( | BSTR BSTR BSTR VARIANT_BOOL | bstrCompanyName, bstrDepartment, bstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCompanyName | The company's name. |
[in] BSTR | bstrDepartment | The optional department part of the company. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetFax

IAddress::SetFax method |  |  | space
Sets a structured fax number. The Swiss international calling code +41 is filtered in the printing. If the main software does not support structured pone numbers then all data is supplied in the bstrNumber variable. However, +41 is then no longer filtered. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetFax
[JSON input data] | pIAddress: bstrNumber: bstrLocalCode: bstrInternationalCode: bstrExt: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetFax( | BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrNumber, bstrLocalCode, bstrInternationalCode, bstrExt, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrNumber | The pure fax number part of the fax number. It is possible to set the full fax number in this variable and leave the other parts of the fax number empty |
[in] BSTR | bstrLocalCode | The local area code part of the fax number. |
[in] BSTR | bstrInternationalCode | The international calling code part of the fax number. |
[in] BSTR | bstrExt | The extension number part of the fax number. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetOnline

IAddress::SetOnline method |  |  | space
Sets the structured online part of the address. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetOnline
[JSON input data] | pIAddress: bstrEMail: bstrUrl: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetOnline( | BSTR BSTR VARIANT_BOOL | bstrEMail, bstrUrl, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEMail | A relevant email address. |
[in] BSTR | bstrUrl | A relevant URL address. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetPerson

IAddress::SetPerson method |  |  | space
Sets the person's naming part of the address. Note that the subaddressing is part of the extended name and is always printed before any postal information. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetPerson
[JSON input data] | pIAddress: bstrFamilyname: bstrGivenname: bstrSalutation: bstrTitle: bstrSubaddressing: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPerson( | BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrFamilyname, bstrGivenname, bstrSalutation, bstrTitle, bstrSubaddressing, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrFamilyname | The family name (or last name) of the person. |
[in] BSTR | bstrGivenname | The given name (or first name) of the person. |
[in] BSTR | bstrSalutation | The optional salutation of the person. |
[in] BSTR | bstrTitle | The optional title of the person. |
[in] BSTR | bstrSubaddressing | The optional subaddressing information, e.g. a "c/o" like information as defined by the Post |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • SetPostal

IAddress::SetPostal method |  |  | space
Sets the structured postal address part. The Swiss ISO county code is the default but is filtered in the printing. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IAddress/SetPostal
[JSON input data] | pIAddress: bstrStreet: bstrPoBox: bstrZip: bstrCity: bstrStateCode: bstrCountryCode: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPostal( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | bstrStreet, bstrPoBox, bstrZip, bstrCity, bstrStateCode, bstrCountryCode, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrStreet | The street name part of an address. |
[in] BSTR | bstrPoBox | The P.O. box code part of an address. Note that according to the Post the street and poBox parts should be used mutually exclusive. |
[in] BSTR | bstrZip | The mandatory ZIP code part of an address. |
[in] BSTR | bstrCity | The mandatory city name of an address. |
[in] BSTR | bstrStateCode | The optional state code part of an address. |
[in] BSTR | bstrCountryCode | The ISO country code of an address. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IAddress
  • DestructAddress

IAddress::DestructAddress property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IAddress interface instance. The counterpart property to generate an IAddress interface instance is IGeneralCreditRequest::GetCreateAddress. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IAddress/PutDestructAddress
[JSON input data] | pIAddress: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IAddress
  • Type

IAddress::Type property | space
GetType returns the type of address either enAddressPerson or enAddressCompany if an address is defined at all.

If no address is defined then enAddressUndefined is returned.
space
Restful webservice calling syntax
[GET] | /baseURL/ IAddress/GetType?param
[param] pIAddress= longValue
[JSON result data] peType: longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Type( AddressType *peType );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] AddressType | *peType
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • AddressType *GetType(void);
space


  • IGeneralCreditRequest

IGeneralCreditRequest interface |  | V4.50/ 1 Nov 2019
With the IGeneralCreditRequest interface all general credit related data and parameters can be set by the available interface methods like SetPatient, SetTreatment,... Alternatively to producing the data from scratch, the data of a previously generated XML infoset can be loaded with the IGeneralCreditRequestManager::LoadXML method and thereafter data can selectively be changed. |  | space
space
Methods |  | 26 methods
AddDiagnosis | Adds a diagnosis to the list of diagnoses. |
AddDocument | Attaches a PDF, JPG or PNG document inline to the list of documents |
AddService | Adds a service record from a simple/normal tariff to the list of services |
AddXtraData4CantonalPhysician | Adds a token/value pair to the list of cantonal physician instructions |
Finalize | Finalizes and validates all data set so far in the IGeneralCreditRequest interface |
GetAbortInfo | Get the abort information string with the error coded in the module language |
Initialize | Initializes all input data in the IGeneralCreditRequest interface |
SetBiller | Sets the biller's various identifiers (GLN, ZSR,...) as well as the structured address |
SetCard | Sets the patient's insurance card information - optional in respect to the dependent XSD schema. |
SetCreditObject | Sets the general credit object reference parameters |
SetCreditRefObject | Sets the optional creditRef object reference parameters |
SetData4CantonalPhysician | Sets the special data for the cantonal physician (CP) |
SetDebitor | Sets the debitor's GLN and the structured address |
SetEmployer | Sets the employer's various identifiers (GLN, UID) and the structured address of the employer of the patient |
SetInsurance | Sets the GLN and the structured address of the insurance |
SetLaw | Sets the data about the applied law and its dependent information |
SetPackage | Defines the identification parameters of the main software. |
SetPatient | Sets the primary parameters and structured address of the patient |
SetProvider | Sets the main provider's various identifiers (GLN, ZSR,...) as well as the structured address |
SetReferrer | Sets the referrer's various identifiers (GLN, ZSR,...) and the structured address - this is an optional part |
SetRequest | Sets the primary parameters of the request, namely the "storno" and "copy" status besides an optional remark |
SetStationary | Sets additional treatment data if it the treatment type is stationary. |
SetSubstantiation | Sets the substantiation (motives and reasons) for the planned treatment. |
SetSurgeon | Sets the various identifiers (GLN, ZSR,...) and the structured address of a surgeon |
SetTransport | Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to) |
SetTreatment | Sets the basic primary parameters of the planned treatment |
space
Properties |  | 3 properties
[get] CreateAddress | Creates an instance of the IAddress interface |
[put] DestructAddress | Destructs/invalidates the IAddress interface instance |
[put] DestructGeneralCreditRequest | Destructs/invalidates this IGeneralCreditRequest interface instance |
space |


  • IGeneralCreditRequest
  • AddDiagnosis

IGeneralCreditRequest::AddDiagnosis method |  |  | space
Adds a diagnosis to the list of diagnoses. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/AddDiagnosis
[JSON input data] | pIGeneralCreditRequest: eDiagnosisType: bstrCode: bstrText: | longValue, //interface address longValue, "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddDiagnosis( | DiagnosisType BSTR BSTR VARIANT_BOOL | eDiagnosisType, bstrCode, bstrText, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] DiagnosisType | eDiagnosisType | The type of the diagnosis catalog |
[in] BSTR | bstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog defined by DiagnosisType . |
[in] BSTR | bstrText | The textual description of the diagnosis as given in the corresponding diagnosis catalog defined by DiagnosisType . |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • AddDocument

IGeneralCreditRequest::AddDocument method | space
Attaches a PDF, JPG or PNG document inline to the list of documents.

Internally, the inline document will be transformed to a BASE64 octet representation to safeguard the binary nature of the file.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequest/AddDocument?param
[param] pIGeneralCreditRequest=longValue&
bstrFile=urlEncodedString&
bstrTitle=urlEncodedString&
bstrMimeType=urlEncodedString
+
<application/octet-stream> input_file_upload_stream
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT AddDocument( BSTR
BSTR
BSTR
VARIANT_BOOL 		bstrFile,
bstrTitle,
bstrMimeType,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrFile | bstrFile supplies the full file name (path + name) of the document. Be sure, that privileges allows to open and read the file since the content is internally BASE64 coded.
[in] BSTR | bstrTitle | bstrTitle is the document's title on the primary system and thus describes the document in terms of its semantic content.
[in] BSTR bstrMimeType The MIME type of the document. The MIME type enables applications to define the format and eventually read the file (cf. RFC 2046 standardizes and names the commonly used MIME types).

Since the underlying XSD schema restricts the type of files, the MIME type must be one of
  • application/pdf for PDF files
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequest
  • AddService

IGeneralCreditRequest::AddService method | space
Adds a service record from a simple/normal tariff to the list of services. The services describes an applied treatment part in terms of incurred costs.

The term "normal" means a tariff with a simple (code, name, tax point, tax point value) structure as opposed to "extended" tariffs like the Tarmed. If a record from an extended tariff should be added than supply TP(medical)+TP(technical) as tax point.

If the return status is VARIANT_FALSE then the service record is not added to the list of services

space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequest/AddService
[JSON input data] pIGeneralCreditRequest:
bstrTariffType:
bstrTariffCode:
bstrReferenceCode:
bstrTariffText:
dQuantity:
dDateBegin:
dTP:
dTPV:
dExternalFactor:
bstrRemark: 		longValue, //interface address
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
doubleValue,
variantDateValue | "stringISODateValue",
doubleValue,
doubleValue,
doubleValue,
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT AddService( BSTR
BSTR
BSTR
BSTR
double
DATE
double
double
double
BSTR
VARIANT_BOOL 		bstrTariffType,
bstrTariffCode,
bstrReferenceCode,
bstrTariffText,
dQuantity,
dDateBegin,
dTP,
dTPV,
dExternalFactor,
bstrRemark,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrTariffType | The official tariff type as defined by Forum Datenaustausch
[in] BSTR | bstrTariffCode | The tariff code as defined by the used tariff catalog
[in] BSTR | bstrReferenceCode | A reference code to define a master-slave connection between two service records. Please note, that the tariff code implies the existence of a reference code.
[in] BSTR | bstrTariffText | The name of the tariff record as defined by the used tariff
[in] double dQuantity The quantity of the current service.

Note, that the quantity is defined as double, spanning zero and positive fractional values!
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
  • negative quantities are set for a storno to reflect the negative incurred cost situation
The quantity must not be rounded but given in full precision.
[in] DATE dDateBegin The supposed application date of the service.

Please note, that the service date defines the existence of a service as well as the correct TP and TPV. Therefore, if you do not know the service date, supply the treatment begin date (SetTreatment) for all services.
[in] double | dTP | The tax points (TP) of the current service.
[in] double | dTPV | The tax point value (TPV) of the current service.
[in] double dExternalFactor The external scaling factor used to scale the service e.g. to give a discount or surcharge.

The external scale factor can as well be used to define a customer cost splitting situation (for example, between a KV and IV insurance or between a canton and a KV insurance).
[in] BSTR | bstrRemark | An optional remark for the given service.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequest
  • AddXtraData4CantonalPhysician

IGeneralCreditRequest::AddXtraData4CantonalPhysician method |  |  | space
Adds a token/value pair to the list of cantonal physician instructions. It should be noted that the data space for the cantonal physician (CP) is exclusively defined by the Swiss cantonal authorities. While at the moment of this documenbtation all needed data for the CP can be delivered by the SetData4CantonalPhysician method, this generic token/value approach presents a safeguard for allowing an expansion of the data situation (due to corresponding cantonal requirements) without the necessity of changing the basic underlaying standard generalCreditRequest450. Note, that the semantic, grammar and nomenclature of these instructions are unstandardized and bilateral in nature between biller and CP. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/AddXtraData4CantonalPhysician
[JSON input data] | pIGeneralCreditRequest: bstrToken: bstrValue: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT AddXtraData4CantonalPhysician( | BSTR BSTR VARIANT_BOOL | bstrToken, bstrValue, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrToken | The name of the token/value instruction pair |
[in] BSTR | bstrValue | The data of the token/value instruction pair |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • Finalize

IGeneralCreditRequest::Finalize method | space
Finalizes and validates all data set so far in the IGeneralCreditRequest interface. This method is the counterpart to the Initialize method.

This method should be called after all data have been set in the IGeneralCreditRequest interface since higher-level validation rules can only be called at the end of input phase. Therefore, be prepared to get validation errors at that point.

Please note, that apart from validation tasks there are automatic assignments of addresses as well, should such an address be missing.
Eventually the following addresses are cloned in the given sequence:
  • if the debitor address is missing than it is cloned from the insurance's address
  • if the insurance address is missing than it is cloned from the debitor's address
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequest/Finalize
[JSON input data] pIGeneralCreditRequest: longValue, //interface address
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT Finalize( | VARIANT_BOOL | *pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequest
  • GetAbortInfo

IGeneralCreditRequest::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/GetAbortInfo
[JSON input data] | pIGeneralCreditRequest: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IGeneralCreditRequest
  • Initialize

IGeneralCreditRequest::Initialize method |  |  | space
Initializes all input data in the IGeneralCreditRequest interface. This method is the counterpart to the Finalize method. This method should be called before any input is set in the IGeneralCreditRequest interface. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/Initialize
[JSON input data] | pIGeneralCreditRequest: eDataLanguage: | longValue, //interface address longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT Initialize( | LanguageType VARIANT_BOOL | eDataLanguage, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LanguageType | eDataLanguage | Sets the language in which the data part is coded. It is exactly the language in which the request is formulated. Note, that the data language and the module language (given by IGeneralCreditRequestManager::SetModuleLanguage property) are independent and can be different! |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetBiller

IGeneralCreditRequest::SetBiller method |  |  | space
Sets the biller's various identifiers (GLN, ZSR,...) as well as the structured address. The structured address is defined via a Iaddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetBiller
[JSON input data] | pIGeneralCreditRequest: bstrEAN: bstrZSR: bstrNIF: bstrSpecialty: pIAddress: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetBiller( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEAN | The GLN (former EAN) number of the biller as supplied by Stiftung Refdata |
[in] BSTR | bstrZSR | The optional ZSR number of the biller as supplied by Santesuisse |
[in] BSTR | bstrNIF | The optional IV specific identification number NIF of the biller. |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of the biller |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetCard

IGeneralCreditRequest::SetCard method |  |  | space
Sets the patient's insurance card information - optional in respect to the dependent XSD schema. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetCard
[JSON input data] | pIGeneralCreditRequest: bstrCardID: dExpiryDate: dValidationDate: bstrValidationID: bstrValidationServer: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", variantDateValue | "stringISODateValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetCard( | BSTR DATE DATE BSTR BSTR VARIANT_BOOL | bstrCardID, dExpiryDate, dValidationDate, bstrValidationID, bstrValidationServer, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrCardID | The mandatory unique 20 digits card identifier. |
[in] DATE | dExpiryDate | The optional expiry date of the card |
[in] DATE | dValidationDate | The optional date of the last validation of the card's data |
[in] BSTR | bstrValidationID | The optional replied ID when the last validation of the card's data was performed |
[in] BSTR | bstrValidationServer | The optional server for the last validation process |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetCreditObject

IGeneralCreditRequest::SetCreditObject method |  |  | space
Sets the general credit object reference parameters. The creditRef (if supplied) and credit object references form a object reference chain (creditRef -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetCreditObject
[JSON input data] | pIGeneralCreditRequest: eCreditType: bstrRequestCreditID: dRequestCreditDate: lRequestCreditTimestamp: | longValue, //interface address longValue, "utf8StringValue", variantDateValue | "stringISODateValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetCreditObject( | CreditType BSTR DATE long VARIANT_BOOL | eCreditType, bstrRequestCreditID, dRequestCreditDate, lRequestCreditTimestamp, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] CreditType | eCreditType | The type of credit request to set from the CreditType enumeration list |
[in] BSTR | bstrRequestCreditID | The request credit ID is the main software's identification of the general credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the general credit object reference. |
[in] DATE | dRequestCreditDate | The request credit date is the main software's date of the general credit ("Kostengutsprachedatum") This is one of 3 identifiers that form the general credit object reference. |
[in] long | lRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the general credit infoset generation. Set this variable 0 to indicate the generation of a new general credit object reference. The IGeneralCreditRequestManager::GetXML and/or IGeneralCreditRequestManager::Print method will return the timestamp that must be used from that point on as 3rd parameter of the object reference. This is one of 3 identifiers that form the general credit object reference. The timestamp will be generated once for a certain general credit object reference and thereafter the timestamp is always referenced. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetCreditRefObject

IGeneralCreditRequest::SetCreditRefObject method |  |  | space
Sets the optional creditRef object reference parameters. This object reference is only set if such a former general credit request was generated and this former credit object should now be referenced. The creditRef and credit object references form a object reference chain (creditRef -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetCreditRefObject
[JSON input data] | pIGeneralCreditRequest: bstrRequestCreditID: dRequestCreditDate: lRequestCreditTimestamp: | longValue, //interface address "utf8StringValue", variantDateValue | "stringISODateValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetCreditRefObject( | BSTR DATE long VARIANT_BOOL | bstrRequestCreditID, dRequestCreditDate, lRequestCreditTimestamp, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrRequestCreditID | The request credit ID is the main software's identification of the general credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the general creditRef object reference. |
[in] DATE | dRequestCreditDate | The request credit date is the main software's date of the general credit ("Kostengutsprachedatum") This is one of 3 identifiers that form the general creditRef object reference. |
[in] long | lRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the general credit infoset generation. Set this variable 0 to indicate the generation of a new general credit object reference. The IGeneralCreditRequestManager::GetXML and/or IGeneralCreditRequestManager::Print method will return the timestamp that must be used from that point on as 3rd parameter of the object reference. This is one of 3 identifiers that form the general creditRef object reference. The timestamp will be generated once for a certain general credit object reference and thereafter the timestamp is always referenced. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetData4CantonalPhysician

IGeneralCreditRequest::SetData4CantonalPhysician method |  |  | space
Sets the special data for the cantonal physician (CP). To defined these data implies that the debitor is than the CP as well as that the 'Cantonal' print template is used. Furthermore, when generating a XML document a PDF dump of the cantonal print template is automatically added as attachment. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetData4CantonalPhysician
[JSON input data] | pIGeneralCreditRequest: bstrResponsibleAtHospitalWard: bstrUsedTariffType: dUsedBaserate: eAdditionallyRegisteredAtUV: eAdditionallyRegisteredAtIV: eIsMedicalNecessity: bstrJustificationForService: bstrLocationOfEmergency: dDateOfEmergency: bstrJustificationForReconsideration: | longValue, //interface address "utf8StringValue", "utf8StringValue", doubleValue, longValue, longValue, longValue, "utf8StringValue", "utf8StringValue", variantDateValue | "stringISODateValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetData4CantonalPhysician( | BSTR BSTR double YesNoType YesNoType YesNoType BSTR BSTR DATE BSTR VARIANT_BOOL | bstrResponsibleAtHospitalWard, bstrUsedTariffType, dUsedBaserate, eAdditionallyRegisteredAtUV, eAdditionallyRegisteredAtIV, eIsMedicalNecessity, bstrJustificationForService, bstrLocationOfEmergency, dDateOfEmergency, bstrJustificationForReconsideration, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrResponsibleAtHospitalWard | bstrResponsibleAtHospitalWard is the name of the responsible physician at the given hospital ward. Note that in most cases this is the supplied provider. |
[in] BSTR | bstrUsedTariffType | bstrUsedTariffType is the official 3-character designator of the tariff catalog that will be used for the forthcoming invoice |
[in] double | dUsedBaserate | dUsedBaserate is the base rate that will used for the forthcoming invoice |
[in] YesNoType | eAdditionallyRegisteredAtUV | eAdditionallyRegisteredAtUV is a Boolean value indicating if there an additional credit request was generated for an accident insurance (UV) |
[in] YesNoType | eAdditionallyRegisteredAtIV | eAdditionallyRegisteredAtIV is a Boolean value indicating if there an additional credit request was generated for an invalidity insurance (IV) |
[in] YesNoType | eIsMedicalNecessity | eIsMedicalNecessity is a Boolean value indicating if the credit request is done due to a "Medical Necessity". The conditions for having a "Medical Necessity" are defined elsewhere by Swiss Conference of Health Directors. |
[in] BSTR | bstrJustificationForService | bstrJustificationForService is the justification for the non availability of services in the residential canton of the patient. This justification is only needed if the Boolean eIsMedicalNecessity=enYes |
[in] BSTR | bstrLocationOfEmergency | bstrLocationOfEmergency is the location of the emergency. This location is only needed if the Boolean SetStationary::eHospitalizationType=enEmergency |
[in] DATE | dDateOfEmergency | dDateOfEmergency is the date and time when that emergency happened. This date is only needed if the Boolean SetStationary::eHospitalizationType=enEmergency |
[in] BSTR | bstrJustificationForReconsideration | bstrJustificationForReconsideration is the justification for generating a re-consideration credit request. This justification is only needed if SetCreditObject::CreditType=enCreditReconsideration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetDebitor

IGeneralCreditRequest::SetDebitor method |  |  | space
Sets the debitor's GLN and the structured address. If the debitor object is not supplied than a clone of the insurance's address is automatically assigned in the Finalize method. The structured address is defined via a Iaddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetDebitor
[JSON input data] | pIGeneralCreditRequest: bstrEAN: pIAddress: | longValue, //interface address "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetDebitor( | BSTR IAddress VARIANT_BOOL | bstrEAN, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEAN | The GLN (former EAN) number of the debitor as supplied by Stiftung Refdata Note, that the debitor's EAN is a required parameter. However, debitors in Tiers Garant might not possess such an EAN. Therefore do supply a EAN from the private EAN space (e.g. 2000000000008) in such a case. |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetEmployer

IGeneralCreditRequest::SetEmployer method |  |  | space
Sets the employer's various identifiers (GLN, UID) and the structured address of the employer of the patient. The structured address is defined via a Iaddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetEmployer
[JSON input data] | pIGeneralCreditRequest: bstrEAN: bstrRegNumber: pIAddress: | longValue, //interface address "utf8StringValue", "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetEmployer( | BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrRegNumber, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEAN | The GLN (former EAN) number of the employer as supplied by Stiftung Refdata |
[in] BSTR | bstrRegNumber | The employer's national UID number as assigned by Swiss Federal Statistical Office |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetInsurance

IGeneralCreditRequest::SetInsurance method |  |  | space
Sets the GLN and the structured address of the insurance. The address is defined via an IAddress interface pointer and the address data must be defined prior to call this method. Please note, that a clone of the insurance's address is automatically assigned as debitor address in the Finalize method should the SetDebitor method not be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetInsurance
[JSON input data] | pIGeneralCreditRequest: bstrEAN: pIAddress: | longValue, //interface address "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetInsurance( | BSTR IAddress VARIANT_BOOL | bstrEAN, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEAN | The GLN (former EAN) number of the insurance as supplied by Stiftung Refdata |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetLaw

IGeneralCreditRequest::SetLaw method |  |  | space
Sets the data about the applied law and its dependent information |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetLaw
[JSON input data] | pIGeneralCreditRequest: eLawType: dCaseDate: bstrCaseID: bstrInsuredID: | longValue, //interface address longValue, variantDateValue | "stringISODateValue", "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetLaw( | LawType DATE BSTR BSTR VARIANT_BOOL | eLawType, dCaseDate, bstrCaseID, bstrInsuredID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] LawType | eLawType | The type of law to set from the LawType enumeration |
[in] DATE | dCaseDate | The case date of the insurance (e.g. date of accident in UVG) This date might undefined for certain laws and therefore left empty |
[in] BSTR | bstrCaseID | The case ID of the insurance (e.g. accident number in UVG) This ID might undefined for certain laws and therefore left empty |
[in] BSTR | bstrInsuredID | The patient's ID at the insurance (e.g. insurance ID in KVG) This ID might undefined for certain laws and therefore left empty |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetPackage

IGeneralCreditRequest::SetPackage method |  |  | space
Defines the identification parameters of the main software. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetPackage
[JSON input data] | pIGeneralCreditRequest: bstrSoftwarePackage: lSoftwareVersion: lSoftwareID: bstrSoftwareCopyright: | longValue, //interface address "utf8StringValue", longValue, longValue, "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetPackage( | BSTR long long BSTR VARIANT_BOOL | bstrSoftwarePackage, lSoftwareVersion, lSoftwareID, bstrSoftwareCopyright, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrSoftwarePackage | Name of the main software. |
[in] long | lSoftwareVersion | Version of the main software coded as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[in] long | lSoftwareID | Optional ID of the main software |
[in] BSTR | bstrSoftwareCopyright | The copyright notice of the main software. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then no package data is available |
space |


  • IGeneralCreditRequest
  • SetPatient

IGeneralCreditRequest::SetPatient method | space
Sets the primary parameters and structured address of the patient.

The address is defined via an IAddress interface pointer and the address data must be defined prior to call this method.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequest/SetPatient
[JSON input data] pIGeneralCreditRequest:
eSexType:
dBirthdate:
bstrSSN:
pIAddress: 		longValue, //interface address
longValue,
variantDateValue | "stringISODateValue",
"utf8StringValue",
longValue
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		eSexType,
dBirthdate,
bstrSSN,
*pIAddress,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] SexType | eSexType | The patient's gender.
[in] DATE | dBirthdate | The patient's birthdate.
[in] BSTR bstrSSN Defines the social security number (SSN) of the patient whereupon 4 distinguished types are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
The SSN can be supplied in its printed (with dots) or electronic (only digits) form.
[in] IAddress | *pIAddress | Pointer to an IAddress interface instance that holds the structured address parts.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequest
  • SetProvider

IGeneralCreditRequest::SetProvider method |  |  | space
Sets the main provider's various identifiers (GLN, ZSR,...) as well as the structured address. The structured address is defined via a Iaddress interface instance and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetProvider
[JSON input data] | pIGeneralCreditRequest: bstrEAN: bstrZSR: bstrNIF: bstrSpecialty: pIAddress: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetProvider( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEAN | The GLN (former EAN) number of the provider as supplied by Stiftung Refdata |
[in] BSTR | bstrZSR | The optional ZSR number of the provider as supplied by Santesuisse |
[in] BSTR | bstrNIF | The optional IV specific identification number NIF of the provider. |
[in] BSTR | bstrSpecialty | An optional specialty, i.e. FMH title of the provider |
[in] IAddress | *pIAddress | The instance of a IAddress interface that holds the structured address parts. A NULL pointer is supplied if no address should be set. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetReferrer

IGeneralCreditRequest::SetReferrer method |  |  | space
Sets the referrer's various identifiers (GLN, ZSR,...) and the structured address - this is an optional part. The address is defined via an Iaddress interface pointer and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetReferrer
[JSON input data] | pIGeneralCreditRequest: bstrEAN: bstrZSR: bstrNIF: bstrSpecialty: pIAddress: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetReferrer( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEAN | The GLN (former EAN) number of the referrer as supplied by Stiftung Refdata |
[in] BSTR | bstrZSR | The optional ZSR number of the referrer as supplied by Santesuisse |
[in] BSTR | bstrNIF | The optional IV specific identification number NIF of the referrer. |
[in] BSTR | bstrSpecialty | The optional specialty, i.e. FMH title of the referrer. |
[in] IAddress | *pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetRequest

IGeneralCreditRequest::SetRequest method |  |  | space
Sets the primary parameters of the request, namely the "storno" and "copy" status besides an optional remark. Note, that whenever the "storno" and/or "copy" parameters are set then the timestamp of the topmost object reference (SetCreditObject) must be defined as >0 otherwise an error will result in the Finalize method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetRequest
[JSON input data] | pIGeneralCreditRequest: eRoleType: ePlaceType: bstrRoleTitle: eIsStorno: eIsCopy: eIsCostEstimate: eIsConfidential: | longValue, //interface address longValue, longValue, "utf8StringValue", longValue, longValue, longValue, longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetRequest( | RoleType PlaceType BSTR YesNoType YesNoType YesNoType YesNoType VARIANT_BOOL | eRoleType, ePlaceType, bstrRoleTitle, eIsStorno, eIsCopy, eIsCostEstimate, eIsConfidential, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] RoleType | eRoleType | Defines the role categories that the main provider is best categorized. If the main provider has an other role than defined then use enRoleOther and additionally supply a role title with a description of the role |
[in] PlaceType | ePlaceType | Defines the principle place where the main provider is applying the treatment |
[in] BSTR | bstrRoleTitle | Optional role title/description of the main provider. If a suitable predefined role can not be set then bstrRoleTitle is mandatory (use enRoleOther as role in that case) |
[in] YesNoType | eIsStorno | Boolean value that defines the "storno" status of the general credit request eIsStorno should be false when the initial request object is produced. At this step the timestamp is generated and returned in the IGeneralCreditRequestManager::Print and/or IGeneralCreditRequestManager::GetXML method. Whenever eIsStorno is true then the request timestamp must be set otherwise an error will result. |
[in] YesNoType | eIsCopy | Boolean value that defines the "copy" status of the general credit request eIsCopy should be false when the initial request object is produced. At this step the timestamp is generated and returned in the IGeneralCreditRequestManager::Print and/or IGeneralCreditRequestManager::GetXML method. Whenever eIsCopy is true then the request timestamp must be set otherwise an error will result. |
[in] YesNoType | eIsCostEstimate | Boolean value that defines the credit as "cost estimate" instead of "credit". From a semantical point of view cost estimates ("Kostenvoranschlag") and credits ("Kostengutsprache") are the same. It is more of a legal question as 'cost estimate' has a narrower cost interval than a credit. If you don't know what to set then check with the cost bearer. |
[in] YesNoType | eIsConfidential | Boolean flag that defines the confidentiality status of a credit when addressed and transmitted to a consulting physician (CE) at the insurance's site in accordance with Article 42 (5) of the Swiss Federal Act on Health Insurance (KVG). By using the flag in the aforementioned case, the health provider declares that all medical information must be seen and used exclusively by the CE. Therefore, the case qualifies according to Article 42 (5) KVG. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetStationary

IGeneralCreditRequest::SetStationary method |  |  | space
Sets additional treatment data if it the treatment type is stationary. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetStationary
[JSON input data] | pIGeneralCreditRequest: eHospitalizationType: eHospitalizationMode: eHospitalizationClass: bstrSectionMajor: | longValue, //interface address longValue, longValue, longValue, "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetStationary( | HospitalizationType HospitalizationMode HospitalizationClass BSTR VARIANT_BOOL | eHospitalizationType, eHospitalizationMode, eHospitalizationClass, bstrSectionMajor, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] HospitalizationType | eHospitalizationType | The type/reason of a hospitalization given by the HospitalizationType enumeration |
[in] HospitalizationMode | eHospitalizationMode | The mode/indication of a hospitalization given by the HospitalizationMode enumeration |
[in] HospitalizationClass | eHospitalizationClass | The hospitalization class given by the HospitalizationClass enumeration |
[in] BSTR | bstrSectionMajor | The major BfS section code as defined by the Swiss Federal Statistical Office |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetSubstantiation

IGeneralCreditRequest::SetSubstantiation method |  |  | space
Sets the substantiation (motives and reasons) for the planned treatment. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetSubstantiation
[JSON input data] | pIGeneralCreditRequest: bstrMeasures: bstrRemark: | longValue, //interface address "utf8StringValue", "utf8StringValue"
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetSubstantiation( | BSTR BSTR VARIANT_BOOL | bstrMeasures, bstrRemark, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrMeasures | The intended measures for the planned treatment |
[in] BSTR | bstrRemark | An optional remark regarding the planned treatment |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetSurgeon

IGeneralCreditRequest::SetSurgeon method |  |  | space
Sets the various identifiers (GLN, ZSR,...) and the structured address of a surgeon. Of course, the surgeon's address is set only if it is a stationary treatment with surgery. The address is defined via a Iaddress interface pointer and the address data must be defined prior to call this method. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetSurgeon
[JSON input data] | pIGeneralCreditRequest: bstrEAN: bstrZSR: bstrNIF: bstrSpecialty: pIAddress: | longValue, //interface address "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetSurgeon( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | bstrEAN, bstrZSR, bstrNIF, bstrSpecialty, *pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] BSTR | bstrEAN | The GLN (former EAN) number of the surgeon as supplied by Stiftung Refdata |
[in] BSTR | bstrZSR | The optional ZSR number of the surgeon as supplied by Santesuisse |
[in] BSTR | bstrNIF | The optional IV specific identification number NIF of the surgeon. |
[in] BSTR | bstrSpecialty | The optional specialty, i.e. FMH title of the surgeon. |
[in] IAddress | *pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • SetTransport

IGeneralCreditRequest::SetTransport method | space
Sets transport information that is the routing information going from a sender (from) over the first intermediate (via) to the receiver (to). All the involved parties are defined by GLN numbers as defined by Stiftung Refdata.

Furthermore, this method allows to define the parameters needed for sign and/or encrypt the resulting XML infoset. Therefore, read the notes about signature and encryption to get familiar with these concepts.

Important new feature: the electronic reachability of a recipient for a certain version of generalCreditRequest is kind of a chicken and egg problem. To solve this connectivity problem, the service medSRS (medical Standard Routing Service) has been created. By using the RESTful webservice method queryRHS one can find out, how and whether a specific recipient can be reached electronically. Please refer to the website medSRS.ch for getting an introduction to the topic or detailed information about the functionality of the webservice.

Instead of inputting the bstrToEan GLN literal, the query call queryRHS(glnProvider,glnRecipient) is supplied instead - cf. description of bstrToEAN below.

The usage of the patch can generate a new error code 'ERROR_RECIPIENTRHS_NOTAVAILABLE' indicating that a given recipient is not reachable. It is the decision of the calling program whether the error 'ERROR_RECIPIENTRHS_NOTAVAILABLE' will be considered or not.

space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequest/SetTransport
[JSON input data] pIGeneralCreditRequest:
bstrFromEAN:
bstrFromPFXFile:
bstrFromPFXPassword:
bstrViaEAN:
bstrToEAN:
bstrToBinDERFile: 		longValue, //interface address
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetTransport( BSTR
BSTR
BSTR
BSTR
BSTR
BSTR
VARIANT_BOOL 		bstrFromEAN,
bstrFromPFXFile,
bstrFromPFXPassword,
bstrViaEAN,
bstrToEAN,
bstrToBinDERFile,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrFromEAN | The GLN (former EAN) number of the sender as supplied by Stiftung Refdata
[in] BSTR bstrFromPFXFile The file name of the PFX certificate that is the private certificate of the "from" entity.
If the variable is empty or NULL then no signature is applied otherwise a signature might be applied depending on the lXMLGenerationAttributes of the GetXML method.
[in] BSTR | bstrFromPFXPassword | The password to open the PFX certificate. The password is only used if a PFX certificate is supplied.
[in] BSTR | bstrViaEAN | The GLN (former EAN) number of the first intermediate as supplied by Stiftung Refdata
[in] BSTR bstrToEAN The GLN (former EAN) number of the recipient as supplied by Stiftung Refdata

Patch for querying medSRS:
bstrToEAN = "queryRHS(glnProvider,glnRecipient);"

where:
  • queryRHS( ) is a literal command
  • glnProvider is the official GLN of the service with a required pattern of ^76[0-9]{11}.
    Please note that the official GLN of the service provider is needed here, which is not necessarily identical with the GLN of the sender == bstrFromEAN. The latter may be a GLN from the private sector (^2[0-9]{12}) - this is a small but crucial difference.
  • glnRecipient is the official GLN of the recipient with a required pattern of ^76[0-9]{11}.
    Please note that the official GLN of the sender is needed here, which is not necessarily identical with the GLN of the recipient == bstrToEAN. The latter may be a GLN from the private sector (^2[0-9]{12}) - this is a small but crucial difference.
Note, that the patch is neither case- nor whitespace-sensitive.

For example, given the input 'queryRHS(7601001302112, 7601003000078)' the medSRS system is queried whether
the recipient Suva (GLN=7601003000078) can be reached via the given intermediate (bstrViaEAN) with the standard 'carCreditRequest450' for the provider TMR (GLN=7601001302112).

The result of the RESTful webservice call can return 3 possible result states:
  1. the recipient (Suva) is reachable: the correct GLN bstrToEAN is returned and error state S_OK is defined
  2. the call is faulty because the parameters have a wrong format or the used intermediate (bstrViaEAN) is unknown on medSRS or the call has caused some other technical problem. In this case bstrToEAN=bstrRecipient (7601003000078 in the example) is set and the error state S_OK is defined
  3. the recipient (Suva) is not reachable: if there is the possibility of a downgrade, the RESTful call is repeated for the next lower version or bstrToEAN=bstrRecipient (7601003000078 in the example) is set and the error state 'ERROR_RECIPIENTRHS_NOTAVAILABLE' is defined.
It is the decision of the calling program whether the error 'ERROR_RECIPIENTRHS_NOTAVAILABLE' will be considered or not.
[in] BSTR bstrToBinDERFile The file name of the binary DER certificate that is the public certificate of the "to" entity.
If the variable is empty or NULL then no encryption is applied otherwise encryption might be applied depending on the lXMLGenerationAttributes of the GetXML
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequest
  • SetTreatment

IGeneralCreditRequest::SetTreatment method |  |  | space
Sets the basic primary parameters of the planned treatment |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequest/SetTreatment
[JSON input data] | pIGeneralCreditRequest: dDateBegin: dDateEnd: eTreatmentCanton: eTreatmentReason: | longValue, //interface address variantDateValue | "stringISODateValue", variantDateValue | "stringISODateValue", longValue, longValue
[JSON result data] | pbStatus: | booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT SetTreatment( | DATE DATE CantonType TreatmentReasonType VARIANT_BOOL | dDateBegin, dDateEnd, eTreatmentCanton, eTreatmentReason, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] DATE | dDateBegin | dDateBegin is the supposed start of the treatment |
[in] DATE | dDateEnd | dDateEnd is the supposed end of the treatment If the end of treatment is unknown, than supply a 0 date. |
[in] CantonType | eTreatmentCanton | The treatment canton given by the CantonType enumeration |
[in] TreatmentReasonType | eTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequest
  • CreateAddress

IGeneralCreditRequest::CreateAddress property | space
Creates an instance of the IAddress interface.

Any address data is specified or retrieved using properties and methods of this interface. The interface is reusable for any semantic type of address. Just call the IAddress:Initialize method before starting to input new address data.
space
Restful webservice calling syntax
[GET] | /baseURL/ IGeneralCreditRequest/GetCreateAddress?param
[param] pIGeneralCreditRequest= longValue
[JSON result data] pIAddress: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | CreateAddress( IAddress **peCreateAddress );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IAddress | **peCreateAddress | The created instance of the IAddress interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IAddress **GetCreateAddress(void);
space


  • IGeneralCreditRequest
  • DestructAddress

IGeneralCreditRequest::DestructAddress property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates the IAddress interface instance. The counterpart property to generate an IAddress interface instance is IGeneralCreditRequest::GetCreateAddress. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IGeneralCreditRequest/PutDestructAddress
[JSON input data] | pIGeneralCreditRequest: pIAddress: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IGeneralCreditRequest
  • DestructGeneralCreditRequest

IGeneralCreditRequest::DestructGeneralCreditRequest property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IGeneralCreditRequest interface instance. The counterpart property to generate an IGeneralCreditRequest interface instance is IGeneralCreditRequestManager::GetGeneralCreditRequest. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IGeneralCreditRequest/PutDestructGeneralCreditRequest
[JSON input data] | pIGeneralCreditRequest: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IGeneralCreditRequestManager

IGeneralCreditRequestManager interface |  | V4.50/ 1 Nov 2019
The IGeneralCreditRequestManager interface provides all the necessary methods to produce general credit requests of type generalCreditRequest_450 for all roles and places. Firstly, an instance of the IGeneralCreditRequest interface is created by the GetGeneralCreditRequest property. All the general credit related data and parameters can be set by the supplied interface methods like SetPatient, SetTreatment,... After all information is defined the general credit object is printed or a XML infoset is produced which can be electronically transported to a recipient. In the latter case the general credit object optionally can be signed and/or encrypted . Due to the processing attributes "storno" and "copy" a previously generated general credit object can be canceled or a copy can be produced (cf. Notes about processing attributes). |  | space
space
Methods |  | 8 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetLogSettings | Get the log settings for the module. |
GetXML | The GetXML method generates the XML infoset based on the data of the IGeneralCreditRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory |
LoadXML | Loads a previously generated XML infoset back into memory for further processing via the returned interface handles |
Print | The Print method validates the defined general credit data and prints the request on the local printer |
PrintAdjust | Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file |
PrintSetup | Shows the printer setup dialog that allows to define the printer and its settings |
SetLogSettings | Sets the log setting preferences for the module |
space
Properties |  | 9 properties
[get] CreateGeneralCreditRequestManager | Creates an instance of the main IGeneralCreditRequestManager interface |
[put] DestructGeneralCreditRequest | Destructs/invalidates this IGeneralCreditRequest interface instance |
[put] DestructGeneralCreditRequestManager | Destructs/invalidates a main instance of the IGeneralCreditRequestManager interface |
[put] DestructGeneralCreditResult | Destructs/invalidates this IGeneralCreditResult interface instance. |
[get] GeneralCreditRequest | Gets the IGeneralCreditRequest interface instance |
[get/put] ModuleLanguage | Get/Set the language for the module i.e |
[get] ModuleVersion | Get the version of the GeneralCreditRequestManager module. |
[get] ModuleVersionText | Get the version of the GeneralCreditRequestManager module in textual form. |
[get/put] Modus | Gets/Sets the operation modus of the module |
space |


  • IGeneralCreditRequestManager
  • GetAbortInfo

IGeneralCreditRequestManager::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequestManager/GetAbortInfo
[JSON input data] | pIGeneralCreditRequestManager: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IGeneralCreditRequestManager
  • GetLogSettings

IGeneralCreditRequestManager::GetLogSettings method | space
Get the log settings for the module.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequestManager/GetLogSettings
[JSON input data] pIGeneralCreditRequestManager: longValue, //interface address
[JSON result data] plLogLevel:
plMaxSizeKB:
peDoArchive:
pbstrArchiveDir:
pbStatus: 		longValue,
longValue,
longValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		*plLogLevel,
*plMaxSizeKB,
*peDoArchive,
*pbstrArchiveDir,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] long *plLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes
[out] long | *plMaxSizeKB | The maximum size in KB of the log file.
[out] YesNoType | *peDoArchive | eDoArchive defines if the log file is recycled if the maximum size is reached (enNo) or if the log file is archived (enYes).
[out] BSTR | *pbstrArchiveDir | The base directory where log files are archived. bstrArchiveDir is only defined if eDoArchive=enYes otherwise bstrArchiveDir is empty.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequestManager
  • GetXML

IGeneralCreditRequestManager::GetXML method |  |  | space
The GetXML method generates the XML infoset based on the data of the IGeneralCreditRequest interface and the XML generation attributes, validates the XML against the XSD schema, and stores the XML content as UTF8 file in the internal working directory. The full file name to this XML document is replied in the pbstrOutputFile output variable. The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down! Note about encryption: an encrypted XML infoset can not be loaded successfully by LoadXML. Therefore, to build a local archive besides encrypted XML infosets, call GetXML twice once with the lXMLGenerationAttributes = enGenerateWithoutEncryption |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditRequestManager/GetXML
[JSON input data] | pIGeneralCreditRequestManager: lGenerationAttributes: | longValue, //interface address longValue
[JSON result data] | pbstrOutputFile: plValidationError: plTimestamp: pbstrUsedSchema: pIGeneralCreditResult: pbStatus: | "utf8StringValue", longValue, longValue, "utf8StringValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetXML( | long BSTR long long BSTR IGeneralCreditResult VARIANT_BOOL | lGenerationAttributes, *pbstrOutputFile, *plValidationError, *plTimestamp, *pbstrUsedSchema, **pIGeneralCreditResult, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[in] long | lGenerationAttributes | This variable overrules the default behavior of the XML generation process even if the appropriate data have been defined. lGenerationAttributes is a 32-bit integer where the possible "commands" are values from the generationAttributes data type ORed together to form the overall command. This feature is necessary to generate different "flavors" of XML infosets without re-setting input data. For instance, an encrypted XML infoset for the "to" entity can be produced and in a second call the XML infoset without encryption (lGenerationAttributes=enGenerateXMLWithoutEncryption) is requested for a local archive (that can be loaded back later!). |
[out] BSTR | *pbstrOutputFile | The full file name (path + name) where the XML infoset is stored in UTF-8 mode. The XML file must be saved to a different location as all temporary XML files in the working directory are deleted before the COM module shuts down! In Restful Webservice output: pbstrOutputFile is a releative URL which must be downloaded in a subsequent GET process. |
[out] long | *plValidationError | lValidationError is filled with the validation error code returned by the MSXML DOM parser. A zero value indicates that the validation was successful. |
[out] long | *plTimestamp | The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on. If the timestamp for the topmost object reference was already set (e.g. to produce a copy) then this same timestamp is returned. |
[out] BSTR | *pbstrUsedSchema | The full XSD name that was used to generate the XML infoset. In all situations this would be generalCreditRequest_450.xsd. |
[out] IGeneralCreditResult | **pIGeneralCreditResult | The instance of a IGeneralCreditResult interface allows to read all loaded data back. The handle is NULL if an error occurred. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditRequestManager
  • LoadXML

IGeneralCreditRequestManager::LoadXML method | space
Loads a previously generated XML infoset back into memory for further processing via the returned interface handles. The GeneralCreditRequest450 COM module understands and processes the generalCreditRequest_450 XSD standard.

To analyze and retrieve the loaded data use the returned instance of the IGeneralCreditRequest interface and/or preview/print the data.

Furthermore, this method serves as dashboard e.g. to produce a "storno" or "copy" XML infoset.
  • Load the initial XML infoset with LoadXML
  • set the appropriate storno and/or copy values with the IGeneralCreditRequest::SetRequest method
  • produce the XML infoset again with the GetXML method or print the general credit request with the Print method.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequestManager/LoadXML?param
[param] pIGeneralCreditRequestManager=longValue&
bstrInputFile=urlEncodedString
+
<application/octet-stream> input_file_upload_stream
[JSON result data] pbstrUsedSchema:
pIGeneralCreditRequest:
pIGeneralCreditResult:
pbStatus: 		"utf8StringValue",
longValue,
longValue,
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT LoadXML( BSTR
BSTR
IGeneralCreditRequest
IGeneralCreditResult
VARIANT_BOOL 		bstrInputFile,
*pbstrUsedSchema,
**pIGeneralCreditRequest,
**pIGeneralCreditResult,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR | bstrInputFile | The input XML infoset (full file name) that must be loaded and analyzed.
[out] BSTR *pbstrUsedSchema The full XSD schema name referenced by the of the loaded XML file.

Since there is only one understandable standard, the returned schema is generalCreditRequest_450.xsd. This variable is not set if the loading of an XML infoset was unsuccessful or the referenced XSD is not valid.
[out] IGeneralCreditRequest **pIGeneralCreditRequest The IGeneralCreditRequest interface handle that allows to add further data.
The handle is NULL if an error occurred.
[out] IGeneralCreditResult **pIGeneralCreditResult The instance of a IGeneralCreditResult interface allows to read all loaded data back.
The handle is NULL if an error occurred.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequestManager
  • Print

IGeneralCreditRequestManager::Print method | space
The Print method validates the defined general credit data and prints the request on the local printer. The printer selection is done via the used report generator template file. If the template file was not connected to a printer with the PrintSetup method then the default printer with its default settings is used.

The bstrPrintTemplate variable obeys a special syntax and can optionally be used to set special print commands like using electronic webstamps, producing PDFs or changing print objects dynamically.
  • "How to print webstamps" is a description how to integrate electronic stamps into the general credit request
  • "How to generate PDF archive file" is a description about generating PDF archive files of the general credit request
  • "How to use an alternate print template" is a description about overriding the default print template
  • "Syntax of the printTemplate variable"

IMPORTANT LICENSE NOTE The report engine used is Hexatech's ViewPro (www.hexatech.com). If you supply your own template files then you must have your own ViewPro license. By using this COM module you implicitly agree upon this restriction!
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequestManager/Print
[JSON input data] pIGeneralCreditRequestManager:
bstrPrintTemplate:
lGenerationAttributes:
ePrintPreview:
bstrSenderID: 		longValue, //interface address
"utf8StringValue",
longValue,
longValue,
"utf8StringValue"
[JSON result data] plTimestamp:
pbstrPDFFile:
pIGeneralCreditResult:
pbStatus: 		longValue,
"utf8StringValue",
longValue,
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT Print( BSTR
long
YesNoType
BSTR
long
IGeneralCreditResult
VARIANT_BOOL 		bstrPrintTemplate,
lGenerationAttributes,
ePrintPreview,
bstrSenderID,
*plTimestamp,
**pIGeneralCreditResult,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate The bstrPrintTemplate variable is used to explicitly change print template reports and/or print objects as defined in "Syntax of the printTemplate variable".

If bstrPrintTemplate is empty then the default print template of the defined data language ( IGeneralCreditRequest:: Initialize method) is used.
[in] long lGenerationAttributes This variable overrules the default behavior of the print process.

lGenerationAttributes is a 32-bit integer where the possible "commands" are values from the generationAttributes data type ORed together to form the overall command.
[in] YesNoType ePrintPreview A Boolean that defines if print preview is used (enYes) or printing is done (enNo)

In Restful Webservice system: ePrintPreview is automatically set to enNo no matter what the input value is. Furthermore, printing is automatically redirected to a PDF output file since there are no printers available.

[in] BSTR bstrSenderID Short sender address identification or empty.

If set then the sender identification is printed atop of the receiver address as an alternative to the sender address on the envelop.
[out] long *plTimestamp The timestamp of the XML document as epoch time (seconds elapsed since 1.1.1970) that is used as timestamp of the topmost object reference from that point on.

If the timestamp for the topmost object reference was already set (e.g. to produce a copy) then this same timestamp is returned.
[out] BSTR *pbstrPDFFile In Restful webservice output:

pbstrPDFFile is a relative URL to a PDF file holding the result of the Print method. Therefore, after receiving the JSON result data do GET pbstrPDFile such as to have the produced printout.
[out] IGeneralCreditResult **pIGeneralCreditResult The IGeneralCreditResult interface handle that allows to get all loaded data back.
The handle is NULL if an error occurred.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequestManager
  • PrintAdjust

IGeneralCreditRequestManager::PrintAdjust method | space
Shows the print object adjustment dialog that allows to move print objects of a .vps report generator file.

Besides the position adjustment of any available print object, there exists the possibility of move all print objects globally.
space
Restful webservice calling syntax
This method has no Restful Webservice representation!
space
C/C++ calling syntax
HRESULT PrintAdjust( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via one of the following case insensitive logical names:
Detail[_version]_addressSide_language
- the multi-page general credit template for all laws
where
  • version is 450, the absence of a version identifier defaults to 450
  • language is one of {dt, fr, it}.
  • addressSide is R for right sided addressing of the recipient.

For example the logical name "Detail_R_fr" is the French print template of version 450 with right sided addressing.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequestManager
  • PrintSetup

IGeneralCreditRequestManager::PrintSetup method | space
Shows the printer setup dialog that allows to define the printer and its settings. When saving the data the selected printer and the currently used computer is connected with the given .vps report generator file.
space
Restful webservice calling syntax
This method has no Restful Webservice representation!
space
C/C++ calling syntax
HRESULT PrintSetup( BSTR
BSTR
VARIANT_BOOL 		bstrPrintTemplate,
bstrINIPath,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] BSTR bstrPrintTemplate Either the full file name (path + name) or a logical name of a target .vps report generator file for which the settings will be defined.

There are predefined .vps files in the installation directory that can be accessed via one of the following case insensitive logical names:
Detail[_version]_addressSide_language
- the multi-page general credit template for all laws
where
  • version is 450, the absence of a version identifier defaults to 450
  • language is one of {dt, fr, it}.
  • addressSide is R for right sided addressing of the recipient.

For example the logical name "Detail_R_fr" is the French print template of version 450 with right sided addressing.
[in] BSTR bstrINIPath Optional path to a directory where the .vpd printer setting file is stored. The name of the printer setting file is the same name as the .vps file but with a .vpd extension.

If bstrINIPath is left empty then the standard directory (the directory of the dll) is used.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequestManager
  • SetLogSettings

IGeneralCreditRequestManager::SetLogSettings method | space
Sets the log setting preferences for the module.

The default for the log activity are: level=1, lMaxSizeKB=20000,eDoArchive=enNo, and the log settings are persistent via the log file itself.

Note, that the log facility is a best effort system. If there is an error e.g. due to insufficient privileges to write the log entries then nothing is logged.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditRequestManager/SetLogSettings
[JSON input data] pIGeneralCreditRequestManager:
lLogLevel:
lMaxSizeKB:
eDoArchive:
bstrArchiveDir: 		longValue, //interface address
longValue,
longValue,
longValue,
"utf8StringValue"
[JSON result data] pbStatus: booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT SetLogSettings( long
long
YesNoType
BSTR
VARIANT_BOOL 		lLogLevel,
lMaxSizeKB,
eDoArchive,
bstrArchiveDir,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[in] long lLogLevel The log activity level where
lLogLevel = 0 | Logging is turned off
lLogLevel = 1 | Normal log activity
lLogLevel > 1 | Debug log activity. Use this level only for debugging purposes

Any log level below 0 is corrected to 0.
[in] long lMaxSizeKB The maximum size in KB of the log file (default value is 20000 kB).
Any size below 1000 kB is corrected to the default value
[in] YesNoType | eDoArchive | eDoArchive defines if the log file is recycled once the maximum size is reached (enNo) or if the log file is archived (enYes) into the archive directory.
[in] BSTR bstrArchiveDir Defines the base directory where log files are archived. bstrArchiveDir is only used if eDoArchive=enYes. If bstrArchiveDir is empty and eDoArchive=enYes then the place of the module is used as the base archive directory.

If the base archive directory or directories below have insufficient privileges to create directories or write files archiving is not done!
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditRequestManager
  • CreateGeneralCreditRequestManager

IGeneralCreditRequestManager::CreateGeneralCreditRequestManager property |  |  | space
This property has a Restful Webservice representation only! Creates an instance of the main IGeneralCreditRequestManager interface. To delete/invalidate this interface instance, the counterpart property PutDestructGeneralCreditRequestManager must be explicitly called, since the pIGeneralCreditRequestManager address has a global scope and is not automatically destructed. |  |  |
space
Restful webservice calling syntax |  |  |
[GET] | /baseURL/ IGeneralCreditRequestManager/GetCreateGeneralCreditRequestManager?param
[param] | pIGeneralCreditRequestManager= | longValue
[JSON result data] | pIGeneralCreditRequestManager: | longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IGeneralCreditRequestManager
  • DestructGeneralCreditRequest

IGeneralCreditRequestManager::DestructGeneralCreditRequest property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IGeneralCreditRequest interface instance. The counterpart property to generate an IGeneralCreditRequest interface instance is IGeneralCreditRequestManager::GetGeneralCreditRequest. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IGeneralCreditRequestManager/PutDestructGeneralCreditRequest
[JSON input data] | pIGeneralCreditRequestManager: pIGeneralCreditRequest: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IGeneralCreditRequestManager
  • DestructGeneralCreditRequestManager

IGeneralCreditRequestManager::DestructGeneralCreditRequestManager property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates a main instance of the IGeneralCreditRequestManager interface. Please note, that all dependent, active interface instances generated with IGeneralCreditRequestManager::GetGeneralCreditRequest, all dependent, active interface instances generated with IGeneralCreditRequest::GetCreateAddress and all IGeneralCreditResult interface instances under this main instance, are automatically destructed as well. The counterpart property to generate a main interface instance is IGeneralCreditRequestManager::GetCreateGeneralCreditRequestManager. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IGeneralCreditRequestManager/PutDestructGeneralCreditRequestManager
[JSON input data] | pIGeneralCreditRequestManager: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IGeneralCreditRequestManager
  • DestructGeneralCreditResult

IGeneralCreditRequestManager::DestructGeneralCreditResult property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IGeneralCreditResult interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IGeneralCreditRequestManager/PutDestructGeneralCreditResult
[JSON input data] | pIGeneralCreditRequestManager: pIGeneralCreditResult: | longValue, //interface address longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • IGeneralCreditRequestManager
  • GeneralCreditRequest

IGeneralCreditRequestManager::GeneralCreditRequest property | space
Gets the IGeneralCreditRequest interface instance.

This property is called if the data are defined from scratch. The same interface instance is returned when the IGeneralCreditRequestManager::LoadXML method is called.
space
Restful webservice calling syntax
[GET] | /baseURL/ IGeneralCreditRequestManager/GetGeneralCreditRequest?param
[param] pIGeneralCreditRequestManager= longValue
[JSON result data] pIGeneralCreditRequest: longValue //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | GeneralCreditRequest( IGeneralCreditRequest **peGeneralCreditRequest );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] IGeneralCreditRequest | **peGeneralCreditRequest | The created instance of the IGeneralCreditRequest interface
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • IGeneralCreditRequest **GetGeneralCreditRequest(void);
space


  • IGeneralCreditRequestManager
  • ModuleLanguage

IGeneralCreditRequestManager::ModuleLanguage property | space
Get/Set the language for the module i.e. the language in which the error strings are coded.

Note, that the module language and the data language (given by IGeneralCreditRequest::Initialize) are independent and can be different!
space
Restful webservice calling syntax
[GET] | /baseURL/ IGeneralCreditRequestManager/GetModuleLanguage?param
[param] pIGeneralCreditRequestManager= longValue
[JSON result data] peModuleLanguage: longValue
[PUT] | /baseURL/ IGeneralCreditRequestManager/PutModuleLanguage
[JSON input data] pIGeneralCreditRequestManager:
eModuleLanguage: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleLanguage( LanguageType *peModuleLanguage );
[put] HRESULT | ModuleLanguage( LanguageType eModuleLanguage );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] LanguageType | *peModuleLanguage | The language for the main interface defining e.g. the language of the error messages
[in] LanguageType | eModuleLanguage | The language for the main interface defining e.g. the language of the error messages
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • LanguageType *GetModuleLanguage(void);
  • void PutModuleLanguage( LanguageType lModuleLanguage);
space


  • IGeneralCreditRequestManager
  • ModuleVersion

IGeneralCreditRequestManager::ModuleVersion property | space
Get the version of the GeneralCreditRequestManager module.
space
Restful webservice calling syntax
[GET] | /baseURL/ IGeneralCreditRequestManager/GetModuleVersion?param
[param] pIGeneralCreditRequestManager= longValue
[JSON result data] pbstrModuleVersion: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersion( BSTR *pbstrModuleVersion );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersion | The module version of the generalCreditRequestManager module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersion(void);
space


  • IGeneralCreditRequestManager
  • ModuleVersionText

IGeneralCreditRequestManager::ModuleVersionText property | space
Get the version of the GeneralCreditRequestManager module in textual form.
space
Restful webservice calling syntax
[GET] | /baseURL/ IGeneralCreditRequestManager/GetModuleVersionText?param
[param] pIGeneralCreditRequestManager= longValue
[JSON result data] pbstrModuleVersionText: "utf8StringValue"
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | ModuleVersionText( BSTR *pbstrModuleVersionText );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] BSTR | *pbstrModuleVersionText | The module version string of the generalCreditRequestManager module
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • BSTR *GetModuleVersionText(void);
space


  • IGeneralCreditRequestManager
  • Modus

IGeneralCreditRequestManager::Modus property | space
Gets/Sets the operation modus of the module.

The default modus is enProduction whereas for developing/debugging purposes enTest can be set.
space
Restful webservice calling syntax
[GET] | /baseURL/ IGeneralCreditRequestManager/GetModus?param
[param] pIGeneralCreditRequestManager= longValue
[JSON result data] peModus: longValue
[PUT] | /baseURL/ IGeneralCreditRequestManager/PutModus
[JSON input data] pIGeneralCreditRequestManager:
eModus: 		longValue, //interface address
longValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
[get] HRESULT | Modus( ModusType *peModus );
[put] HRESULT | Modus( ModusType eModus );
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out,retval] ModusType | *peModus | The modus type of operation
[in] ModusType | eModus | The modus type of operation
space
Remarks
If SmartPointers are used than the function names and calls are rewritten by Microsoft into the form
  • ModusType *GetModus(void);
  • void PutModus( ModusType lModus);
space


  • IGeneralCreditResult

IGeneralCreditResult interface |  | V4.50/ 1 Nov 2019
The IGeneralCreditResult interface allows to read back all data that have been set by the IGeneralCreditRequest interface or by loading a previously generated XML infoset with the IGeneralCreditRequestManager::LoadXML method. |  | space
space
Methods |  | 32 methods
GetAbortInfo | Get the abort information string with the error coded in the module language |
GetBiller | Retrieves the biller's various identifiers (GLN, ZSR,...) as well as the structured address |
GetCard | Retrieves the patient's insurance card information |
GetCreditObject | Retrieves the general credit object reference parameters |
GetCreditRefObject | Retrieves the optional general creditRef object reference parameters |
GetData4CantonalPhysician | Retrieves the special data for the cantonal physician (CP) |
GetDebitor | Retrieves the debitor's GLN identifier as well as the structured address |
GetDiagnoses | Method for collecting all diagnosis data covered by the IGeneralCreditResult interface and returned as JSON array |
GetDocuments | Method for collecting all document data covered by the IGeneralCreditResult interface and returned as JSON array |
GetEmployer | Retrieves the employer's various identifiers (GLN, UID) and the structured address of the employer |
GetFirstDiagnosis | Retrieves the first diagnosis from the list of diagnoses |
GetFirstDocument | Retrieves the first document from the list of documents |
GetFirstService | Retrieves the first service record from the list of services |
GetFirstXtraData4CantonalPhysician | Retrieves the first xtra data instruction from the list of instructions |
GetInsurance | Retrieves the insurance's GLN as well as the structured address |
GetLaw | Retrieves the data about the applied law and its dependent information |
GetNextDiagnosis | Retrieves the next diagnosis from the list of diagnoses |
GetNextDocument | Retrieves the next document from the list of documents |
GetNextService | Retrieves the next service record from the list of services |
GetNextXtraData4CantonalPhysician | Retrieves the next xtra data instruction from the list of instructions |
GetPackage | Retrieves the identification parameters of the main software |
GetPatient | Retrieves the patient's primary parameters (sex, birthdate, SSN, etc.) as well as the structured address |
GetProvider | Retrieves the main provider's various identifiers (GLN, ZSR,...) and the structured address |
GetReferrer | Retrieves the referrer's various identifiers (GLN, ZSR,...) and the structured address |
GetRequest | Returns the primary parameters of the request, namely the language the data is supplied, the "storno" and "copy" status besides an optional remark. |
GetServices | Method for collecting all service records covered by the IGeneralCreditResult interface and returned as JSON array |
GetStationary | Retrieves the additional stationary treatment data if such a stationary treatment is defined |
GetSubstantiation | Retrieves the substantiation (motives and reasons) for the planned treatment |
GetSurgeon | Retrieves the surgeon's various identifiers (GLN, ZSR,...) and the structured address |
GetTransport | Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to) |
GetTreatment | Retrieves the basic treatment parameters |
GetXtraData4CantonalPhysician | Method for collecting all data for a cantonal physician covered by the IGeneralCreditResult interface and returned as JSON array |
space
Properties |  | 1 properties
[put] DestructGeneralCreditResult | Destructs/invalidates this IGeneralCreditResult interface instance. |
space |


  • IGeneralCreditResult
  • GetAbortInfo

IGeneralCreditResult::GetAbortInfo method |  |  | space
Get the abort information string with the error coded in the module language. Call this method whenever the returned pbStatus variable of the primarily called method is VARIANT_FALSE and the primarily called method is not an iterator (GetFirst/GetNext). In the later case VARIANT_FALSE signals the end of data. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetAbortInfo
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrAbort: pbStatus: | "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetAbortInfo( | BSTR VARIANT_BOOL | *pbstrAbort, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrAbort | Abort information string. If the abort string is empty then there is no error condition - S_FALSE was set (e.g. in an iterator to signal end_of_data) |
[out,retval] VARIANT_BOOL | *pbStatus | Return status. VARIANT_TRUE means S_OK, VARIANT_FALSE means S_FALSE (e.g. in an iterator) or an error (E_name). In the later case check for possible errors with the GetAbortInfo method. |
space |


  • IGeneralCreditResult
  • GetBiller

IGeneralCreditResult::GetBiller method |  |  | space
Retrieves the biller's various identifiers (GLN, ZSR,...) as well as the structured address. The structured address data is read via the methods of the returned Iaddress interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetBiller
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrEAN: pbstrZSR: pbstrNIF: pbstrSpecialty: pIAddress: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetBiller( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The GLN (former EAN) number of the biller as supplied by Stiftung Refdata |
[out] BSTR | *pbstrZSR | The optional ZSR number of the biller as supplied by Santesuisse |
[out] BSTR | *pbstrNIF | The optional IV specific identification number NIF of the biller |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the biller |
[out] IAddress | **pIAddress | The instance of an IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetCard

IGeneralCreditResult::GetCard method |  |  | space
Retrieves the patient's insurance card information. VARIANT_FALSE is returned if the data is undefined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetCard
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrCardID: pdExpiryDate: pdValidationDate: pbstrValidationID: pbstrValidationServer: pbStatus: | "utf8StringValue", "stringISODateValue", "stringISODateValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetCard( | BSTR DATE DATE BSTR BSTR VARIANT_BOOL | *pbstrCardID, *pdExpiryDate, *pdValidationDate, *pbstrValidationID, *pbstrValidationServer, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrCardID | The mandatory unique 20 digits card identifier |
[out] DATE | *pdExpiryDate | The optional expiry date of the card |
[out] DATE | *pdValidationDate | The optional date of the last validation of the card's data |
[out] BSTR | *pbstrValidationID | The optional replied ID when the last validation of the card's data was performed |
[out] BSTR | *pbstrValidationServer | The optional server for the last validation process |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetCreditObject

IGeneralCreditResult::GetCreditObject method |  |  | space
Retrieves the general credit object reference parameters. The creditRef (if supplied) and credit object references form a object reference chain (creditRef -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetCreditObject
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | peCreditType: pbstrRequestCreditID: pdRequestCreditDate: plRequestCreditTimestamp: pbStatus: | longValue, "utf8StringValue", "stringISODateValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetCreditObject( | CreditType BSTR DATE long VARIANT_BOOL | *peCreditType, *pbstrRequestCreditID, *pdRequestCreditDate, *plRequestCreditTimestamp, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] CreditType | *peCreditType | The type of credit request defined from the CreditType enumeration list |
[out] BSTR | *pbstrRequestCreditID | The request credit ID is the main software's identification of the general credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the general credit object reference. |
[out] DATE | *pdRequestCreditDate | The request credit date is the main software's date of the general credit ("Kostengutsprachedatum") This is one of 3 identifiers that form the general credit object reference. |
[out] long | *plRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the general credit infoset generation. This is one of 3 identifiers that form the general credit object reference. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetCreditRefObject

IGeneralCreditResult::GetCreditRefObject method |  |  | space
Retrieves the optional general creditRef object reference parameters. The creditRef (if supplied) and credit object references form a object reference chain (creditRef -> credit) with the credit as topmost object reference. The page "object reference" provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference". |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetCreditRefObject
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrRequestCreditID: pdRequestCreditDate: plRequestCreditTimestamp: pbStatus: | "utf8StringValue", "stringISODateValue", longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetCreditRefObject( | BSTR DATE long VARIANT_BOOL | *pbstrRequestCreditID, *pdRequestCreditDate, *plRequestCreditTimestamp, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrRequestCreditID | The request credit ID is the main software's identification of the general credit ("Kostengutsprachenummer"). This is one of 3 identifiers that form the general creditRef object reference. |
[out] DATE | *pdRequestCreditDate | The request credit date is the main software's date of the general credit ("Kostengutsprachedatum") This is one of 3 identifiers that form the general creditRef object reference. |
[out] long | *plRequestCreditTimestamp | This is a UNIX timestamp defined at the moment of the general credit infoset generation. This is one of 3 identifiers that form the general creditRef object reference. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetData4CantonalPhysician

IGeneralCreditResult::GetData4CantonalPhysician method |  |  | space
Retrieves the special data for the cantonal physician (CP). If data for the CP was not supplied at all than S_FALSE (VARIANT_FALSE) is returned. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetData4CantonalPhysician
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrResponsibleAtHospitalWard: pbstrUsedTariffType: pdUsedBaserate: peAdditionallyRegisteredAtUV: peAdditionallyRegisteredAtIV: peIsMedicalNecessity: pbstrJustificationForService: pbstrLocationOfEmergency: pdDateOfEmergency: pbstrJustificationForReconsideration: pbStatus: | "utf8StringValue", "utf8StringValue", doubleValue, longValue, longValue, longValue, "utf8StringValue", "utf8StringValue", "stringISODateValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetData4CantonalPhysician( | BSTR BSTR double YesNoType YesNoType YesNoType BSTR BSTR DATE BSTR VARIANT_BOOL | *pbstrResponsibleAtHospitalWard, *pbstrUsedTariffType, *pdUsedBaserate, *peAdditionallyRegisteredAtUV, *peAdditionallyRegisteredAtIV, *peIsMedicalNecessity, *pbstrJustificationForService, *pbstrLocationOfEmergency, *pdDateOfEmergency, *pbstrJustificationForReconsideration, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrResponsibleAtHospitalWard | bstrResponsibleAtHospitalWard is the name of the responsible physician at the given hospital ward. Note that in most cases this is the supplied provider. |
[out] BSTR | *pbstrUsedTariffType | bstrUsedTariffType is the official 3-character designator of the tariff catalog that will be used for the forthcoming invoice |
[out] double | *pdUsedBaserate | dUsedBaserate is the base rate that will used for the forthcoming invoice |
[out] YesNoType | *peAdditionallyRegisteredAtUV | eAdditionallyRegisteredAtUV is a Boolean value indicating if there an additional credit request was generated for an accident insurance (UV) |
[out] YesNoType | *peAdditionallyRegisteredAtIV | eAdditionallyRegisteredAtIV is a Boolean value indicating if there an additional credit request was generated for an invalidity insurance (IV) |
[out] YesNoType | *peIsMedicalNecessity | eIsMedicalNecessity is a Boolean value indicating if the credit request is done due to a "Medical Necessity". The conditions for having a "Medical Necessity" are defined elsewhere by Swiss Conference of Health Directors. |
[out] BSTR | *pbstrJustificationForService | bstrJustificationForService is the justification for the non availability of services in the residential canton of the patient. This justification is only needed if the Boolean eIsMedicalNecessity=enYes |
[out] BSTR | *pbstrLocationOfEmergency | bstrLocationOfEmergency is the location of the emergency. This location is only needed if the Boolean SetStationary::eHospitalizationType=enEmergency |
[out] DATE | *pdDateOfEmergency | dDateOfEmergency is the date and time when that emergency happened. This date is only needed if the Boolean SetStationary::eHospitalizationType=enEmergency |
[out] BSTR | *pbstrJustificationForReconsideration | bstrJustificationForReconsideration is the justification for generating a re-consideration credit request. This justification is only needed if SetCreditObject::CreditType=enCreditReconsideration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then either no data was defined (the GetAbortInfo error string would be empty) or an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetDebitor

IGeneralCreditResult::GetDebitor method |  |  | space
Retrieves the debitor's GLN identifier as well as the structured address. The structured address data is read via the methods of the returned Iaddress interface instance. Please note, that a clone of the insurance's address is automatically assigned as debitor address in the IGeneralCreditRequest::Finalize method should the IGeneralCreditRequest::SetDebitor method not be called. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetDebitor
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrEAN: pIAddress: pbStatus: | "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetDebitor( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The GLN (former EAN) number of the debitor as supplied by Stiftung Refdata. If the debitor's GLN is undefined than a GLN from the private segment should be used (e.g. 2000000000008). |
[out] IAddress | **pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetDiagnoses

IGeneralCreditResult::GetDiagnoses method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all diagnosis data covered by the IGeneralCreditResult interface and returned as JSON array. Please note that IGeneralCreditResult::GetDiagnoses takes over the functionality of the iterator pair IGeneralCreditResult::GetFirstDiagnosis / IGeneralCreditResult::GetNextDiagnosis with a single call, making the latter superfluous. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetDiagnoses
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result array] | { peDiagnosisType: pbstrCode: pbstrText: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] DiagnosisType | *peDiagnosisType | The type of the diagnosis as given by the enumeration. |
[out] BSTR | *pbstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog. |
[out] BSTR | *pbstrText | Textual description of the code as given in the corresponding diagnosis catalog. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IGeneralCreditResult
  • GetDocuments

IGeneralCreditResult::GetDocuments method | space
This method has a Restful Webservice representation only!
Method for collecting all document data covered by the IGeneralCreditResult interface and returned as JSON array.

Please note that IGeneralCreditResult::GetDocuments takes over the functionality of the iterator pair IGeneralCreditResult::GetFirstDocument / IGeneralCreditResult::GetNextDocument with a single call, making the latter superfluous.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditResult/GetDocuments
[JSON input data] pIGeneralCreditResult: longValue, //interface address
[JSON result array] { pbstrFile:
pbstrTitle:
pbstrMimeType:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[out] BSTR *pbstrFile *pbstrFile supplies the full file name (path + name) of the document in a temporary working directory.

Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down!

In Restful Webservice output: pbstrFile is a relative URL that subsequently must be downloaded by a GET process.

[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content.
[out] BSTR *pbstrMimeType The MIME type of the document.

Since the underlying XSD schema restricts the type of files, the MIME type must be one of

  • application/pdf for PDF files
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • IGeneralCreditResult
  • GetEmployer

IGeneralCreditResult::GetEmployer method |  |  | space
Retrieves the employer's various identifiers (GLN, UID) and the structured address of the employer. The Iaddress interface might be NULL if no address was defined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetEmployer
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrEAN: pbstrRegNumber: pIAddress: pbStatus: | "utf8StringValue", "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetEmployer( | BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrRegNumber, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The GLN (former EAN) number of the employer as supplied by Stiftung Refdata. |
[out] BSTR | *pbstrRegNumber | The employer's national BUR or UID number as defined by Swiss Federal Statistical Office |
[out] IAddress | **pIAddress | The instance of an IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetFirstDiagnosis

IGeneralCreditResult::GetFirstDiagnosis method |  |  | space
Retrieves the first diagnosis from the list of diagnoses. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetFirstDiagnosis
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | peDiagnosisType: pbstrCode: pbstrText: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstDiagnosis( | DiagnosisType BSTR BSTR VARIANT_BOOL | *peDiagnosisType, *pbstrCode, *pbstrText, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] DiagnosisType | *peDiagnosisType | The type of the diagnosis as given by the enumeration. |
[out] BSTR | *pbstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog. |
[out] BSTR | *pbstrText | Textual description of the code as given in the corresponding diagnosis catalog. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IGeneralCreditResult
  • GetFirstDocument

IGeneralCreditResult::GetFirstDocument method | space
Retrieves the first document from the list of documents.

VARIANT_FALSE is returned if the end of the document list is reached.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditResult/GetFirstDocument
[JSON input data] pIGeneralCreditResult: longValue, //interface address
[JSON result data] pbstrFile:
pbstrTitle:
pbstrMimeType:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetFirstDocument( BSTR
BSTR
BSTR
VARIANT_BOOL 		*pbstrFile,
*pbstrTitle,
*pbstrMimeType,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrFile *pbstrFile supplies the full file name (path + name) of the document in a temporary working directory.

Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down!

In Restful Webservice output: pbstrFile is a relative URL that subsequently must be downloaded by a GET process.

[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content.
[out] BSTR *pbstrMimeType The MIME type of the document.

Since the underlying XSD schema restricts the type of files, the MIME type must be one of

  • application/pdf for PDF files
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • IGeneralCreditResult
  • GetFirstService

IGeneralCreditResult::GetFirstService method | space
Retrieves the first service record from the list of services.

VARIANT_FALSE is returned if the end of the service list is reached.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditResult/GetFirstService
[JSON input data] pIGeneralCreditResult: longValue, //interface address
[JSON result data] pbstrTariffType:
pbstrTariffCode:
pbstrTariffRefCode:
pbstrTariffText:
pdQuantity:
pdDateBegin:
pdTP:
pdTPV:
pdExternalFactor:
pdAmount:
pbstrRemark:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
doubleValue,
"stringISODateValue",
doubleValue,
doubleValue,
doubleValue,
doubleValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetFirstService( BSTR
BSTR
BSTR
BSTR
double
DATE
double
double
double
double
BSTR
VARIANT_BOOL 		*pbstrTariffType,
*pbstrTariffCode,
*pbstrTariffRefCode,
*pbstrTariffText,
*pdQuantity,
*pdDateBegin,
*pdTP,
*pdTPV,
*pdExternalFactor,
*pdAmount,
*pbstrRemark,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR | *pbstrTariffType | The official tariff type as defined by Forum Datenaustausch
[out] BSTR | *pbstrTariffCode | The tariff code as defined by the used tariff
[out] BSTR | *pbstrTariffRefCode | The tariff reference code if any such code was defined in the input.
[out] BSTR | *pbstrTariffText | The name of the tariff record as defined by the used tariff
[out] double *pdQuantity The quantity of the current service.

Note, that the quantity is defined as double, spanning zero and positive fractional values!
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
  • negative quantities are set for a storno to reflect the negative incurred cost situation
The quantity must not be rounded but given in full precision.
[out] DATE *pdDateBegin The supposed application date of the service.

Please note, that the service date defines the existence of a service as well as the correct TP and TPV. Therefore, if the service date is unknown, the treatment begin date is applied.
[out] double | *pdTP | The tax points (TP) of the current service.
[out] double | *pdTPV | The tax point value (TPV) of the current service.
[out] double | *pdExternalFactor | The external scaling factor used to scale the service e.g. to give a discount or surcharge.
[out] double *pdAmount dAmount is the caused incurred cost given by the tariff record and calculated as follows:
dQuantity * dTP * dTPV * dExternalFactor = dAmount

The equation is calculated in full precision and the result rounded to 2 significant decimal places.
[out] BSTR | *pbstrRemark | An optional remark for the given service
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • IGeneralCreditResult
  • GetFirstXtraData4CantonalPhysician

IGeneralCreditResult::GetFirstXtraData4CantonalPhysician method |  |  | space
Retrieves the first xtra data instruction from the list of instructions. VARIANT_FALSE is returned if the end of the instruction list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetFirstXtraData4CantonalPhysician
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrToken: pbstrValue: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetFirstXtraData4CantonalPhysician( | BSTR BSTR VARIANT_BOOL | *pbstrToken, *pbstrValue, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrToken | The name of the token/value instruction pair |
[out] BSTR | *pbstrValue | The data of the token/value instruction pair |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IGeneralCreditResult
  • GetInsurance

IGeneralCreditResult::GetInsurance method |  |  | space
Retrieves the insurance's GLN as well as the structured address. Please note, that a clone of the insurance's address is automatically assigned as debitor address in the IGeneralCreditRequest::Finalize method should the IGeneralCreditRequest::SetDebitor method not be called. The structured address data is read via the methods of the returned Iaddress interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetInsurance
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrEAN: pIAddress: pbStatus: | "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetInsurance( | BSTR IAddress VARIANT_BOOL | *pbstrEAN, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The GLN (form EAN) number of the insurance as supplied by Stiftung Refdata |
[out] IAddress | **pIAddress | The instance of an IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetLaw

IGeneralCreditResult::GetLaw method |  |  | space
Retrieves the data about the applied law and its dependent information |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetLaw
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | peLawType: pdCaseDate: pbstrCaseID: pbstrInsuredID: pbStatus: | longValue, "stringISODateValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetLaw( | LawType DATE BSTR BSTR VARIANT_BOOL | *peLawType, *pdCaseDate, *pbstrCaseID, *pbstrInsuredID, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] LawType | *peLawType | Defines the type of law as given by the LawType enumeration. |
[out] DATE | *pdCaseDate | The case date of the insurance (e.g. date of accident in UVG) This date might undefined for certain laws and is than left empty |
[out] BSTR | *pbstrCaseID | The case ID of the insurance (e.g. accident number in UVG) This caseID might undefined for certain laws and is than left empty |
[out] BSTR | *pbstrInsuredID | The patient's ID at the insurance (e.g. the insurance ID in KVG) This patientID might undefined for certain laws and is than left empty |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetNextDiagnosis

IGeneralCreditResult::GetNextDiagnosis method |  |  | space
Retrieves the next diagnosis from the list of diagnoses. VARIANT_FALSE is returned if the end of the diagnosis list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetNextDiagnosis
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | peDiagnosisType: pbstrCode: pbstrText: pbStatus: | longValue, "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextDiagnosis( | DiagnosisType BSTR BSTR VARIANT_BOOL | *peDiagnosisType, *pbstrCode, *pbstrText, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] DiagnosisType | *peDiagnosisType | The type of the diagnosis as given by the enumeration. |
[out] BSTR | *pbstrCode | The code of the diagnosis as given in the corresponding diagnosis catalog. |
[out] BSTR | *pbstrText | Textual description of the code as given in the corresponding diagnosis catalog. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IGeneralCreditResult
  • GetNextDocument

IGeneralCreditResult::GetNextDocument method | space
Retrieves the next document from the list of documents.

VARIANT_FALSE is returned if the end of the document list is reached.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditResult/GetNextDocument
[JSON input data] pIGeneralCreditResult: longValue, //interface address
[JSON result data] pbstrFile:
pbstrTitle:
pbstrMimeType:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetNextDocument( BSTR
BSTR
BSTR
VARIANT_BOOL 		*pbstrFile,
*pbstrTitle,
*pbstrMimeType,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR *pbstrFile *pbstrFile supplies the full file name (path + name) of the document in a temporary working directory.

Be sure to copy away the file to a different location as all files in the working directory are deleted before the COM module shuts down!

In Restful Webservice output: pbstrFile is a relative URL that subsequently must be downloaded by a GET process.

[out] BSTR | *pbstrTitle | The title of the document on the primary system. It thus describes the document to a certain degree in terms of its semantic content.
[out] BSTR *pbstrMimeType The MIME type of the document.

Since the underlying XSD schema restricts the type of files, the MIME type must be one of

  • application/pdf for PDF files
  • image/jpeg for JPG graphic files
  • image/png for PNG graphic files
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • IGeneralCreditResult
  • GetNextService

IGeneralCreditResult::GetNextService method | space
Retrieves the next service record from the list of services.

VARIANT_FALSE is returned if the end of the service list is reached.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditResult/GetNextService
[JSON input data] pIGeneralCreditResult: longValue, //interface address
[JSON result data] pbstrTariffType:
pbstrTariffCode:
pbstrTariffRefCode:
pbstrTariffText:
pdQuantity:
pdDateBegin:
pdTP:
pdTPV:
pdExternalFactor:
pdAmount:
pbstrRemark:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
doubleValue,
"stringISODateValue",
doubleValue,
doubleValue,
doubleValue,
doubleValue,
"utf8StringValue",
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetNextService( BSTR
BSTR
BSTR
BSTR
double
DATE
double
double
double
double
BSTR
VARIANT_BOOL 		*pbstrTariffType,
*pbstrTariffCode,
*pbstrTariffRefCode,
*pbstrTariffText,
*pdQuantity,
*pdDateBegin,
*pdTP,
*pdTPV,
*pdExternalFactor,
*pdAmount,
*pbstrRemark,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] BSTR | *pbstrTariffType | The official tariff type as defined by Forum Datenaustausch
[out] BSTR | *pbstrTariffCode | The tariff code as defined by the used tariff
[out] BSTR | *pbstrTariffRefCode | The tariff reference code if any such code was defined in the input.
[out] BSTR | *pbstrTariffText | The name of the tariff record as defined by the used tariff
[out] double *pdQuantity The quantity of the current service.

Note, that the quantity is defined as double, spanning zero and positive fractional values!
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
  • negative quantities are set for a storno to reflect the negative incurred cost situation
The quantity must not be rounded but given in full precision.
[out] DATE *pdDateBegin The supposed application date of the service.

Please note, that the service date defines the existence of a service as well as the correct TP and TPV. Therefore, if the service date is unknown, the treatment begin date is applied.
[out] double | *pdTP | The tax points (TP) of the current service.
[out] double | *pdTPV | The tax point value (TPV) of the current service.
[out] double | *pdExternalFactor | The external scaling factor used to scale the service e.g. to give a discount or surcharge.
[out] double *pdAmount dAmount is the caused incurred cost given by the tariff record and calculated as follows:
dQuantity * dTP * dTPV * dExternalFactor = dAmount

The equation is calculated in full precision and the result rounded to 2 significant decimal places.
[out] BSTR | *pbstrRemark | An optional remark for the given service
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • IGeneralCreditResult
  • GetNextXtraData4CantonalPhysician

IGeneralCreditResult::GetNextXtraData4CantonalPhysician method |  |  | space
Retrieves the next xtra data instruction from the list of instructions. VARIANT_FALSE is returned if the end of the instruction list is reached. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetNextXtraData4CantonalPhysician
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrToken: pbstrValue: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetNextXtraData4CantonalPhysician( | BSTR BSTR VARIANT_BOOL | *pbstrToken, *pbstrValue, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrToken | The name of the token/value instruction pair |
[out] BSTR | *pbstrValue | The data of the token/value instruction pair |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IGeneralCreditResult
  • GetPackage

IGeneralCreditResult::GetPackage method |  |  | space
Retrieves the identification parameters of the main software. Since the package information is optionally VARIANT_FALSE is returned if the sender's main software is undefined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetPackage
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrSoftwarePackage: plSoftwareVersion: plSoftwareID: pbstrSoftwareCopyright: pbStatus: | "utf8StringValue", longValue, longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetPackage( | BSTR long long BSTR VARIANT_BOOL | *pbstrSoftwarePackage, *plSoftwareVersion, *plSoftwareID, *pbstrSoftwareCopyright, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrSoftwarePackage | Name of the main software. |
[out] long | *plSoftwareVersion | Version of the main software coded as 32-bit value where lSoftwareVersion = 100*Major version + Minor version. |
[out] long | *plSoftwareID | Optional ID of the main software |
[out] BSTR | *pbstrSoftwareCopyright | The copyright notice of the main software. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then no package data is available |
space |


  • IGeneralCreditResult
  • GetPatient

IGeneralCreditResult::GetPatient method | space
Retrieves the patient's primary parameters (sex, birthdate, SSN, etc.) as well as the structured address.

The structured address data is read via the methods of the returned Iaddress interface instance.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditResult/GetPatient
[JSON input data] pIGeneralCreditResult: longValue, //interface address
[JSON result data] peSexType:
pdBirthdate:
pbstrSSN:
pIAddress:

pbStatus: 		longValue,
"stringISODateValue",
"utf8StringValue",
{
pbIsPrivateAddress: true,
pbstrCompanyName: "utf8StringValue",
pbstrDepartment: "utf8StringValue",
pbstrSalutation: "utf8StringValue",
pbstrTitle: "utf8StringValue",
pbstrFamilyname: "utf8StringValue",
pbstrGivenname: "utf8StringValue",
pbstrSubaddressing: "utf8StringValue",
pbstrStreet: "utf8StringValue",
pbstrPoBox: "utf8StringValue",
pbstrZip: "utf8StringValue",
pbstrCity: "utf8StringValue",
pbstrStateCode: "utf8StringValue",
pbstrCountryCode: "utf8StringValue",
pbstrPhone1: "utf8StringValue",
pbstrPhone2: "utf8StringValue",
pbstrPhone3: "utf8StringValue",
pbstrFax: "utf8StringValue",
pbstrEMail: "utf8StringValue",
pbstrUrl: "utf8StringValue"
},
booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
C/C++ calling syntax
HRESULT GetPatient( SexType
DATE
BSTR
IAddress
VARIANT_BOOL 		*peSexType,
*pdBirthdate,
*pbstrSSN,
**pIAddress,
*pbStatus);
[C/C++ return value] | S_OK | This value is returned if the function call was successful.
S_FALSE | This value is returned if the end of an iteration is reached
E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions.
space
Calling argument description
[out] SexType | *peSexType | The patient's gender.
[out] DATE | *pdBirthdate | The patient's birthdate.
[out] BSTR *pbstrSSN The social security number (SSN) of the patient in its printed form whereupon 4 distinguished types are possible:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
[out] IAddress **pIAddress The IAddress interface handle that allows to get the structured address data back.
If no address is defined then the handle is NULL.
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string.
space


  • IGeneralCreditResult
  • GetProvider

IGeneralCreditResult::GetProvider method |  |  | space
Retrieves the main provider's various identifiers (GLN, ZSR,...) and the structured address. The IAddress interface might be NULL if no address was defined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetProvider
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrEAN: pbstrZSR: pbstrNIF: pbstrSpecialty: pIAddress: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetProvider( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The GLN (former EAN) number of the provider as supplied by Stiftung Refdata |
[out] BSTR | *pbstrZSR | ZSR number of the provider as supplied by Santesuisse |
[out] BSTR | *pbstrNIF | The optional IV specific identification number NIF of the provider |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the provider |
[out] IAddress | **pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetReferrer

IGeneralCreditResult::GetReferrer method |  |  | space
Retrieves the referrer's various identifiers (GLN, ZSR,...) and the structured address. The IAddress interface might be NULL if no address was defined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetReferrer
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrEAN: pbstrZSR: pbstrNIF: pbstrSpecialty: pIAddress: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetReferrer( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The GLN (former EAN) number of the referrer as supplied by Stiftung Refdata |
[out] BSTR | *pbstrZSR | The optional ZSR number of the referrer as supplied by Santesuisse |
[out] BSTR | *pbstrNIF | The optional IV specific identification number NIF of the referrer. |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the referrer |
[out] IAddress | **pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetRequest

IGeneralCreditResult::GetRequest method |  |  | space
Returns the primary parameters of the request, namely the language the data is supplied, the "storno" and "copy" status besides an optional remark. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetRequest
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | peDataLanguage: peRoleType: pePlaceType: pbstrRoleTitle: peIsStorno: peIsCopy: peIsCostEstimate: peIsConfidential: pbStatus: | longValue, longValue, longValue, "utf8StringValue", longValue, longValue, longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetRequest( | LanguageType RoleType PlaceType BSTR YesNoType YesNoType YesNoType YesNoType VARIANT_BOOL | *peDataLanguage, *peRoleType, *pePlaceType, *pbstrRoleTitle, *peIsStorno, *peIsCopy, *peIsCostEstimate, *peIsConfidential, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] LanguageType | *peDataLanguage | Gets the language in which the data part is coded. It is exactly the language in which the request is formulated. Note, that the data language and the module language (given by IGeneralCreditRequestManager::SetModuleLanguage) are independent and can be different! |
[out] RoleType | *peRoleType | Defines the role categories that the main provider is best categorized. If the main provider has an other role than defined then use enRoleOther and additionally supply a role title with a description of the role |
[out] PlaceType | *pePlaceType | Defines the principle place where the main provider is applying the treatment |
[out] BSTR | *pbstrRoleTitle | Optional role title/description of the main provider. If a suitable predefined role can not be set then bstrRoleTitle is mandatory (use enRoleOther as role in that case) |
[out] YesNoType | *peIsStorno | Gets the language in which the data part is coded. It is exactly the language in which the request is formulated. Note, that the data language and the module language (given by IGeneralCreditRequestManager::SetModuleLanguage) are independent and can be different! |
[out] YesNoType | *peIsCopy | Boolean value that defines the "storno" status of the general credit request eIsStorno should be false when the initial request object is produced. At this step the timestamp is generated and returned in the IGeneralCreditRequestManager::Print and/or IGeneralCreditRequestManager::GetXML method. Whenever eIsStorno is true then the request timestamp must be set otherwise an error will result. |
[out] YesNoType | *peIsCostEstimate | Boolean value that defines the credit as "cost estimate" instead of "credit". From a semantical point of view cost estimates ("Kostenvoranschlag") and credits ("Kostengutsprache") are the same. It is more of a legal question as 'cost estimate' has a narrower cost interval than a credit. If you don't know what to set then check with the cost bearer. |
[out] YesNoType | *peIsConfidential | Boolean flag that defines the confidentiality status of a credit when addressed and transmitted to a consulting physician (CE) at the insurance's site in accordance with Article 42 (5) of the Swiss Federal Act on Health Insurance (KVG). By using the flag in the aforementioned case, the health provider declares that all medical information must be seen and used exclusively by the CE. Therefore, the case qualifies according to Article 42 (5) KVG. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetServices

IGeneralCreditResult::GetServices method | space
This method has a Restful Webservice representation only!
Method for collecting all service records covered by the IGeneralCreditResult interface and returned as JSON array.

Please note that IGeneralCreditResult::GetServices takes over the functionality of the iterator pair IGeneralCreditResult::GetFirstService / IGeneralCreditResult::GetNextService with a single call, making the latter superfluous.
space
Restful webservice calling syntax
[POST] | /baseURL/ IGeneralCreditResult/GetServices
[JSON input data] pIGeneralCreditResult: longValue, //interface address
[JSON result array] { pbstrTariffType:
pbstrTariffCode:
pbstrTariffRefCode:
pbstrTariffText:
pdQuantity:
pdDateBegin:
pdTP:
pdTPV:
pdExternalFactor:
pdAmount:
pbstrRemark:
pbStatus: 		"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
"utf8StringValue",
doubleValue,
"stringISODateValue",
doubleValue,
doubleValue,
doubleValue,
doubleValue,
"utf8StringValue",
booleanValue
},
[HTTP result status] | 200 | Return status 200 signals a successful method call
204 | Return status 204 (noContent) signals that the end of an iteration is reached
>= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do.
space
Calling argument description
[out] BSTR | *pbstrTariffType | The official tariff type as defined by Forum Datenaustausch
[out] BSTR | *pbstrTariffCode | The tariff code as defined by the used tariff
[out] BSTR | *pbstrTariffRefCode | The tariff reference code if any such code was defined in the input.
[out] BSTR | *pbstrTariffText | The name of the tariff record as defined by the used tariff
[out] double *pdQuantity The quantity of the current service.

Note, that the quantity is defined as double, spanning zero and positive fractional values!
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
  • negative quantities are set for a storno to reflect the negative incurred cost situation
The quantity must not be rounded but given in full precision.
[out] DATE *pdDateBegin The supposed application date of the service.

Please note, that the service date defines the existence of a service as well as the correct TP and TPV. Therefore, if the service date is unknown, the treatment begin date is applied.
[out] double | *pdTP | The tax points (TP) of the current service.
[out] double | *pdTPV | The tax point value (TPV) of the current service.
[out] double | *pdExternalFactor | The external scaling factor used to scale the service e.g. to give a discount or surcharge.
[out] double *pdAmount dAmount is the caused incurred cost given by the tariff record and calculated as follows:
dQuantity * dTP * dTPV * dExternalFactor = dAmount

The equation is calculated in full precision and the result rounded to 2 significant decimal places.
[out] BSTR | *pbstrRemark | An optional remark for the given service
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached
space


  • IGeneralCreditResult
  • GetStationary

IGeneralCreditResult::GetStationary method |  |  | space
Retrieves the additional stationary treatment data if such a stationary treatment is defined. VARIANT_FALSE is returned if the data are not defined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetStationary
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | peHospitalizationType: peHospitalizationMode: peHospitalizationClass: pbstrSectionMajor: pbStatus: | longValue, longValue, longValue, "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetStationary( | HospitalizationType HospitalizationMode HospitalizationClass BSTR VARIANT_BOOL | *peHospitalizationType, *peHospitalizationMode, *peHospitalizationClass, *pbstrSectionMajor, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] HospitalizationType | *peHospitalizationType | The type/reason of a hospitalization given by the HospitalizationType enumeration |
[out] HospitalizationMode | *peHospitalizationMode | The mode/indication of a hospitalization given by the HospitalizationMode enumeration |
[out] HospitalizationClass | *peHospitalizationClass | The hospitalization class given by the HospitalizationClass enumeration |
[out] BSTR | *pbstrSectionMajor | The major BfS section code as defined by the Swiss Federal Statistical Office |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetSubstantiation

IGeneralCreditResult::GetSubstantiation method |  |  | space
Retrieves the substantiation (motives and reasons) for the planned treatment |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetSubstantiation
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrMeasures: pbstrRemark: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetSubstantiation( | BSTR BSTR VARIANT_BOOL | *pbstrMeasures, *pbstrRemark, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrMeasures | The intended measures for the planned treatment |
[out] BSTR | *pbstrRemark | An optional remark regarding the planned treatment |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetSurgeon

IGeneralCreditResult::GetSurgeon method |  |  | space
Retrieves the surgeon's various identifiers (GLN, ZSR,...) and the structured address. The IAddress interface might be NULL if no address was defined. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetSurgeon
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrEAN: pbstrZSR: pbstrNIF: pbstrSpecialty: pIAddress: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", { pbIsPrivateAddress: true, pbstrCompanyName: "utf8StringValue", pbstrDepartment: "utf8StringValue", pbstrSalutation: "utf8StringValue", pbstrTitle: "utf8StringValue", pbstrFamilyname: "utf8StringValue", pbstrGivenname: "utf8StringValue", pbstrSubaddressing: "utf8StringValue", pbstrStreet: "utf8StringValue", pbstrPoBox: "utf8StringValue", pbstrZip: "utf8StringValue", pbstrCity: "utf8StringValue", pbstrStateCode: "utf8StringValue", pbstrCountryCode: "utf8StringValue", pbstrPhone1: "utf8StringValue", pbstrPhone2: "utf8StringValue", pbstrPhone3: "utf8StringValue", pbstrFax: "utf8StringValue", pbstrEMail: "utf8StringValue", pbstrUrl: "utf8StringValue" }, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetSurgeon( | BSTR BSTR BSTR BSTR IAddress VARIANT_BOOL | *pbstrEAN, *pbstrZSR, *pbstrNIF, *pbstrSpecialty, **pIAddress, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrEAN | The GLN (former EAN) number of the surgeon as supplied by Stiftung Refdata |
[out] BSTR | *pbstrZSR | The optional ZSR number of the surgeon as supplied by Santesuisse |
[out] BSTR | *pbstrNIF | The optional IV specific identification number NIF of the surgeon. |
[out] BSTR | *pbstrSpecialty | The optional specialty, i.e. FMH title of the surgeon |
[out] IAddress | **pIAddress | The instance of a IAddress interface that allows to read back the structured address data. If no address is defined then the handle is NULL. |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetTransport

IGeneralCreditResult::GetTransport method |  |  | space
Returns the transport information that is the routing information going from a sender (from) over at least one intermediate (via) to the receiver (to). All the involved parties are defined by GLN numbers as defined by Stiftung Refdata. If the parameters for the signature and encryption were set then these data are returned as well otherwise the corresponding variables are empty. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetTransport
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pbstrFromEAN: pbstrFromPFXFile: pbstrFromPFXPassword: pbstrViaEAN: pbstrToEAN: pbstrToBinDERFile: pbStatus: | "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", "utf8StringValue", booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTransport( | BSTR BSTR BSTR BSTR BSTR BSTR VARIANT_BOOL | *pbstrFromEAN, *pbstrFromPFXFile, *pbstrFromPFXPassword, *pbstrViaEAN, *pbstrToEAN, *pbstrToBinDERFile, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrFromEAN | The GLN (former EAN) number of the sender as supplied by Stiftung Refdata |
[out] BSTR | *pbstrFromPFXFile | The file name of the PFX certificate used for signing that is the private certificate of the "from" entity. If the request is not signed than this parameter is empty |
[out] BSTR | *pbstrFromPFXPassword | The password to open the PFX certificate. If the request is not signed than this parameter is empty |
[out] BSTR | *pbstrViaEAN | The GLN (former EAN) number of the first intermediate as supplied by Stiftung Refdata |
[out] BSTR | *pbstrToEAN | The GLN (former EAN) number of the receiver as supplied by Stiftung Refdata |
[out] BSTR | *pbstrToBinDERFile | The file name of the binary DER certificate used for encryption that is the public certificate of the "to" entity |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetTreatment

IGeneralCreditResult::GetTreatment method |  |  | space
Retrieves the basic treatment parameters |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetTreatment
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result data] | pdDateBegin: pdDateEnd: peTreatmentCanton: peTreatmentType: peTreatmentReason: pbStatus: | "stringISODateValue", "stringISODateValue", longValue, longValue, longValue, booleanValue
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
C/C++ calling syntax |  |  |
HRESULT GetTreatment( | DATE DATE CantonType TreatmentType TreatmentReasonType VARIANT_BOOL | *pdDateBegin, *pdDateEnd, *peTreatmentCanton, *peTreatmentType, *peTreatmentReason, *pbStatus); |
[C/C++ return value] | S_OK | This value is returned if the function call was successful. |
 | S_FALSE | This value is returned if the end of an iteration is reached |
 | E_name | This value is returned if the function call was unsuccessful and an error exception was generated. Note that if you are using SmartPointers an exception is thrown under these conditions. |
space
Calling argument description |  |  |
[out] DATE | *pdDateBegin | dDateBegin is the supposed start of the treatment |
[out] DATE | *pdDateEnd | dDateEnd is the supposed end of the treatment |
[out] CantonType | *peTreatmentCanton | The treatment canton given by the CantonType enumeration |
[out] TreatmentType | *peTreatmentType | The treatment type (ambulatory or stationary) given by the TreatmentType enumeration |
[out] TreatmentReasonType | *peTreatmentReason | The treatment reason given by the TreatmentReasonType enumeration |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE then an error occurred and GetAbortInfo should be called to retrieve the error string. |
space |


  • IGeneralCreditResult
  • GetXtraData4CantonalPhysician

IGeneralCreditResult::GetXtraData4CantonalPhysician method |  |  | space
This method has a Restful Webservice representation only! Method for collecting all data for a cantonal physician covered by the IGeneralCreditResult interface and returned as JSON array. Please note that IGeneralCreditResult::GetXtraData4CantonalPhysician takes over the functionality of the iterator pair IGeneralCreditResult::GetFirstXtraData4CantonalPhysician / IGeneralCreditResult::GetNextXtraData4CantonalPhysician with a single call, making the latter superfluous. |  |  |
space
Restful webservice calling syntax |  |  |
[POST] | /baseURL/ IGeneralCreditResult/GetXtraData4CantonalPhysician
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[JSON result array] | { pbstrToken: pbstrValue: pbStatus: | "utf8StringValue", "utf8StringValue", booleanValue },
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Calling argument description |  |  |
[out] BSTR | *pbstrToken | The name of the token/value instruction pair |
[out] BSTR | *pbstrValue | The data of the token/value instruction pair |
[out,retval] VARIANT_BOOL | *pbStatus | Return status of the method. If pbStatus is VARIANT_FALSE the end of data is reached |
space |


  • IGeneralCreditResult
  • DestructGeneralCreditResult

IGeneralCreditResult::DestructGeneralCreditResult property |  |  | space
This property has a Restful Webservice representation only! Destructs/invalidates this IGeneralCreditResult interface instance. |  |  |
space
Restful webservice calling syntax |  |  |
[PUT] | /baseURL/ IGeneralCreditResult/PutDestructGeneralCreditResult
[JSON input data] | pIGeneralCreditResult: | longValue, //interface address
[HTTP result status] | 200 | Return status 200 signals a successful method call |
 | 204 | Return status 204 (noContent) signals that the end of an iteration is reached |
 | >= 400 | Return status >= 400 signals an unsuccessful function call. The returned JSON{errorCode: code, errorText:"text"} supplies the error message the same as GetAbortInfo() would do. |
space
Remarks |  |  |
This property has a Restful Webservice representation only! |  |  |
space |


  • Type definitions

Builtin, composite & enumeration types |  | V4.50/ 1 Nov 2019
The following list shows ans defines all used data types either basic builtin, composite or enumeration types that are used in the interface of the ATL COM module. |  | space
space
Data types |  | 26 types
[enumeration] AddressType | Enumerates the defined types of addresses. |
[builtin] BSTR | A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions |
[enumeration] CantonType | Enumerates the defined Swiss cantons as well as countries close to the border. |
[enumeration] CreditType | Enumerates the defined types of credit request |
[builtin] DATE | DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. |
[enumeration] DiagnosisType | Enumerates the defined diagnosis coding systems. |
[builtin] double | An 8-byte IEEE real value. |
[enumeration] generationAttributes | List of options with which the standard generation of the XML infoset and/or print process can be oversteered. |
[enumeration] HospitalizationClass | Enumerates the defined classes/types of hospitalization |
[enumeration] HospitalizationMode | Enumerates the defined modes/indications of the hospitalization |
[enumeration] HospitalizationType | Enumerates the defined types (reasons) of the hospitalization |
[builtin] HRESULT | The HRESULT data type is a 32-bit value that is used to describe an error or warning |
[builtin] IAddress | The IAddress interface object |
[builtin] IGeneralCreditRequest | The IGeneralCreditRequest interface object |
[builtin] IGeneralCreditResult | The IGeneralCreditResult interface object |
[enumeration] LanguageType | Enumerates all supported languages. |
[enumeration] LawType | Enumerates the supported legal law set. |
[builtin] long | A 4-byte integer value. |
[enumeration] ModusType | Enumerates the defined operation modus types |
[enumeration] PlaceType | Enumerates the defined places where the main provider is located |
[enumeration] RoleType | Enumerates the defined role categories that the main provider is best categorized |
[enumeration] SexType | Enumerates the defined basic gender types. |
[enumeration] TreatmentReasonType | Enumerates the list of defined treatment reasons. |
[enumeration] TreatmentType | Enumerates the top level treatment types. |
[builtin] VARIANT_BOOL | A 16 bit Boolean (True/False) value was specified |
[enumeration] YesNoType | Boolean enumerator. |
space |


  • Type definitions
  • AddressType

AddressType enumeration type |  |
Enumerates the defined types of addresses. |  | space
space
Set of enumeration values |  | 3 elements
enAddressUndefined: 0 | Address type is undefined or unknown. |
enAddressPerson: 1 | Address of a person |
enAddressCompany: 2 | Address of a company |
space


  • Type definitions
  • BSTR

BSTR type |
A BSTR, known as basic string or binary string, is a pointer to a wide character string used by Automation data manipulation functions. BSTRs are wide, double-byte (Unicode) strings on 32-bit Windows platforms. | space
space
space


  • Type definitions
  • CantonType

CantonType enumeration type |  |
Enumerates the defined Swiss cantons as well as countries close to the border. |  | space
space
Set of enumeration values |  | 32 elements
enCantonUndefined: 0 | Undefined or unknown canton. |
enAG: 1 | The Swiss canton is AG |
enAI: 2 | The Swiss canton is AI |
enAR: 3 | The Swiss canton is AR |
enBE: 4 | The Swiss canton is BE |
enBL: 5 | The Swiss canton is BL |
enBS: 6 | The Swiss canton is BS |
enFR: 7 | The Swiss canton is FR |
enGE: 8 | The Swiss canton is GE |
enGL: 9 | The Swiss canton is GL |
enGR: 10 | The Swiss canton is GR |
enJU: 11 | The Swiss canton is JU |
enLU: 12 | The Swiss canton is LU |
enNE: 13 | The Swiss canton is NE |
enNW: 14 | The Swiss canton is NW |
enOW: 15 | The Swiss canton is OW |
enSG: 16 | The Swiss canton is SG |
enSH: 17 | The Swiss canton is SH |
enSO: 18 | The Swiss canton is SO |
enSZ: 19 | The Swiss canton is SZ |
enTG: 20 | The Swiss canton is TG |
enTI: 21 | The Swiss canton is TI |
enUR: 22 | The Swiss canton is UR |
enVD: 23 | The Swiss canton is VD |
enVS: 24 | The Swiss canton is VS |
enZG: 25 | The Swiss canton is ZG |
enZH: 26 | The Swiss canton is ZH |
enLiechtenstein: 27 | The country is Liechtenstein |
enAustria: 28 | The country is Austria |
enGermany: 29 | The country is Germany |
enItaly: 30 | The country is Italy |
enFrance: 31 | The country is France |
space


  • Type definitions
  • CreditType

CreditType enumeration type |  |
Enumerates the defined types of credit request |  | space
space
Set of enumeration values |  | 3 elements
enCreditNew: 1 | The credit is of type enCreditNew - an initial first credit request |
enCreditReconsideration: 2 | The credit is of type enCreditReconsideration - an credit request whose data space is unmodified (regarding a previously sent but rejected credit) but possibly extended by further documents and is sent for a re-consideration at the recipient's site. |
enCreditProlongation: 3 | The credit is of type enCreditProlongation - a follow up, prolonged credit request following a previously created first credit. |
space


  • Type definitions
  • DATE

DATE type |
DATE is denoting a date and time represented by a double-precision number, where midnight, January 1st, 1900 has the value 2.0, January 2nd, 1900 is 3.0, and so on. | space
space
space


  • Type definitions
  • DiagnosisType

DiagnosisType enumeration type |  |
Enumerates the defined diagnosis coding systems. |  | space
space
Set of enumeration values |  | 8 elements
enDiagnosisICD: 0 | ICD 10 diagnosis catalog |
enDiagnosisCHOP: 1 | CHOP 9 diagnosis catalog |
enDiagnosisDRG: 2 | DRG tariff catalog |
enDiagnosisICPC: 3 | ICPC diagnosis catalog (International Classification of Primary Care) |
enDiagnosisCantonal: 4 | Cantonal diagnosis catalog ("TI Diagnosis catalog") |
enDiagnosisByContract: 5 | Diagnosis coded according to a bilateral contract |
enDiagnosisFreeText: 6 | Free text diagnosis system |
enDiagnosisBirthdefect: 7 | Birth defect diagnosis catalog |
space


  • Type definitions
  • double

double type |
An 8-byte IEEE real value. | space
space
space


  • Type definitions
  • generationAttributes

generationAttributes enumeration type |  |
List of options with which the standard generation of the XML infoset and/or print process can be oversteered. |  | space
space
Set of enumeration values |  | 3 elements
enGenerateXMLWithoutDocuments: 65536 | The XML infoset is generated without any documents even if such documents have been added in the IGeneralInvoiceRequest::AddDocument method. |
enGenerateXMLWithoutSignature: 131072 | The XML infoset is generated without applying a signature even if the signature parameters have been set in the IGeneralInvoiceRequest::SetTransport method. |
enGenerateXMLWithoutEncryption: 262144 | The XML infoset is generated without applying encryption even if the encryption parameters have been set in the IGeneralInvoiceRequest::SetTransport method. |
space


  • Type definitions
  • HospitalizationClass

HospitalizationClass enumeration type |  |
Enumerates the defined classes/types of hospitalization |  | space
space
Set of enumeration values |  | 5 elements
enClassGeneral: 0 | The general hospitalization class is used |
enClassSemiPrivate: 1 | The semi-private hospitalization class is used |
enClassPrivate: 2 | The private hospitalization class is used |
enHospitalComfort: 3 | The comfort hospitalization class is used |
enFreeMDChoice: 4 | The hospitalization class with free choice of physician is used |
space


  • Type definitions
  • HospitalizationMode

HospitalizationMode enumeration type |  |
Enumerates the defined modes/indications of the hospitalization |  | space
space
Set of enumeration values |  | 3 elements
enCantonal: 0 | Mode of hospitalization is cantonal |
enIndicated: 1 | Mode of hospitalization is non-cantonal (person living in another canton then treated) but indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |
enNonIndicated: 2 | Mode of hospitalization is non-cantonal (person living in another canton then treated) and not indicated. This implicitly qualifies to define "outer cantonal" data and to send a credit request to the cantonal surgeon. |
space


  • Type definitions
  • HospitalizationType

HospitalizationType enumeration type |  |
Enumerates the defined types (reasons) of the hospitalization |  | space
space
Set of enumeration values |  | 3 elements
enRegular: 0 | The type of the hospitalization is an emergency |
enEmergency: 1 | The type of the hospitalization is regular |
enWelfare: 2 | The type of the hospitalization is due to welfare ("Freiheitsenzug") |
space


  • Type definitions
  • HRESULT

HRESULT type |
The HRESULT data type is a 32-bit value that is used to describe an error or warning | space
space
space


  • Type definitions
  • IAddress

IAddress type |
The IAddress interface object | space
space
space


  • Type definitions
  • IGeneralCreditRequest

IGeneralCreditRequest type |
The IGeneralCreditRequest interface object | space
space
space


  • Type definitions
  • IGeneralCreditResult

IGeneralCreditResult type |
The IGeneralCreditResult interface object | space
space
space


  • Type definitions
  • LanguageType

LanguageType enumeration type |  |
Enumerates all supported languages. |  | space
space
Set of enumeration values |  | 3 elements
enGerman: 1 | The language is German |
enFrench: 2 | The language is French |
enItalian: 3 | The language is Italian |
space


  • Type definitions
  • LawType

LawType enumeration type |  |
Enumerates the supported legal law set. |  | space
space
Set of enumeration values |  | 6 elements
enKVG: 0 | KVG - "Krankenversicherungsgesetz" |
enUVG: 1 | UVG - "Unfallversicherungsgesetz" |
enMVG: 2 | MVG - "Militäversicherungsgesetz" |
enIVG: 3 | IVG - "Invalidenversicherungsgesetz" |
enVVG: 4 | VVG - "Versicherungsvertragsgesetz" |
enORG: 5 | ORG - "Obligationenrecht" This is primarily for invoices e.g. of dentists. |
space


  • Type definitions
  • long

long type |
A 4-byte integer value. | space
space
space


  • Type definitions
  • ModusType

ModusType enumeration type |  |
Enumerates the defined operation modus types |  | space
space
Set of enumeration values |  | 2 elements
enProduction: 0 | Production modus. |
enTest: 1 | Test modus - the data should not be forwarded to the receiver. |
space


  • Type definitions
  • PlaceType

PlaceType enumeration type |  |
Enumerates the defined places where the main provider is located |  | space
space
Set of enumeration values |  | 5 elements
enPlacePractice: 1 | The service location is a practice |
enPlaceHospital: 2 | The service location is a hospital |
enPlaceLab: 4 | The service location is a laboratory |
enPlaceAssociation: 8 | The service location is in an association (like "Spitex") |
enPlaceCompany: 16 | The service location is a company |
space


  • Type definitions
  • RoleType

RoleType enumeration type |  |
Enumerates the defined role categories that the main provider is best categorized |  | space
space
Set of enumeration values |  | 21 elements
enRolePhysician: 1 | The main provider is a physician |
enRolePhysiotherapist: 2 | The main provider is a physiotherapist This role includes therapeutic masseurs as well. |
enRoleChiropractor: 4 | The main provider is a chiropractor |
enRoleErgotherapist: 8 | The main provider is an ergotherapist |
enRoleNutritionist: 16 | The main provider is a nutritionist This role includes diet advisors, diabetic dietitian and diabetic advisors as well |
enRoleMidwife: 32 | The main provider is a midwife |
enRoleLogotherapist: 64 | The main provider is a logotherapist |
enRoleHospital: 128 | The main provider's address is that of a hospital. Therefore the "virtual" role is enRoleHospital and it qualifies the invoice/reminder as one from a hospital |
enRolePharmacist: 256 | The main provider is a pharmacist |
enRoleDentist: 512 | The main provider is a dentist This role includes dental hygienists as well. |
enRoleLabTechnician: 1024 | The main provider is a lab technician |
enRoleDentalTechnician: 2048 | The main provider is a dental technician |
enRoleOtherTechnician: 4096 | The main provider The main provider is a technician but neither a dental nor a lab technician This role includes (orthopedic) shoemakers as well |
enRolePsychologist: 16384 | The main provider a psychologist Note that psychiatrists would count as enRolePhysician |
enRoleWholesaler: 65536 | The main provider is a wholesaler |
enRoleNursingStaff: 131072 | The main provider is belonging to the nursing staff including nursing auxiliaries |
enRoleTransport: 262144 | The main provider accomplishes transports or carrier services This role includes ambulance transport as well. |
enRoleDruggist: 524288 | The main provider is a druggist |
enRoleNaturopathicDoctor: 1048576 | The main provider is a is naturopathic doctor. As per definition this is a doctor of non-conventional Western medicine/non-biomedicine. |
enRoleNaturopathicTherapist: 2097152 | The main provider is a is naturopathic therapist. As per definition this is a therapist of non-conventional Western medicine/non-biomedicine. This role includes wellness therapists as well. |
enRoleOther: 4194304 | The main provider has another role than defined here. Supply a role title in this case with a description of the role |
space


  • Type definitions
  • SexType

SexType enumeration type |  |
Enumerates the defined basic gender types. |  | space
space
Set of enumeration values |  | 2 elements
enMale: 0 | Male. |
enFemale: 1 | Female. |
space


  • Type definitions
  • TreatmentReasonType

TreatmentReasonType enumeration type |  |
Enumerates the list of defined treatment reasons. |  | space
space
Set of enumeration values |  | 6 elements
enDisease: 0 | The treatment reason is due to a disease. |
enAccident: 1 | The treatment reason is due to an accident |
enMaternity: 2 | The treatment reason is due to maternity |
enPrevention: 3 | The treatment reason is due to a prevention. |
enBirthdefect: 4 | The treatment reason is due to a birth defect |
enUnknown: 5 | The treatment reason is unknown |
space


  • Type definitions
  • TreatmentType

TreatmentType enumeration type |  |
Enumerates the top level treatment types. |  | space
space
Set of enumeration values |  | 2 elements
enAmbulatory: 0 | Ambulatory (out-patient) treatment. |
enStationary: 1 | Stationary (in-patient) treatment. |
space


  • Type definitions
  • VARIANT_BOOL

VARIANT_BOOL type |
A 16 bit Boolean (True/False) value was specified. A value of 0xFFFF (all bits 1) indicates True; a value of 0 (all bits 0) indicates False. No other values are valid. | space
space
space


  • Type definitions
  • YesNoType

YesNoType enumeration type |  |
Boolean enumerator. |  | space
space
Set of enumeration values |  | 2 elements
enNo: 0 | No. |
enYes: 1 | Yes. |
space


 Sumex1 under a 64bit architecture...

All Sumex1 COM modules are written as 32bit managed C++ dll. As a consequence, a 64bit executable cannot load a 32bit COM dll into its process space due to the addressing differences.

Since some necessary underlying sub-modules are not available in a 64bit version, this problem must be addressed differently than by a 64bit compilation. As Microsoft suggests Sumex1 uses the out-of-process proxy approach where a 32bit COM server loads the 32bit COM dll into its process space and delegates each method call to the dll. Since a 32bit COM server exists in its own process space, the main 64bit process can handle the 64/32bit boundary without problems.

As a result, each 32bit Sumex1 COM dll has a 32bit COM server counterpart with the same name and an oopProxy prefix, e.g. oopProxyCareCreditManager450.exe, where the prefix signifies the out-of-process proxy nature of the executable.

Any 64bit software now creates an instance of the 32bit oopProxy server and then calls the same methods and properties as with the 32bit COM dll. However, there is one crucial difference when using the oopProxy mechanism, namely the necessity to forcefully unload to the COM server at the end e.g. by using Marshal.ReleaseComObject() since the automatic garbage collection approach is too error prone.


 Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects

  • the encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.

    Here recipient is used in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • the namespace v1 of W3C http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES

The generalCreditRequest module does obey all these conditions whenever encryption is "turned on" by setting a public certificate of the "toEAN" entity (cf. IGeneralCreditRequest::SetTransport). This certificate must be in the format "binary DER".

Where do I get this certificate?
The request/response system is self-contained insofar as the careCreditResponse module (or any other V4.5 module!) extracts the public certificate of a signed response XML infoset and generates a binary DER file named X509DER_from_EAN.cer. This is exactly the certificate to use for encrypting a nursing care credit (or all other V4.5) request XML infosets!


 Code snippets for using the generalInvoiceRequestManager

Private Sub GeneralCreditRequestExampleButton_Click()

On Error GoTo Err_Trap

Dim bStatus As Boolean

'### init variables
Dim strFrom As String
strFrom = "2001001302112"
Dim strVia As String
strVia = "2001000012345"
Dim strTo As String
strTo = "2034567890000"
Dim dBirthdate As Date
dBirthdate = DateValue("1944-02-28")
Dim eSex As SexType
eSex = enMale
Dim eCanton As CantonType
eCanton = enBS
Dim eLaw As LawType
eLaw = enKVG
Dim eTreatType As TreatmentType
eTreatType = enAmbulatory
Dim dTreatmentStart As Date
dTreatmentStart = DateValue("2020-07-01")
Dim dTreatmentEnd As Date
dTreatmentEnd = DateValue("2020-07-20")
Dim strPatientInsID As String
strPatientInsID = "123.45.678-012"
Dim eTreatmentReason As TreatmentReasonType
eTreatmentReason = enDisease
Dim strEanProvider As String
strEanProvider = "2034567890111"
Dim strEanResponsible As String
strEanResponsible = "2034567890333"

'### create the main GeneralCreditRequestManager interface
Dim generalCreditRequestManagerEx As GENERALCREDITREQUESTMANAGER450Lib.GeneralCreditRequestManager
Set generalCreditRequestManagerEx = New GeneralCreditRequestManager

'### generate the dependent GeneralCreditRequest interface (allows to input data)
Dim generalCreditRequestEx As GENERALCREDITREQUESTMANAGER450Lib.GeneralCreditRequest
Set generalCreditRequestEx = generalCreditRequestManagerEx.GeneralCreditRequest

'### start the input of data
generalCreditRequestEx.Initialize(enGerman)
generalCreditRequestEx.SetRequest(enRolePhysiotherapist,enPlacePractice,  _
                                  "Physiotherapie am Knetweg",enNo,enNo,enNo,enNo);

'### generate some routing/transport as well as some identifying data (required for XML only)
bStatus = generalCreditRequestEx.SetTransport(strFrom, "", "", strVia, strTo, "")
bStatus = generalCreditRequestEx.SetPackage("GeneralCreditRequestExample", 10001, 4, "sumex1")

'###############################################################################
'### start with credit relevant data, followed by the various address data
'###############################################################################
'### set data triple of the credit object (required)
bStatus = generalCreditRequestEx.SetCreditObject("PhysioID20200707", dTreatmentStart, 0)

'### set the applicable law (required)
bStatus = generalCreditRequestEx.SetLaw(enKVG, 0, "", strPatientInsID)

'### create an address interface that is need to add all the following addresses
'### do not forget to initialize the IAddress interface befor using it
Dim addressEx As GENERALCREDITREQUESTMANAGER450Lib.Address
Set addressEx = generalCreditRequestEx.CreateAddress

'### define the biller of the general credit (required)
'### note that phone, fax and online data are optional
addressEx.Initialize
bStatus = addressEx.SetCompany("Biller AG", "Abteilung Inkasso", "")
bStatus = addressEx.SetPostal("Billerweg 128", "", "4414", "Frenkendorf", "", "")
bStatus = addressEx.AddPhone("956 99 00", "061", "", "")
bStatus = addressEx.SetFax("956 99 10", "061", "+41", "")
bStatus = addressEx.SetOnline("info@biller.ch", "")
bStatus = generalCreditRequestEx.SetBiller("2011234567890", "H-1211-11", "", "", addressEx)

'### define the provider of the nursing care data (required)
'### note that only the required parts are defined here
addressEx.Initialize
bStatus = addressEx.SetCompany("Spitex", "Region Liestal", "")
bStatus = addressEx.SetPostal("Spitexgasse 17b5", "", "4410", "Liestal", "", "")
bStatus = generalCreditRequestEx.SetProvider(strEanProvider,"P-1234-56","", _
                                             "", addressEx)

'### define the health insurance (required)
addressEx.Initialize
bStatus = addressEx.SetCompany("Krankenkasse AG", "Sektion Basel", "")
bStatus = addressEx.SetPostal("Kassengraben 222", "", "4000", "Basel", "", "")
bStatus = generalCreditRequestEx.SetInsurance("2034567890222", addressEx)

'### define the patient (required)
'### note that more data are needed here (sex, birthdate,ssn). data from the insurance
'### card can be supplied as well
addressEx.Initialize
bStatus = addressEx.SetPerson("Muster", "Peter", "Herr", "", "c/o Mieter Karl")
bStatus = addressEx.SetPostal("Musterstrasse 5", "", "7304", "Maienfeld", "", "")
bStatus = generalCreditRequestEx.SetPatient(eSex, dBirthdate, "756.1234.5678.90",  _
                                         enDisabilityNone, enIncontinenceNone, addressEx)

bStatus = generalCreditRequestEx.SetCard("12345678901234567890", DateValue("2019-12-31"), _
                                         DateValue("2016-02-01"), "", "")

'### define a referrer if any (optional)
addressEx.Initialize
bStatus = addressEx.SetPerson("Ueberweiser", "Herbert", "Herr", "Dr. med.", "")
bStatus = addressEx.SetPostal("Referrerstrasse 11", "", "5000", "Aarau", "", "")
bStatus = generalCreditRequestEx.SetReferrer("2034567890333", "R-2345-67", "", "", addressEx)

'###############################################################################
'### define some treatment data for an ambulatory case and supply some services
'###############################################################################
'### set treatment information (required)
bStatus = generalCreditRequestEx.SetTreatment(dTreatmentStart, dTreatmentEnd, eCanton, _
                                              eTreatmentReason)

bStatus = generalCreditRequestEx.AddService("311","7320","", _
                "Sitzungspauschale fuer Elektro- und Thermotherapie/Instruktion bei Geraetevermietung", _
                6,dTreatmentStart, 1.0, 25.0, 1.0, "")

bStatus = generalCreditRequestEx.AddService("311","7350","", _
                "Zuschlagsposition fuer die erste Behandlung eines Patienten", _
                1,dTreatmentStart, 1.0, 24.0, 1.0, "")

bStatus = generalCreditRequestEx.AddService("311","7320","", _
                "Sitzungspauschale fuer Elektro- und Thermotherapie/Instruktion bei Geraetevermietung", _
                6,dTreatmentEnd, 1.0, 10.0, 1.0, "")

bStatus = generalCreditRequestEx.AddService("452","10.01.01.00.1","","Kruecken fuer Erwachsene, Kauf", _
                 1,dTreatmentEnd, 0.92, 10.0, 1.0, "")

'### define the measures  - required
bStatus = generalCreditRequestEx.SetSubstantiation("Lorem ipsum dolor sit amet, consetetur....", _
                "this is an optional remark, basically to express something apart from the measures")

'### finalize the input
bStatus = generalCreditRequestEx.Finalize()

'### print the general credit request out as defined by the data
Dim lTimestamp As Integer
Dim generalCreditResultEx As CARECREDITREQUESTMANAGER450Lib.CareCreditResult
bStatus = generalCreditRequestManagerEx.Print("",0,enNo,"",lTimestamp,   _
                                              generalCreditResultEx)
Set generalCreditResultEx = Nothing

'### finally produce the XML infoset
'### note that the interface generalCreditResultEx is returned by the method
'### if the call was successful - it must not be created!
Dim lGenerationAttribute As Long
lGenerationAttribute = 0
Dim lValidationError As Long
Dim strXMLFile As String
Dim strUsedXSDSchema As String
bStatus = generalCreditRequestManagerEx.GetXML(lGenerationAttribute, strXMLFile, lValidationError, _
                                                lTimestamp, strUsedXSDSchema, generalCreditResultEx)

'### copy the XML infoset away
Dim strTargetFile As String
strTargetFile = "C:\\GeneralCreditRequestExample.xml"
FileCopy strXMLFile, strTargetFile

'### relase all resources
Set addressEx = Nothing
Set generalCreditResultEx = Nothing
Set generalCreditRequestEx = Nothing
Set generalCreditRequestManagerEx = Nothing

Exit Sub

'### error situation
Err_Trap:
    MsgBox "Error: " & Err.Description, vbCritical, _
           "Opps! Error" & Str$(Err.Number)

'### release all resources
Set addressEx = Nothing
Set generalCreditResultEx = Nothing
Set generalCreditRequestEx = Nothing
Set generalCreditRequestManagerEx = Nothing

End Sub

private void generalCreditRequestExampleButton_Click()
{
    ServiceExInput serviceInputEx;
    CARECREDITREQUESTMANAGER450Lib.Address addressEx;
    CARECREDITREQUESTMANAGER450Lib.CareCreditRequest generalCreditRequestEx;
    CARECREDITREQUESTMANAGER450Lib.CareCreditRequestManager generalCreditRequestManagerEx;
    CARECREDITREQUESTMANAGER450Lib.CareCreditResult generalCreditResultEx;

    try
    {
        bool bStatus;
        // ### init variables
        string strFrom = "2001001302112";
        string strVia = "2001000012345";
        string strTo = "2034567890000";
        DateTime dBirthdate = DateTime.ParseExact("1944-02-28", "yyyy-MM-dd",
                                                  System.Globalization.CultureInfo.InvariantCulture);
        SexType eSex = SexType.enMale;
        CantonType eCanton = CantonType.enBS;
        LawType eLaw = LawType.enKVG;
        TreatmentType eTreatType = TreatmentType.enAmbulatory;
        DateTime dTreatmentStart = DateTime.ParseExact("2020-07-01", "yyyy-MM-dd",
                                                       System.Globalization.CultureInfo.InvariantCulture);
        DateTime dTreatmentEnd = DateTime.ParseExact("2020-07-20", "yyyy-MM-dd",
                                                     System.Globalization.CultureInfo.InvariantCulture);
        string strPatientInsID = "123.45.678-012";
        TreatmentReasonType eTreatmentReason = TreatmentReasonType.enDisease;
        string strEanProvider = "2034567890111";
        string strEanResponsible = "2034567890333";

        // ### create the main CareCreditRequestManager interface
        generalCreditRequestManagerEx = new CareCreditRequestManager();
        generalCreditRequestManagerEx.SetModuleLanguage(LanguageType.enGerman);

        // ### generate the dependent CareCreditRequest interface (allows to input data)
        generalCreditRequestEx = generalCreditRequestManagerEx.CareCreditRequest;

        // ### start the input of data
        generalCreditRequestEx.Initialize(LanguageType.enGerman);
        generalCreditRequestEx.SetRequest(YesNoType.enNo,YesNoType.enNo,OrdinanceType.enFirstOrdinance,"");
        generalCreditRequestEx.SetRequest(RoleType.enRolePhysiotherapist,PlaceType.enPlacePractice,
                                          "Physiotherapie am Knetweg",YesNoType.enNo,YesNoType.enNo,
                                          YesNoType.enNo,YesNoType.enNo);

        // ### generate some routing/transport  as well as some identifying data (required for XML only)
        bStatus = generalCreditRequestEx.SetTransport(strFrom, "", "", strVia, strTo, "");
        bStatus = generalCreditRequestEx.SetPackage("CareCreditRequestExample", 10001, 4, "sumex1");

        // ###############################################################################
        // ### start with credit relevant data, followed by the various address data
        // ###############################################################################
        // ### set data triple of the credit object (required)
        bStatus = generalCreditRequestEx.SetCreditObject("PhysioID20200707", dTreatmentStart, 0);

        // ### set the applicable law (required)
        bStatus = generalCreditRequestEx.SetLaw(LawType.enKVG, DateTime.MinValue, "", strPatientInsID);

        // ### create an address interface that is need to add all the following addresses
        // ### do not forget to initialize the IAddress interface befor using it
        addressEx = generalCreditRequestEx.CreateAddress;

        // ### define the biller of the nursing care credit (required)
        // ### note that phone, fax and online data are optional
        addressEx.Initialize();
        bStatus = addressEx.SetCompany("Biller AG", "Abteilung Inkasso", "");
        bStatus = addressEx.SetPostal("Billerweg 128", "", "4414", "Frenkendorf", "", "");
        bStatus = addressEx.AddPhone("956 99 00", "061", "", "");
        bStatus = addressEx.SetFax("956 99 10", "061", "+41", "");
        bStatus = addressEx.SetOnline("info@biller.ch", "");
        bStatus = generalCreditRequestEx.SetBiller("2011234567890", "H-1211-11", "", "", addressEx);

        // ### define the provider of the nursing care data (required)
        // ### note that only the required parts are defined here
        addressEx.Initialize();
        bStatus = addressEx.SetCompany("Spitex", "Region Liestal", "");
        bStatus = addressEx.SetPostal("Spitexgasse 17b5", "", "4410", "Liestal", "", "");
        bStatus = generalCreditRequestEx.SetProvider(strEanProvider, "", "", "", addressEx);

        // ### define the health insurance (required)
        addressEx.Initialize();
        bStatus = addressEx.SetCompany("Krankenkasse AG", "Sektion Basel", "");
        bStatus = addressEx.SetPostal("Kassengraben 222", "", "4000", "Basel", "", "");
        bStatus = generalCreditRequestEx.SetInsurance("2034567890222", addressEx);

        // ### define the patient (required)
        // ### note that more data are needed here (sex, birthdate,ssn) as well as insurance card data
        addressEx.Initialize();
        bStatus = addressEx.SetPerson("Muster", "Peter", "Herr", "", "c/o Mieter Karl");
        bStatus = addressEx.SetPostal("Musterstrasse 5", "", "7304", "Maienfeld", "", "");
        bStatus = generalCreditRequestEx.SetPatient(eSex, dBirthdate, "756.1234.5678.90",
                                                 DisabilityAllowanceType.enDisabilityNone,
                                                 IncontinenceDegreeType.enIncontinenceNone, addressEx);
        bStatus = generalCreditRequestEx.SetCard("12345678901234567890", DateTime.ParseExact("2019-12-31",
                                                  "yyyy-MM-dd",
                                                  System.Globalization.CultureInfo.InvariantCulture),
                                                  DateTime.ParseExact("2019-02-01", "yyyy-MM-dd",
                                                  System.Globalization.CultureInfo.InvariantCulture),
                                                  "", "");

        // ### define a referrer if any (optional)
        addressEx.Initialize();
        bStatus = addressEx.SetPerson("Ueberweiser", "Herbert", "Herr", "Dr. med.", "Allgemeinmedizin FMH");
        bStatus = addressEx.SetPostal("Referrerstrasse 11", "", "5000", "Aarau", "", "");
        bStatus = generalCreditRequestEx.SetReferrer("2034567890333", "R-2345-67", "", "", addressEx);

        // ###############################################################################
        // ### define some treatment data for an ambulatory case and supply some services
        // ###############################################################################
        // ### set treatment information (required)
        bStatus = generalCreditRequestEx.SetTreatment(dTreatmentStart, dTreatmentEnd,
                                                   eCanton, eTreatmentReason);

        bStatus = generalCreditRequestEx.AddService("311","7320","",
                "Sitzungspauschale fuer Elektro- und Thermotherapie/Instruktion bei Geraetevermietung",
                6,dTreatmentStart, 1.0, 25.0, 1.0, "")

        bStatus = generalCreditRequestEx.AddService("311","7350","",
                "Zuschlagsposition fuer die erste Behandlung eines Patienten",
                1,dTreatmentStart, 1.0, 24.0, 1.0, "")

        bStatus = generalCreditRequestEx.AddService("311","7320","",
                "Sitzungspauschale fuer Elektro- und Thermotherapie/Instruktion bei Geraetevermietung",
                6,dTreatmentEnd, 1.0, 10.0, 1.0, "")

        bStatus = generalCreditRequestEx.AddService("452","10.01.01.00.1","",
                "Kruecken fuer Erwachsene, Kauf",1,dTreatmentEnd, 0.92, 10.0, 1.0, "")

        // ### define the measures  - required
        bStatus = generalCreditRequestEx.SetSubstantiation("Lorem ipsum dolor sit amet, cosetur....",
                "this is an optional remark, basically to express something apart from the measures")

        // ### finalize the input
        bStatus = generalCreditRequestEx.Finalize();

        // ### finally produce the XML infoset
        // ### note that the interface generalCreditResultEx is returned by the method
        // ### if the call was successful - it must not be created!
        int lGenerationAttribute = 0;
        int lValidationError;
        int lTimestamp = 0;

        string strXMLFile;
        string strUsedXSDSchema;
        bStatus = generalCreditRequestManagerEx.GetXML(lGenerationAttribute, out strXMLFile,
                                                        out lValidationError, out lTimestamp,
                                                        out strUsedXSDSchema, out generalCreditResultEx);

        // ### copy the XML infoset away
        string strTargetFile = "GeneralCreditRequestExample.xml";
        System.IO.File.Copy(strXMLFile, strTargetFile);
    }
    catch (Exception ex)
    {
        MessageBox.Show("Opps! Error " + ex.ToString(), "OK");
    }

    finally
    {
        // ### relase all resources
        serviceInputEx = null;
        addressEx = null;
        generalCreditResultEx = null;
        generalCreditRequestEx = null;
        generalCreditRequestManagerEx = null;

    }
}


 General use of the generalCreditRequest ATL COM module

The IGeneralCreditRequestManager interface provides all the necessary tools to produce nursing care credit requests for all roles and places.

Firstly, an instance of the IGeneralCreditRequest interface is created by the GetGeneralCreditRequest property. All the nursing care credit related data and parameters can be set by the supplied interface methods as SetPatient, SetTreatment,...

One auxiliary input interface IAddress is available for setting/retrieving addresses in a structured way.

After all information is defined the nursing care credit is printed or a XML infoset is produced which can be electronically transported to the recipient. In the latter case the care credit request optionally can be signed and/or encrypted .

Due to the processing attributes "storno" and "copy" a previously generated care credit request object can be canceled or a copy can be produced (cf. Notes about processing attributes).

To get a starting point there is a Visual Basic or C# code snippet provided that can be used for using the generalCreditRequest module.


 How to generate PDF archive files of a nursing care credit request

To generate PDF archive files of a nursing care credit request in the generalCreditRequestManager use
(PDF=PDF_file_to_generate;)
or
(PDF_NOPRINT=PDF_file_to_generate;)
as a print object name in the Print method (cf. "Syntax of the printTemplate variable" for an overview about print object names). The "PDF" token means to print the care credit object and generate the PDF files, whereas the "PDF_NOPRINT" token only generates the PDF files without physical printing.
The above print object definition is ignored in the print preview mode!

In its simplest form the IGeneralCreditRequestManager::Print method looks like:

     BSTR bstrPrintTemplate = "(PDF="+bstrPDFFile+";)";

     IGeneralCreditRequestManager::Print(bstrPrintTemplate,...);
in order to generate a PDF archive file of the "Bedarfsmeldung".

Since the PDF generation is not the primary purpose of the Print method this PDF feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped into the log file!
Boundary conditions:
  • Only active in printing mode
  • No error propagation
  • The supplied PDF archive name must not exist
  • The directory where the PDF is stored must be writable (EMF files are temporarily generated and delete there.)


 How to best make...

The following list describes the easiest way to generate e.g. a copy or storno request given that the initial nursing care request was successfully produced and the none-encrypted XML infoset of type generalCreditRequest_450 was archived on a local disk

copy of a nursing care credit request
This can be accomplished by calling the following 4 methods:
  1. IGeneralCreditRequestManager::LoadXML using careCreditXML as input file
  2. IGeneralCreditResult::GetRequest to retrieve the parameters
  3. IGeneralCreditRequest::SetRequest with eIsCopy=enYes
  4. IGeneralCreditRequestManager::GetXML
storno of nursing care credit request
This can be accomplished by calling the following 4 methods:
  1. IGeneralCreditRequestManager::LoadXML using careCreditgXML as input file
  2. IGeneralCreditResult::GetRequest to retrieve the parameters
  3. IGeneralCreditRequest::SetRequest with eIsStorno=enYes
  4. IGeneralCreditRequestManager::GetXML


 Query reachability of a recipient by the medSRS webservice

medSRS.ch is an open routing service for standards of the Forum Datenaustausch, basically allowing to find a communication partner in function of/for a certain Forum Datenaustausch standard.

The Routing Half Set (RHS) consists of a set of Global Location Numbers (GLN) plus the targeting Forum Datenaustausch standard forming an address path to an intermediate.

glnProvider(standardName, glnIntermediate, glnFrom)

In this notation, a provider is bounded to an intermediate with a certain standard having the given GLN at that intermediate. By using the query interface of medSRS, the RHS of a searched communication partner is returned.

The medSRS service is accessible, managed, and queried by a RESTful webservice defined and build upon the state of the art OpenAPI 3.0 standard. Please consult the medSRS.ch website directly for an in-depth introduction to the principles and objectives of the medSRS service and the associated RESTful web service calls.

Patch of the IGeneralCreditRequest::SetTransport method

Important new feature: the electronic reachability of a recipient for a certain version of generalCreditRequest is kind of a chicken and egg problem. To solve this connectivity problem, the webservice medSRS (medical Standard Routing Service) has been created. By using the RESTful webservice method queryRHS one can find out, how and whether a specific recipient can be reached electronically. Please refer to the website medSRS.ch for getting an introduction to the topic or detailed information about the functionality of the webservice.

Instead of inputting the argument bstrToEan literal, the string queryRHS(glnProvider,glnRecipient) is supplied virtually as a webservice call in the IGeneralCreditRequest::SetTransport method. The such given data is actually translated into the RESTful call of the same name.

The usage of the patch can generate a new error code 'ERROR_RECIPIENTRHS_NOTAVAILABLE' indicating that a given recipient is not reachable. It is the decision of the calling program whether the error 'ERROR_RECIPIENTRHS_NOTAVAILABLE' will be considered or not.


 How to print webstamps onto a nursing care credit request

To print a webstamp onto a nursing care credit in the generalCreditRequestManager use a special print object name (cf. "Syntax of the printTemplate variable" for an overview).

(WEBSTAMP=file_path_of_BMP_file;)
as a print object name on the printTemplate variable of the IGeneralCreditRequestManager::Print method.

In its simplest form the IGeneralCreditRequestManager::Print method looks like:

     BSTR bstrPrintTemplate = "(WEBSTAMP="+bstrBMPFile+";)";

     IGeneralCreditRequestManager::Print(bstrPrintTemplate,...);
in order to print a webstamp onto the first page of the "Bedarfsmeldung".

Since the webstamp printing is not the primary purpose of the Print method this feature has NO error propagation. The generation is done on a best effort basis, errors are only dumped into the log file!

Boundary conditions:

  • No error propagation
  • The supplied BMP webstamp must exist


 How to set the default printer for a certain request

The report generator included in the module allows to map a printer with its print settings against a print template.

The interface IGeneralCreditRequestManager includes the IGeneralCreditRequestManager::PrintSetup method which displays the Microsoft's standard print setup dialog. The defined printer and its settings are then stored persistently in a INI file of the same name as the print template but with an extension .vpd (whereas the print template has an extension .vps).


 Syntax of the printTemplate variable of the Print method

bstrPrintTemplate argument of the IGeneralCreditRequestManager::Print is either empty or of the general form defined below. In the case of an empty bstrPrintTemplate variable, no print variables are changed/substituted and the default print templates are used according to the defined language, law and tiers type.

However, bstrPrintTemplate can be used to change the normal printing behavior or changing the content of printing objects dynamically. The following syntax is used as content of the bstrPrintTemplate variable:

[logTpl][(objectName1=text;...)][=printTemplateFile][#INIPATH=inipath]

where a [] pair defines an optional part. The commands are case insensitive and have the following meaning:
  • logTpl: is the logical template name. Currently there is only one template name defined: { detail }.
    The variant with the 'fee' tag produces fee notes/reminders (with the law=enORG), while the other variant provides the healthcare-defined invoices/reminders (with the law<>enORG).
  • objectName1=text; does control a substitution of the content of the print object objectName.
    A print object is terminated by a semicolon and all print objects together are enclosed in a () pair.
    There are 3 predefined pseudo print objects with a special meaning:
    • PDF for generating PDF files
    • WEBSTAMP for printing electronic stamps
  • printTemplateFile defines an external print template file name (full path + name!).
  • #INIPATH=inipath defines a fully qualified path to a directory where the report engine searches the corresponding .vpd print template INI file.
    This allows for global settings of a print template in a LAN. The default inipath is the install directory of the Dll

Here are some usage examples:
  • bstrPrintTemplate: "" or bstrPrintTemplate: Detail denotes a standard printing situation.
  • bstrPrintTemplate: detail(DOCUMENT_TITLE_DETAIL=Alternate title for the care title;) prints a substituted title onto the standard print output.
  • bstrPrintTemplate: detail=C:\myForms\myPrintForm.vps
    uses the print template "C:\myForms\myPrintForm.vps" instead of the default one in the installation directory. An optional INI file with the name "C:\myForms\myPrintForm.vpd" is searched under this condition at the same directory.
  • bstrPrintTemplate: #INIPATH=\\host1\myForms\
    the default path for the ini files (place of the installed component) is changed to "\\host1\myForms\". If "\\host1\myForms\" is accessible by all hosts of the LAN then the same settings (printer/printing settings) can be used.


 Process attributes...

An XML request is primarily defined by its topmost object reference (cf. "Overview over "Object reference"). However, the XML request is further characterized by a state that is formed by a set of Boolean process attributes, namely

"copy" attribute

The copy attribute defines the XML request as an identical copy of an initial request.
The absence of the copy attribute in reverse defines the XML request as "normal" (initial) request.

It is considered an error to send a XML request with turned on copy attribute without having prior sent a "normal" request.

"storno" attribute

The storno attribute cancels the XML request defined by the topmost reference object.
The absence of the storno attribute in reverse defines the XML request as "normal" request.

It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

The copy and storno attributes can be combined to form a total of 4 different combinations.


 Object reference...

The following paragraphs defines the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • ID of the object defined by the provider
Each and every XML request of version 4.5 is defined by such an object reference. All XML responses are replies to the object reference of the corresponding request.

Thus the object reference is a clustered primary key of the request/response system!

object reference chain

As a consequence of the XML schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "GeneralCreditRequest" can hold a maximum of 2 object references, namely
  • an optional credit_ref object reference from a prvious "General Credit Request" process
  • a mandatory credit object reference from the "General Credit Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> credit) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


 Introduction, overview and usage of the Restful Webservice Server

The application generalCreditRequestManagerServer450.exe is a Restful Webservice Server, that has the same interface methods/properties as the COM module generalCreditRequestManager450.dll.
This allows to create a programming semantically similar to the COM approach but under the Restful Webservice paradigm. Consequently, on the Restful Client side there are no prevailing dependencies on Microsoft platforms and/or on Microsoft resources such as the database technology. Of course, the installation location of the server software is still subject to these restrictions.

In the next section of this document, the installation, configuration and operation of generalCreditRequestManagerServer450.exe will be addressed.

Installation, registration and parameterization:
By installing the installer object generalCreditRequestManager450 the COM module generalCreditRequestManager450.dll as well as the out-of-process proxy component oopGeneralCreditRequestManager450.exe is automatically installed/registered in the system. However, the generalCreditRequestManagerServer450.exe must be installed manually as a system service.
generalCreditRequestManagerServer450.exe -help | Creates a help window with the the name and full version of the applicationb as well as the currently define Webservice Endpoint. Furthermore the complete list of command line switches is shown.
generalCreditRequestManagerServer450.exe -install | Installs/registers the Restful Webservice Server as a system service. Please take into account, that the installation must be performed under administrator privileges
generalCreditRequestManagerServer450.exe -uninstall | Uninstalls the system service component. Please take into account, that the uninstallation must be performed under administrator privileges
generalCreditRequestManagerServer450.exe -setport X | Sets the port X as part of the Webservice Endpoint
Restful Webservice Endpoint:
Installing generalCreditRequestManagerServer450.exe as a service activates the Restful Webservice Endpoint:
http://localhost:35338/generalCreditRequestManagerServer450
which is subsumed as baseURL in the subsequent API documentation.

To run the webservice under a different URL or under https protocol, a permanent webservice target endpoint mapping is performed on the target system.
For example, under Apache, the following rewrite rule is defined:
<VirtualHost *:*>
    ProxyPreserveHost Off
    Header always set Access-Control-Allow-Origin "*"
    Header always set Access-Control-Max-Age "1000"
    Header always set Access-Control-Allow-Headers "x-requested-with, Content-Type, origin, authorization, accept, client-security-token"

    ProxyPass /generalCreditRequestManager/450/ http://localhost:35338/generalCreditRequestManagerServer450/
    ProxyPassReverse /generalCreditRequestManager/450/ http://localhost:35338/generalCreditRequestManagerServer450/
</VirtualHost>
Restful Webservice Operation:
The service might be modified after installation, for example to start under a different account, to extend the recovery properties or to change the startup type. Finally, this should be set to 'Automatic' or 'Automatic (Delayed start)' so that the service is automatically available after a system restart.
Remarks about programming:
In the rest of this document we will discuss programming of the Restful web service and the differences to the C/C++ programming of the classic COM component.

As already mentioned, Restful programming is analogous to C++ programming with the addition that each instance of an interface (including the main interface) is created via the corresponding GET function. For example, an instance of the main interface is created with:
baseURL/IGeneralCreditRequestManager/GetCreateGeneralCreditRequestManager | returns the instance address as JSON out{pIGeneralCreditRequestManager: longValue,...}
In every further call of a method or a property of the main interface this instance address must be included as part of the JSON-In. The termination/deletion of an instance must be done via the corresponding PUT Destruct property:
baseURL/IGeneralCreditRequestManager/PutDestructGeneralCreditRequestManager | with JSON-In{pIGeneralCreditRequestManager: longValue}, deletes the corresponding main instance AND all at that moment still active dependent subinstances (subinstances which have been generated by the explicit main instance).
It should be noted that the webserver generalCreditRequestManagerServer450.exe performs an internal management of the generated instances and automatically deletes instances that have no activity for a defined period of 1 hour. If after the deletion a rest call with such an instance is made, an error (HTTP Status >= 400) is generated and the instance address is marked as unknown.
Code snippet:
Minimal code snippet to load an XML and produce a PDF representation of that input data:

    http://localhost:35338/generalCreditRequestManagerServer450/IGeneralCreditRequestManager/GetModuleVersion?pIGeneralCreditRequestManager=45467
        returns JSON-Out{pbstrModuleVersion: "1.00.010"}

    http://localhost:35338/generalCreditRequestManagerServer450/IGeneralCreditRequestManager/GetModuleLanguage?pIGeneralCreditRequestManager=45467
        returns JSON-Out{peLanguage: "1"}

    http://localhost:35338/generalCreditRequestManagerServer450/IGeneralCreditRequestManager/GetGeneralCreditRequest?pIGeneralCreditRequestManager=45467
        returns JSON-Out{pIGeneralCreditRequest: 5788991}

    http://localhost:35338/generalCreditRequestManagerServer450/IGeneralCreditRequest/PutDestructGeneralCreditRequest
        JSON-IN(pIGeneralCreditRequest: 5788991}

    http://localhost:35338/generalCreditRequestManagerServer450/IGeneralCreditRequestManager/PutDestructGeneralCreditRequestManager
        JSON-IN{pIGeneralCreditRequestManager:45467}


 Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects

  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.

    In this context sender is used in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute

  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/ccr:request/ccr:payload)">
  • it is recommended to add the public key via a X509Data element such that a key store can be built at the recipient's site
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization

The generalCreditRequest module does obey all these conditions whenever signature is "turned on" by setting the private certificate and password of the "fromEAN" entity (cf. IGeneralCreditRequest::SetTransport). This certificate must be in the PFX format.